Linux-Fsdevel Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: Josef Bacik <josef@toxicpanda.com>,
Dan Williams <dan.j.williams@intel.com>,
dm-devel@redhat.com,
"Martin K. Petersen" <martin.petersen@oracle.com>,
linux-kernel@vger.kernel.org, linux-block@vger.kernel.org,
nbd@other.debian.org, ceph-devel@vger.kernel.org,
virtualization@lists.linux-foundation.org,
linux-raid@vger.kernel.org, linux-nvdimm@lists.01.org,
linux-nvme@lists.infradead.org, linux-scsi@vger.kernel.org,
linux-fsdevel@vger.kernel.org
Subject: remove revalidate_disk()
Date: Tue, 1 Sep 2020 17:57:39 +0200 [thread overview]
Message-ID: <20200901155748.2884-1-hch@lst.de> (raw)
Hi Jens,
this series removes the revalidate_disk() function, which has been a
really odd duck in the last years. The prime reason why most people
use it is because it propagates a size change from the gendisk to
the block_device structure. But it also calls into the rather ill
defined ->revalidate_disk method which is rather useless for the
callers. So this adds a new helper to just propagate the size, and
cleans up all kinds of mess around this area. Follow on patches
will eventuall kill of ->revalidate_disk entirely, but ther are a lot
more patches needed for that.
Diffstat:
Documentation/filesystems/locking.rst | 3 --
block/genhd.c | 9 ++----
drivers/block/nbd.c | 8 ++---
drivers/block/rbd.c | 2 -
drivers/block/rnbd/rnbd-clt.c | 10 +------
drivers/block/virtio_blk.c | 2 -
drivers/block/zram/zram_drv.c | 4 +-
drivers/md/dm-raid.c | 2 -
drivers/md/md-cluster.c | 6 ++--
drivers/md/md-linear.c | 2 -
drivers/md/md.c | 10 +++----
drivers/md/md.h | 2 -
drivers/nvdimm/blk.c | 3 --
drivers/nvdimm/btt.c | 3 --
drivers/nvdimm/bus.c | 9 ++----
drivers/nvdimm/nd.h | 2 -
drivers/nvdimm/pmem.c | 3 --
drivers/nvme/host/core.c | 16 +++++++----
drivers/scsi/sd.c | 6 ++--
fs/block_dev.c | 46 ++++++++++++++++------------------
include/linux/blk_types.h | 4 ++
include/linux/genhd.h | 6 ++--
22 files changed, 74 insertions(+), 84 deletions(-)
next reply other threads:[~2020-09-01 16:01 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-01 15:57 Christoph Hellwig [this message]
2020-09-01 15:57 ` [PATCH 1/9] Documentation/filesystems/locking.rst: remove an incorrect sentence Christoph Hellwig
2020-09-02 7:22 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 2/9] block: don't clear bd_invalidated in check_disk_size_change Christoph Hellwig
2020-09-01 15:57 ` [PATCH 3/9] block: rename bd_invalidated Christoph Hellwig
2020-09-02 7:23 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 4/9] block: add a new revalidate_disk_size helper Christoph Hellwig
2020-09-02 6:06 ` Song Liu
2020-09-02 7:23 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 5/9] block: use revalidate_disk_size in set_capacity_revalidate_and_notify Christoph Hellwig
2020-09-02 7:23 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 6/9] nvme: opencode revalidate_disk in nvme_validate_ns Christoph Hellwig
2020-09-02 7:23 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 7/9] sd: open code revalidate_disk Christoph Hellwig
2020-09-02 7:24 ` Johannes Thumshirn
2020-09-01 15:57 ` [PATCH 8/9] nvdimm: simplify revalidate_disk handling Christoph Hellwig
2020-09-01 15:57 ` [PATCH 9/9] block: remove revalidate_disk() Christoph Hellwig
2020-09-02 5:59 ` Song Liu
2020-09-02 7:25 ` Johannes Thumshirn
2020-09-01 17:45 ` Josef Bacik
2020-09-02 14:02 ` Jens Axboe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200901155748.2884-1-hch@lst.de \
--to=hch@lst.de \
--cc=axboe@kernel.dk \
--cc=ceph-devel@vger.kernel.org \
--cc=dan.j.williams@intel.com \
--cc=dm-devel@redhat.com \
--cc=josef@toxicpanda.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nvdimm@lists.01.org \
--cc=linux-nvme@lists.infradead.org \
--cc=linux-raid@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
--cc=nbd@other.debian.org \
--cc=virtualization@lists.linux-foundation.org \
--subject='Re: remove revalidate_disk()' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).