Linux-Fsdevel Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH -next] fs/proc/vmcore: Fix 'sizez' kernel-doc warning in vmcore.c
@ 2020-09-18 12:51 Wang Hai
  0 siblings, 0 replies; only message in thread
From: Wang Hai @ 2020-09-18 12:51 UTC (permalink / raw)
  To: dyoung, bhe, vgoyal, adobriyan; +Cc: kexec, linux-kernel, linux-fsdevel

Fixes the following W=1 kernel build warning(s):

fs/proc/vmcore.c:458: warning: Excess function parameter 'sizez' description in 'vmcore_alloc_buf'

Rename sizez to size.

Signed-off-by: Wang Hai <wanghai38@huawei.com>
---
 fs/proc/vmcore.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/proc/vmcore.c b/fs/proc/vmcore.c
index c3a345c28a93..bfb0aa4d63e4 100644
--- a/fs/proc/vmcore.c
+++ b/fs/proc/vmcore.c
@@ -446,7 +446,7 @@ static const struct vm_operations_struct vmcore_mmap_ops = {
 
 /**
  * vmcore_alloc_buf - allocate buffer in vmalloc memory
- * @sizez: size of buffer
+ * @size: size of buffer
  *
  * If CONFIG_MMU is defined, use vmalloc_user() to allow users to mmap
  * the buffer to user-space by means of remap_vmalloc_range().
-- 
2.17.1


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2020-09-18 12:54 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-18 12:51 [PATCH -next] fs/proc/vmcore: Fix 'sizez' kernel-doc warning in vmcore.c Wang Hai

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).