Linux-Fsdevel Archive on lore.kernel.org
help / color / mirror / Atom feed
[PATCH ghak90 V9 00/13] audit: implement container identifier
2020-07-29 19:00 UTC (4+ messages)
` [PATCH ghak90 V9 06/13] audit: add contid support for signalling the audit daemon
Inverted mount options completely broken (iversion,relatime)
2020-07-29 18:47 UTC (3+ messages)
[PATCH v1 0/4] [RFC] Implement Trampoline File Descriptor
2020-07-29 17:55 UTC (22+ messages)
` [PATCH v1 1/4] [RFC] fs/trampfd: Implement the trampoline file descriptor API
` [PATCH v1 2/4] [RFC] x86/trampfd: Provide support for the trampoline file descriptor
` [PATCH v1 3/4] [RFC] arm64/trampfd: "
` [PATCH v1 4/4] [RFC] arm/trampfd: "
mmotm 2020-07-27-18-18 uploaded
2020-07-29 17:29 UTC (15+ messages)
` mmotm 2020-07-27-18-18 uploaded (drivers/scsi/ufs/: SCSI_UFS_EXYNOS)
` mmotm 2020-07-27-18-18 uploaded (mm/page_alloc.c)
` make oldconfig (Re: mmotm 2020-07-27-18-18 uploaded (mm/page_alloc.c))
[PATCH 0/5] seqlock: Cleanups
2020-07-29 16:19 UTC (12+ messages)
` [PATCH 1/5] seqlock: s/__SEQ_LOCKDEP/__SEQ_LOCK/g
` [PATCH 2/5] seqlock: Fold seqcount_LOCKNAME_t definition
` [PATCH 3/5] seqlock: Fold seqcount_LOCKNAME_init() definition
` [PATCH 4/5] seqcount: Compress SEQCNT_LOCKNAME_ZERO()
` [PATCH 5/5] seqcount: More consistent seqprop names
[PATCH] fs: Eliminate a local variable to make the code more clear
2020-07-29 15:21 UTC
[RFC] orangefs: posix acl fix
2020-07-29 14:42 UTC
[RFC PATCH 0/5] madvise MADV_DOEXEC
2020-07-29 13:52 UTC (15+ messages)
` [RFC PATCH 3/5] mm: introduce VM_EXEC_KEEP
` [RFC PATCH 5/5] mm: introduce MADV_DOEXEC
[PATCH] fput: Allow calling __fput_sync() from !PF_KTHREAD thread
2020-07-29 13:04 UTC (2+ messages)
` [PATCH v2] "
[PATCH v3 02/10] xattr: add a function to check if a namespace is supported
2020-07-29 12:23 UTC (7+ messages)
[PATCH v2] exfat: integrates dir-entry getting and validation
2020-07-29 10:01 UTC (2+ messages)
improve compat handling for the i386 u64 alignment quirk
2020-07-29 6:08 UTC (8+ messages)
` [PATCH 2/4] compat: lift compat_s64 and compat_u64 to <linux/compat.h>
` [PATCH 2/4 v2] "
` [PATCH 4/4] quota: simplify the quotactl compat handling
[PATCH] idr: Fix a typo in idr_alloc_cyclic()'s comment
2020-07-29 4:30 UTC
[PATCH] dax: Fix wrong error-number passed into xas_set_err()
2020-07-29 3:44 UTC
[PATCH 0/3] fs: reduce export usage of kerne_read*() calls
2020-07-29 1:20 UTC (7+ messages)
[PATCH] proc/sysctl: make protected_* world readable
2020-07-29 0:03 UTC (3+ messages)
[RFC PATCH v5 00/11] Integrity Policy Enforcement LSM (IPE)
2020-07-28 23:55 UTC (20+ messages)
` [RFC PATCH v5 01/11] scripts: add ipe tooling to generate boot policy
` [RFC PATCH v5 02/11] security: add ipe lsm evaluation loop and audit system
` [RFC PATCH v5 03/11] security: add ipe lsm policy parser and policy loading
` [RFC PATCH v5 04/11] ipe: add property for trust of boot volume
` [RFC PATCH v5 05/11] fs: add security blob and hooks for block_device
` [RFC PATCH v5 06/11] dm-verity: move signature check after tree validation
` [RFC PATCH v5 07/11] dm-verity: add bdev_setsecurity hook for dm-verity signature
` [RFC PATCH v5 08/11] ipe: add property for signed dmverity volumes
` [RFC PATCH v5 09/11] dm-verity: add bdev_setsecurity hook for root-hash
` [RFC PATCH v5 10/11] documentation: add ipe documentation
` [RFC PATCH v5 10/12] ipe: add property for dmverity roothash
` [RFC PATCH v5 11/11] cleanup: uapi/linux/audit.h
` [RFC PATCH v5 11/12] documentation: add ipe documentation
` [RFC PATCH v5 12/12] cleanup: uapi/linux/audit.h
[PATCH] fuse: Add filesystem attribute in sysfs control dir
2020-07-28 23:45 UTC
[PATCH 1/4] anon_inodes: Make _anon_inode_getfile() static
2020-07-28 19:41 UTC (5+ messages)
` [PATCH 2/4] mm: swap: Fix kerneldoc of swap_vma_readahead()
` [PATCH 3/4] mm: mempolicy: Fix kerneldoc of numa_map_to_online_node()
` [PATCH 4/4] mm: mmu_notifier: Fix and extend kerneldoc
bdi cleanups v3
2020-07-28 19:20 UTC (21+ messages)
` [PATCH 02/14] drbd: remove dead code in device_to_statistics
` [PATCH 04/14] bdi: initialize ->ra_pages in bdi_init
` [PATCH 05/14] md: update the optimal I/O size on reshape
` [PATCH 06/14] block: lift setting the readahead size into the block layer
` [PATCH 10/14] bdi: remove BDI_CAP_SYNCHRONOUS_IO
` [PATCH 11/14] mm: use SWP_SYNCHRONOUS_IO more intelligently
` [PATCH 12/14] bdi: replace BDI_CAP_STABLE_WRITES with a queue and a sb flag
` [PATCH 13/14] bdi: invert BDI_CAP_NO_ACCT_WB
` [PATCH 14/14] bdi: replace BDI_CAP_NO_{WRITEBACK,ACCT_DIRTY} with a single flag
[RFC][PATCH] exec: Freeze the other threads during a multi-threaded exec
2020-07-28 18:17 UTC (7+ messages)
[PATCH] sched: Make select_idle_sibling search domain configurable
2020-07-28 17:54 UTC (5+ messages)
[RFC 0/2] Avoid indirect function calls in iomap
2020-07-28 17:32 UTC (3+ messages)
` [PATCH 1/2] iomap: Add iomap_iter
` [PATCH 2/2] iomap: Convert readahead to iomap_iter
add file system helpers that take kernel pointers for the init code v4
2020-07-28 16:59 UTC (25+ messages)
` [PATCH 01/23] fs: refactor do_mount
` [PATCH 02/23] fs: refactor ksys_umount
` [PATCH 03/23] fs: push the getname from do_rmdir into the callers
` [PATCH 04/23] devtmpfs: refactor devtmpfsd()
` [PATCH 05/23] init: initialize ramdisk_execute_command at compile time
` [PATCH 06/23] init: mark console_on_rootfs as __init
` [PATCH 07/23] init: mark create_dev "
` [PATCH 08/23] init: add an init_mount helper
` [PATCH 09/23] init: add an init_umount helper
` [PATCH 10/23] init: add an init_unlink helper
` [PATCH 11/23] init: add an init_rmdir helper
` [PATCH 12/23] init: add an init_chdir helper
` [PATCH 13/23] init: add an init_chroot helper
` [PATCH 14/23] init: add an init_chown helper
` [PATCH 15/23] init: add an init_chmod helper
` [PATCH 16/23] init: add an init_eaccess helper
` [PATCH 17/23] init: add an init_link helper
` [PATCH 18/23] init: add an init_symlink helper
` [PATCH 19/23] init: add an init_mkdir helper
` [PATCH 20/23] init: add an init_mknod helper
` [PATCH 21/23] init: add an init_stat helper
` [PATCH 22/23] init: add an init_utimes helper
` [PATCH 23/23] init: add an init_dup helper
[PATCH] /proc/PID/smaps: Consistent whitespace output format
2020-07-28 16:57 UTC (2+ messages)
[PATCH v3 0/3] io_uring: add restrictions to support untrusted applications and guests
2020-07-28 16:01 UTC (4+ messages)
` [PATCH v3 1/3] io_uring: use an enumeration for io_uring_register(2) opcodes
` [PATCH v3 2/3] io_uring: add IOURING_REGISTER_RESTRICTIONS opcode
` [PATCH v3 3/3] io_uring: allow disabling rings during the creation
[PATCH] dma-resv: lockdep-prime address_space->i_mmap_rwsem for dma-resv
2020-07-28 13:58 UTC
xattr names for unprivileged stacking?
2020-07-28 13:55 UTC (3+ messages)
[PATCH v1 0/2] proc: Relax check of mount visibility
2020-07-28 13:54 UTC (4+ messages)
` [PATCH v1 2/2] Show /proc/self/net only for CAP_NET_ADMIN
[PATCH] fs: Return EOPNOTSUPP if block layer does not support REQ_NOWAIT
2020-07-28 13:47 UTC (4+ messages)
[PATCH] iomap: Ensure iop->uptodate matches PageUptodate
2020-07-28 13:15 UTC (6+ messages)
[PATCH] fanotify: compare fsid when merging name event
2020-07-28 9:20 UTC (5+ messages)
[PATCH v4 0/6] zone-append support in io-uring and aio
2020-07-28 7:26 UTC (9+ messages)
` [PATCH v4 6/6] io_uring: add support for zone-append
` [PATCH v4 1/6] fs: introduce FMODE_ZONE_APPEND and IOCB_ZONE_APPEND
[PATCH v2] proc,fcntl: introduce F_SET_DESCRIPTION
2020-07-28 6:25 UTC (5+ messages)
` [PATCH v3] "
[PATCH AUTOSEL 5.7 07/25] io_uring: always allow drain/link/hardlink/async sqe flags
2020-07-27 23:23 UTC (2+ messages)
` [PATCH AUTOSEL 5.7 21/25] io_uring: missed req_init_async() for IOSQE_ASYNC
[PATCH 0/9] Fixes for fanotify name events
2020-07-27 21:57 UTC (12+ messages)
` [PATCH 5/9] fsnotify: simplify dir argument to handle_event()
` [PATCH 6/9] fsnotify: pass dir and inode arguments to fsnotify()
` [PATCH 7/9] fsnotify: fix merge with parent mark masks
` [PATCH 8/9] fsnotify: create method handle_inode_event() in fsnotify_operations
` [PATCH 9/9] fsnotify: pass inode to fsnotify_parent()
[PATCH RFC V2 00/17] PKS: Add Protection Keys Supervisor (PKS) support
2020-07-27 20:59 UTC (7+ messages)
` [PATCH RFC V2 17/17] x86/entry: Preserve PKRS MSR across exceptions
WARNING: ODEBUG bug in delete_node
2020-07-27 20:39 UTC (2+ messages)
[PATCH v7 0/7] Add support for O_MAYEXEC
2020-07-27 19:46 UTC (5+ messages)
` [PATCH v7 4/7] fs: Introduce O_MAYEXEC flag for openat2(2)
[QUESTION] Sharing a `struct page` across multiple `struct address_space` instances
2020-07-27 19:38 UTC (3+ messages)
[PATCH] tools/memory-model: document the "one-time init" pattern
2020-07-27 19:13 UTC (10+ messages)
[PATCH][next] binfmt_elf: fix unsigned regset0_size compared to less than zero
2020-07-27 18:43 UTC (2+ messages)
[PATCH] fs: define inode flags using bit numbers
2020-07-27 18:38 UTC (3+ messages)
[PATCH] fscrypt: don't load ->i_crypt_info before it's known to be valid
2020-07-27 17:41 UTC
[PATCH v2 0/7] mm: introduce memfd_secret system call to create "secret" memory areas
2020-07-27 17:25 UTC (3+ messages)
` [PATCH v2 4/7] arch, mm: wire up memfd_secret system call were relevant
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).