LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Paul Rolland" <rol@as2917.net>
To: "'Tejun Heo'" <htejun@gmail.com>
Cc: "'Alan'" <alan@lxorguk.ukuu.org.uk>,
	"'Robert Hancock'" <hancockr@shaw.ca>,
	"'Linux Kernel Mailing List'" <linux-kernel@vger.kernel.org>
Subject: RE: AHCI - remove probing of ata2
Date: Mon, 12 Feb 2007 12:19:24 +0100	[thread overview]
Message-ID: <00e201c74e97$a982fa70$4b00a8c0@donald> (raw)
In-Reply-To: <45CFBA90.4090201@gmail.com>

Hello Tejun,

> You have a Maxtor connected to that port, right?  That's caused by 

Waoh, you are using crystal ball ? :) You are right, this is a Maxtor
disk, 250 MB. If you want more details about this disk, I can send you
a complete details.

> firmware bug.  Future kernels will consider that condition as 
> protocol 
> violation and blacklist the drive such that NCQ is not used on it.  I 
> think it can be dangerous on rare corner/error cases but there hasn't 
> been any actual report of problems caused by that, so no need 
> to worry 
> about it too much.  If it bothers you, you can turn NCQ off 
> using sysfs 
> node.  Take a look at FAQ section of http://linux-ata.org

I'm just slightly worried about that, and because all this libata
stuff is quite "new", I prefer to report everything I can see, considering
that I can test patches on this machine if people need me to do so.
So, consider this machine as some kind of playground if you have
some code you want someone to test.
 
> Slightly OT, but it's generally a good idea to use LABELs to access 
> filesystems.  With so many ports and EH dynamics including 
> hotplug, it's 
> much more difficult to keep device names persistent and remember them.

Yes, that's what I should do, but I've never really like that stuff ;(
 
> > So, 2.6.20-rc7 results are :
> >  - ata2 probing still very long and delaying boot a lot,
> 
> That's sil4726's config device acting weird.  When reset as a normal 
> device (not PMP device), sil4726 acts as a normal ATA device which is 
> used to configure how the chip behaves.  Unfortunately, the emulation 
> seems to contain some flaws and cause lots of delays as you've seen. 
> I'm attaching a patch to clear TF before IDENTIFY which fixes similar 
> IDENTIFY failures on buggy ATAPI devices.

OK, will try this tonite (I'm sorry, this is my home comp., and I'm at the
office right now - will tell you tomorrow).
 
> >  - Jmicron PATA still not working, and doesn't even detect 
> the DVD-ROM on
> >    the port.
> 
> This problem is likely to be fixed by clearing TF before IDENTIFY.
> 
> So, please test the attached patch and report the result.

Will do, and will test more if you more that are to be tested !

BTW, maybe OT, but what about setting a list of people willing to test
patches together with their configurations so that they can be send
patches related to their hardware ? That could be useful to people developing
drivers...

Regards,
Paul


  reply	other threads:[~2007-02-12 11:20 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <fa.R5BFxVmVJj5OnAPGQI7410dt/fA@ifi.uio.no>
2007-02-10 17:20 ` Robert Hancock
2007-02-10 17:32   ` Paul Rolland
2007-02-10 18:39     ` Paul Rolland
2007-02-10 19:06       ` Alan
2007-02-10 20:01         ` Paul Rolland
2007-02-10 20:36           ` Alan
2007-02-10 21:59             ` Paul Rolland
2007-02-11 10:17               ` Paul Rolland
2007-02-12  0:53                 ` Tejun Heo
2007-02-12 11:19                   ` Paul Rolland [this message]
2007-02-13  7:33                     ` Paul Rolland
2007-02-13 20:20                       ` Tejun Heo
2007-02-14  0:56 Greg Trounson
2007-02-14 17:47 ` Bill Davidsen
2007-02-14 21:43   ` Greg Trounson
2007-04-01 14:19 ` Håkan Lindqvist
  -- strict thread matches above, loose matches on Subject: below --
2007-02-10 14:24 Paul Rolland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='00e201c74e97$a982fa70$4b00a8c0@donald' \
    --to=rol@as2917.net \
    --cc=alan@lxorguk.ukuu.org.uk \
    --cc=hancockr@shaw.ca \
    --cc=htejun@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --subject='RE: AHCI - remove probing of ata2' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).