LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Jurgen Kramer <gtm.kramer@inter.nl.net>
To: linux-kernel@vger.kernel.org
Subject: Re: ACPI problems with 2.6.6
Date: Sat, 15 May 2004 11:21:47 +0200	[thread overview]
Message-ID: <1084612906.29632.5.camel@paragon.slim> (raw)
In-Reply-To: <200405150401.44686.dj@david-web.co.uk>

On Sat, 2004-05-15 at 05:01, David Johnson wrote:
> Hi,
> 
> I've got some serious strangeness being caused by ACPI on 2.6.6.
> 
> 2.6.3 works perfectly on the same machine. I don't use any acpi option on the 
> kernel command line so it's just using the default options.
> 
> The first problem is that a strange device appears as eth0:
> 
> eth0      Link encap:UNSPEC  HWaddr 
> 00-90-F5-00-00-22-91-25-00-00-00-00-00-00-00-00
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
> 
> It seems to be some incarnation of the real ethernet adaptor, but even when I 
> manually configure it it is unable to actually talk to the network.
> I can configure the real ethernet adaptor (8139too) as eth1 with no problems.
> 
> Also, for some reason the loopback device is not added to the routing table 
> which in turn causes a stack more problems.
> Lots of other stuff also doesn't work including X.
> 
> But if I boot 2.6.3 or set acpi=off for 2.6.6 everything works perfectly. The 
> same problems exist in 2.6.5 but I haven't tried 2.6.4.
> 
> I've attached my dmesg and .config - let me know what else is needed.
> 
> Thanks,
> David.
This is not a ACPI problem. Here's the culprit:

CONFIG_IEEE1394_ETH1394=m

The IEEE1394 ethernet module is loaded and is now eth0. Tell tail sings
are the long MAC address and the Link encap. which is set to
unspecified.

Jurgen



  reply	other threads:[~2004-05-15  9:14 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-05-15  3:01 David Johnson
2004-05-15  9:21 ` Jurgen Kramer [this message]
2004-05-17 22:21   ` Bill Davidsen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1084612906.29632.5.camel@paragon.slim \
    --to=gtm.kramer@inter.nl.net \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: ACPI problems with 2.6.6' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).