LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* Re: nvidia not working on 2.6.6-bk5+ (x86-64) ?
@ 2004-05-22 19:42 Bob Gill
  0 siblings, 0 replies; 3+ messages in thread
From: Bob Gill @ 2004-05-22 19:42 UTC (permalink / raw)
  To: Linux Kernel Mailing List

Ok.  In general LKML is for Linux kernel goodness, and since NVIDIA is a
private binary-only driver, most people would prefer you post the bug on
an NVIDIA list.  But, having already started this post... you might
check to see if RHGB is on your kernel boot line.  I am running FC2 but
noticed that even test versions of FC (with non-standard/more modern
kernels) will kill the X server if you use the RedHat graphical boot
(rhgb) on the kernel line.  In my case, I would get the nvidia splash
screen, and the graphical boot window showing the system booting,
followed by a crash when the system tried to start X. I would get a
white screen and no response where the graphical greeter/login is
supposed to be.  Getting rid of rhgb got rid of the problem.  I suspect
a race between X wanting to start and rhgb wanting to stop (and not all
data structures are free yet).  I don't think this problem is related to
the transition between XFree86 and X.org.  If this 'fix' doesn't apply
to you, please ignore it.
Thanks,

Bob


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: nvidia not working on 2.6.6-bk5+ (x86-64) ?
  2004-05-22 14:08 thomas weidner
@ 2004-05-27 21:45 ` Sven Köhler
  0 siblings, 0 replies; 3+ messages in thread
From: Sven Köhler @ 2004-05-27 21:45 UTC (permalink / raw)
  To: linux-kernel

> the nvidia driver works fine on 2.6.6 but causes x to freeze on startup
> with 2.6.6-bk5+ (haven't tried -bk[1234]). the nv driver works. i first
> thought of the 4kstacks issue,but they are i386 only and the patch doesn't
> affect x86-64. any ideas what might break nvidia?

i have the same problem with 2.6.7-rc1. 2.6.6 works fine. (both kernels 
without any patches)



^ permalink raw reply	[flat|nested] 3+ messages in thread

* nvidia not working on 2.6.6-bk5+ (x86-64) ?
@ 2004-05-22 14:08 thomas weidner
  2004-05-27 21:45 ` Sven Köhler
  0 siblings, 1 reply; 3+ messages in thread
From: thomas weidner @ 2004-05-22 14:08 UTC (permalink / raw)
  To: linux-kernel

Hi,

the nvidia driver works fine on 2.6.6 but causes x to freeze on startup
with 2.6.6-bk5+ (haven't tried -bk[1234]). the nv driver works. i first
thought of the 4kstacks issue,but they are i386 only and the patch doesn't
affect x86-64. any ideas what might break nvidia?


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2004-05-27 21:46 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2004-05-22 19:42 nvidia not working on 2.6.6-bk5+ (x86-64) ? Bob Gill
  -- strict thread matches above, loose matches on Subject: below --
2004-05-22 14:08 thomas weidner
2004-05-27 21:45 ` Sven Köhler

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).