LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* BUG, 2.6.20-rc3 raid autodetection
@ 2007-01-04 18:47 Kasper Sandberg
  2007-01-04 19:07 ` Bartlomiej Zolnierkiewicz
  0 siblings, 1 reply; 5+ messages in thread
From: Kasper Sandberg @ 2007-01-04 18:47 UTC (permalink / raw)
  To: LKML Mailinglist

Hello.

i just attempted to test .20-rc3-git4 on a box, which has 6 drives in
raid5. it uses raid autodetection, and 2 ide controllers (via and
promise 20269).

there are two problems.

first, and most importantly, it doesent autodetect, i attempted with
both the old ide drivers, and the new pata on libata drivers, the drives
appears to be found, but the raid autoassembling just doesent happen.

this is .17, which works:
http://sh.nu/p/8001

this is .20-rc3-git4 which doesent work, in pata-on-libata mode:
http://sh.nu/p/8000

this is .20-rc3-git4 which doesent work, in old ide mode:
http://sh.nu/p/8002


second bug:
notice on these pastes the lines at bottom, the keyboard stuff, these
are repeated constantly, and caps/scrolllock button on keyboard is
blinking.


mvh.
Kasper Sandberg


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: BUG, 2.6.20-rc3 raid autodetection
  2007-01-04 18:47 BUG, 2.6.20-rc3 raid autodetection Kasper Sandberg
@ 2007-01-04 19:07 ` Bartlomiej Zolnierkiewicz
  2007-01-04 19:57   ` Kasper Sandberg
  0 siblings, 1 reply; 5+ messages in thread
From: Bartlomiej Zolnierkiewicz @ 2007-01-04 19:07 UTC (permalink / raw)
  To: Kasper Sandberg; +Cc: LKML Mailinglist

On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> Hello.
>
> i just attempted to test .20-rc3-git4 on a box, which has 6 drives in
> raid5. it uses raid autodetection, and 2 ide controllers (via and
> promise 20269).
>
> there are two problems.
>
> first, and most importantly, it doesent autodetect, i attempted with
> both the old ide drivers, and the new pata on libata drivers, the drives
> appears to be found, but the raid autoassembling just doesent happen.
>
> this is .17, which works:
> http://sh.nu/p/8001
>
> this is .20-rc3-git4 which doesent work, in pata-on-libata mode:
> http://sh.nu/p/8000
>
> this is .20-rc3-git4 which doesent work, in old ide mode:
> http://sh.nu/p/8002

For some reason IDE disk driver is not claiming IDE devices.

Could you please double check that IDE disk driver is built-in
(CONFIG_BLK_DEV_IDEDISK=y in the kernel configuration)
and not compiled as module?

Bart

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: BUG, 2.6.20-rc3 raid autodetection
  2007-01-04 19:07 ` Bartlomiej Zolnierkiewicz
@ 2007-01-04 19:57   ` Kasper Sandberg
       [not found]     ` <58cb370e0701041207s5c2e3e26j434dd7fe6809e50b@mail.gmail.com>
  0 siblings, 1 reply; 5+ messages in thread
From: Kasper Sandberg @ 2007-01-04 19:57 UTC (permalink / raw)
  To: Bartlomiej Zolnierkiewicz; +Cc: LKML Mailinglist

On Thu, 2007-01-04 at 20:07 +0100, Bartlomiej Zolnierkiewicz wrote:
> On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > Hello.
> >
> > i just attempted to test .20-rc3-git4 on a box, which has 6 drives in
> > raid5. it uses raid autodetection, and 2 ide controllers (via and
> > promise 20269).
> >
> > there are two problems.
> >
> > first, and most importantly, it doesent autodetect, i attempted with
> > both the old ide drivers, and the new pata on libata drivers, the drives
> > appears to be found, but the raid autoassembling just doesent happen.
> >
> > this is .17, which works:
> > http://sh.nu/p/8001
> >
> > this is .20-rc3-git4 which doesent work, in pata-on-libata mode:
> > http://sh.nu/p/8000
> >
> > this is .20-rc3-git4 which doesent work, in old ide mode:
> > http://sh.nu/p/8002
> 
> For some reason IDE disk driver is not claiming IDE devices.
> 
> Could you please double check that IDE disk driver is built-in
> (CONFIG_BLK_DEV_IDEDISK=y in the kernel configuration)
> and not compiled as module?
i need not check even once, i do not have module support enabled, so
everything 1000000% surely is built in. this is the case for .17 too
(and earlier, this box was started with .15 i think.)

> 
> Bart
> 


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: BUG, 2.6.20-rc3 raid autodetection [repost due to forgotten CC]
       [not found]           ` <1167947115.8595.6.camel@localhost>
@ 2007-01-04 22:06             ` Redeeman
       [not found]             ` <58cb370e0701041405l38641d97jba652ba6645c0d08@mail.gmail.com>
  1 sibling, 0 replies; 5+ messages in thread
From: Redeeman @ 2007-01-04 22:06 UTC (permalink / raw)
  To: Bartlomiej Zolnierkiewicz; +Cc: LKML Mailinglist

On Thu, 2007-01-04 at 22:45 +0100, Kasper Sandberg wrote:
> On Thu, 2007-01-04 at 22:06 +0100, Bartlomiej Zolnierkiewicz wrote:
> > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > On Thu, 2007-01-04 at 21:07 +0100, Bartlomiej Zolnierkiewicz wrote:
> > > > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > > > On Thu, 2007-01-04 at 20:07 +0100, Bartlomiej Zolnierkiewicz wrote:
> > > > > > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > > > > > Hello.
> > > > > > >
> > > > > > > i just attempted to test .20-rc3-git4 on a box, which has 6 drives in
> > > > > > > raid5. it uses raid autodetection, and 2 ide controllers (via and
> > > > > > > promise 20269).
> > > > > > >
> > > > > > > there are two problems.
> > > > > > >
> > > > > > > first, and most importantly, it doesent autodetect, i attempted with
> > > > > > > both the old ide drivers, and the new pata on libata drivers, the drives
> > > > > > > appears to be found, but the raid autoassembling just doesent happen.
> > > > > > >
> > > > > > > this is .17, which works:
> > > > > > > http://sh.nu/p/8001
> > > > > > >
> > > > > > > this is .20-rc3-git4 which doesent work, in pata-on-libata mode:
> > > > > > > http://sh.nu/p/8000
> > > > > > >
> > > > > > > this is .20-rc3-git4 which doesent work, in old ide mode:
> > > > > > > http://sh.nu/p/8002
> > > > > >
> > > > > > For some reason IDE disk driver is not claiming IDE devices.
> > > > > >
> > > > > > Could you please double check that IDE disk driver is built-in
> > > > > > (CONFIG_BLK_DEV_IDEDISK=y in the kernel configuration)
> > > > > > and not compiled as module?
> > > > > i need not check even once, i do not have module support enabled, so
> > > >
> > > > OK
> > > >
> > > > > everything 1000000% surely is built in. this is the case for .17 too
> > > > > (and earlier, this box was started with .15 i think.)
> > > >
> > > > Could you send me your config?
> > > > I'll try to reproduce this locally.
> > > sure thing.
> > >
> > > http://sh.nu/p/8004 <-- .17 working
> > 
> > CONFIG_BLK_DEV_IDEDISK=y
> > 
> > > http://sh.nu/p/8005 <-- .20-rc3-git4 nonworking, idemode, the one with
> > > libata i dont have anymore, but the only difference is that i use the
> > > libata drivers, but as its same result, shouldnt matter
> > 
> > # CONFIG_BLK_DEV_IDEDISK is not set
> > 
> > so not everything is "1000000% surely" built-in ;)
> i see your point, im afraid i may have misinterpreted you, since you
> said "and not compiled as module", so i thought you meant i had to make
> sure it wasnt moduled only.
> 
> i will try with this now, what about pataonlibata, do i need this for
> that too?
> > 
> > Bart
> > 
-- 
Redeeman <redeeman@metanurb.dk>


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: BUG, 2.6.20-rc3 raid autodetection
       [not found]             ` <58cb370e0701041405l38641d97jba652ba6645c0d08@mail.gmail.com>
@ 2007-01-04 22:08               ` Kasper Sandberg
  0 siblings, 0 replies; 5+ messages in thread
From: Kasper Sandberg @ 2007-01-04 22:08 UTC (permalink / raw)
  To: Bartlomiej Zolnierkiewicz, LKML Mailinglist

On Thu, 2007-01-04 at 23:05 +0100, Bartlomiej Zolnierkiewicz wrote:
> On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > On Thu, 2007-01-04 at 22:06 +0100, Bartlomiej Zolnierkiewicz wrote:
> > > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > > On Thu, 2007-01-04 at 21:07 +0100, Bartlomiej Zolnierkiewicz wrote:
> > > > > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > > > > On Thu, 2007-01-04 at 20:07 +0100, Bartlomiej Zolnierkiewicz wrote:
> > > > > > > On 1/4/07, Kasper Sandberg <lkml@metanurb.dk> wrote:
> > > > > > > > Hello.
> > > > > > > >
> > > > > > > > i just attempted to test .20-rc3-git4 on a box, which has 6 drives in
> > > > > > > > raid5. it uses raid autodetection, and 2 ide controllers (via and
> > > > > > > > promise 20269).
> > > > > > > >
> > > > > > > > there are two problems.
> > > > > > > >
> > > > > > > > first, and most importantly, it doesent autodetect, i attempted with
> > > > > > > > both the old ide drivers, and the new pata on libata drivers, the drives
> > > > > > > > appears to be found, but the raid autoassembling just doesent happen.
> > > > > > > >
> > > > > > > > this is .17, which works:
> > > > > > > > http://sh.nu/p/8001
> > > > > > > >
> > > > > > > > this is .20-rc3-git4 which doesent work, in pata-on-libata mode:
> > > > > > > > http://sh.nu/p/8000
> > > > > > > >
> > > > > > > > this is .20-rc3-git4 which doesent work, in old ide mode:
> > > > > > > > http://sh.nu/p/8002
> > > > > > >
> > > > > > > For some reason IDE disk driver is not claiming IDE devices.
> > > > > > >
> > > > > > > Could you please double check that IDE disk driver is built-in
> > > > > > > (CONFIG_BLK_DEV_IDEDISK=y in the kernel configuration)
> > > > > > > and not compiled as module?
> > > > > > i need not check even once, i do not have module support enabled, so
> > > > >
> > > > > OK
> > > > >
> > > > > > everything 1000000% surely is built in. this is the case for .17 too
> > > > > > (and earlier, this box was started with .15 i think.)
> > > > >
> > > > > Could you send me your config?
> > > > > I'll try to reproduce this locally.
> > > > sure thing.
> > > >
> > > > http://sh.nu/p/8004 <-- .17 working
> > >
> > > CONFIG_BLK_DEV_IDEDISK=y
> > >
> > > > http://sh.nu/p/8005 <-- .20-rc3-git4 nonworking, idemode, the one with
> > > > libata i dont have anymore, but the only difference is that i use the
> > > > libata drivers, but as its same result, shouldnt matter
> > >
> > > # CONFIG_BLK_DEV_IDEDISK is not set
> > >
> > > so not everything is "1000000% surely" built-in ;)
> > i see your point, im afraid i may have misinterpreted you, since you
> > said "and not compiled as module", so i thought you meant i had to make
> > sure it wasnt moduled only.
> 
> You were right - I forgot about "CONFIG_BLK_DEV_IDEDISK=n" case.
> 
> > i will try with this now, what about pataonlibata, do i need this for
> 
> Please report if this fixes the issue.
yeah it did.
> 
> > that too?
> 
> for libata you need SCSI disk driver: CONFIG_BLK_DEV_SD=y
> 
> [ libata is not independent subsystem like IDE but depends on SCSI,
>   and I really don't know why this is not mentioned in config help ]
i knew that, i just thought it may select what it required, though i can
see that it isnt strictly required, just what one wishes often. :)

thanks for your help, will try with libata now.
> 


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2007-01-04 22:37 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-01-04 18:47 BUG, 2.6.20-rc3 raid autodetection Kasper Sandberg
2007-01-04 19:07 ` Bartlomiej Zolnierkiewicz
2007-01-04 19:57   ` Kasper Sandberg
     [not found]     ` <58cb370e0701041207s5c2e3e26j434dd7fe6809e50b@mail.gmail.com>
     [not found]       ` <1167944429.8595.3.camel@localhost>
     [not found]         ` <58cb370e0701041306w5c99c974j1137883b7b95a8@mail.gmail.com>
     [not found]           ` <1167947115.8595.6.camel@localhost>
2007-01-04 22:06             ` BUG, 2.6.20-rc3 raid autodetection [repost due to forgotten CC] Redeeman
     [not found]             ` <58cb370e0701041405l38641d97jba652ba6645c0d08@mail.gmail.com>
2007-01-04 22:08               ` BUG, 2.6.20-rc3 raid autodetection Kasper Sandberg

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).