LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: marcin.slusarz@gmail.com
To: LKML <linux-kernel@vger.kernel.org>
Cc: Marcin Slusarz <marcin.slusarz@gmail.com>,
Jan Kara <jack@suse.cz>, Christoph Hellwig <hch@infradead.org>
Subject: [PATCH 10/16] udf: create common function for changing free space counter
Date: Thu, 10 Jan 2008 23:06:26 +0100 [thread overview]
Message-ID: <1200002792-8449-11-git-send-email-marcin.slusarz@gmail.com> (raw)
In-Reply-To: <1200002792-8449-1-git-send-email-marcin.slusarz@gmail.com>
Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
CC: Jan Kara <jack@suse.cz>
CC: Christoph Hellwig <hch@infradead.org>
---
fs/udf/balloc.c | 49 ++++++++++++++++++++-----------------------------
1 files changed, 20 insertions(+), 29 deletions(-)
diff --git a/fs/udf/balloc.c b/fs/udf/balloc.c
index dc9f8a9..78dbf1d 100644
--- a/fs/udf/balloc.c
+++ b/fs/udf/balloc.c
@@ -140,6 +140,20 @@ static inline int load_block_bitmap(struct super_block *sb,
return slot;
}
+static bool udf_inc_free_space(struct udf_sb_info *sbi,
+ u16 partition, u32 cnt)
+{
+ struct logicalVolIntegrityDesc *lvid;
+
+ if (sbi->s_lvid_bh)
+ return false;
+
+ lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
+ lvid->freeSpaceTable[partition] = cpu_to_le32(le32_to_cpu(
+ lvid->freeSpaceTable[partition]) + cnt);
+ return true;
+}
+
static void udf_bitmap_free_blocks(struct super_block *sb,
struct inode *inode,
struct udf_bitmap *bitmap,
@@ -194,11 +208,7 @@ do_more:
} else {
if (inode)
DQUOT_FREE_BLOCK(inode, 1);
- if (sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[sbi->s_partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[sbi->s_partition]) + 1);
- }
+ udf_inc_free_space(sbi, sbi->s_partition, 1);
}
}
mark_buffer_dirty(bh);
@@ -268,12 +278,8 @@ repeat:
if (block_count > 0)
goto repeat;
out:
- if (sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[partition]) - alloc_count);
+ if (udf_inc_free_space(sbi, partition, -alloc_count))
mark_buffer_dirty(sbi->s_lvid_bh);
- }
sb->s_dirt = 1;
mutex_unlock(&sbi->s_alloc_mutex);
return alloc_count;
@@ -404,12 +410,8 @@ got_block:
mark_buffer_dirty(bh);
- if (sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[partition]) - 1);
+ if (udf_inc_free_space(sbi, partition, -1))
mark_buffer_dirty(sbi->s_lvid_bh);
- }
sb->s_dirt = 1;
mutex_unlock(&sbi->s_alloc_mutex);
*err = 0;
@@ -450,12 +452,8 @@ static void udf_table_free_blocks(struct super_block *sb,
could occure, but.. oh well */
if (inode)
DQUOT_FREE_BLOCK(inode, count);
- if (sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[sbi->s_partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[sbi->s_partition]) + count);
+ if (udf_inc_free_space(sbi, sbi->s_partition, count))
mark_buffer_dirty(sbi->s_lvid_bh);
- }
start = bloc.logicalBlockNum + offset;
end = bloc.logicalBlockNum + offset + count - 1;
@@ -719,10 +717,7 @@ static int udf_table_prealloc_blocks(struct super_block *sb,
brelse(epos.bh);
- if (alloc_count && sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[partition]) - alloc_count);
+ if (alloc_count && udf_inc_free_space(sbi, partition, -alloc_count)) {
mark_buffer_dirty(sbi->s_lvid_bh);
sb->s_dirt = 1;
}
@@ -822,12 +817,8 @@ static int udf_table_new_block(struct super_block *sb,
udf_delete_aext(table, goal_epos, goal_eloc, goal_elen);
brelse(goal_epos.bh);
- if (sbi->s_lvid_bh) {
- struct logicalVolIntegrityDesc *lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
- lvid->freeSpaceTable[partition] =
- cpu_to_le32(le32_to_cpu(lvid->freeSpaceTable[partition]) - 1);
+ if (udf_inc_free_space(sbi, partition, -1))
mark_buffer_dirty(sbi->s_lvid_bh);
- }
sb->s_dirt = 1;
mutex_unlock(&sbi->s_alloc_mutex);
--
1.5.3.7
next prev parent reply other threads:[~2008-01-10 22:09 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04 ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14 ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15 ` Jan Kara
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` [PATCH 08/16] udf: fix coding style marcin.slusarz
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19 ` Jan Kara
2008-01-10 22:06 ` marcin.slusarz [this message]
2008-01-10 23:24 ` [PATCH 10/16] udf: create common function for changing free space counter Jan Kara
2008-01-12 13:13 ` Marcin Slusarz
2008-01-14 9:56 ` Jan Kara
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26 ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28 ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30 ` Jan Kara
2008-01-11 9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1200002792-8449-11-git-send-email-marcin.slusarz@gmail.com \
--to=marcin.slusarz@gmail.com \
--cc=hch@infradead.org \
--cc=jack@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--subject='Re: [PATCH 10/16] udf: create common function for changing free space counter' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).