LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH 00/16] udf: cleanup
@ 2008-01-10 22:06 marcin.slusarz
  2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
                   ` (16 more replies)
  0 siblings, 17 replies; 28+ messages in thread
From: marcin.slusarz @ 2008-01-10 22:06 UTC (permalink / raw)
  To: LKML; +Cc: Marcin Slusarz

Hi

This patchset contains various UDF fs cleanups.
It deprecates two patchsets I sent lately:

http://lkml.org/lkml/2008/1/5/196 [PATCH 0/6] udf: improve code related to super_block v3
http://lkml.org/lkml/2008/1/5/211 [PATCH 0/7] udf: more cleanups

I hope I addressed all comments sent by Christoph Hellwig and Jan Kara.
Thanks for review!

[PATCH 01/16] udf: fix coding style of super.c
[PATCH 02/16] udf: remove some ugly macros
[PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function
[PATCH 04/16] udf: check if udf_load_logicalvol failed
[PATCH 05/16] udf: convert macros related to bitmaps to functions
[PATCH 06/16] udf: move calculating of nr_groups into helper function
[PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition)
[PATCH 08/16] udf: fix coding style
[PATCH 09/16] udf: create common function for tag checksumming
[PATCH 10/16] udf: create common function for changing free space counter
[PATCH 11/16] udf: replace loops coded with goto to real loops
[PATCH 12/16] udf: convert byte order of constant instead of variable
[PATCH 13/16] udf: remove UDF_I_* macros and open code them
[PATCH 14/16] udf: cache struct udf_inode_info

These patches are new:
[PATCH 15/16] udf: fix udf_debug macro
[PATCH 16/16] udf: improve readability of udf_load_partition

 fs/udf/balloc.c           |  491 ++++++++++++---------
 fs/udf/crc.c              |    2 +-
 fs/udf/dir.c              |    8 +-
 fs/udf/directory.c        |   94 +++--
 fs/udf/file.c             |   43 ++-
 fs/udf/ialloc.c           |   94 +++--
 fs/udf/inode.c            |  957 +++++++++++++++++++++++-----------------
 fs/udf/misc.c             |  146 ++++---
 fs/udf/namei.c            |  413 ++++++++++-------
 fs/udf/partition.c        |  197 ++++++---
 fs/udf/super.c            | 1081 ++++++++++++++++++++++++++++-----------------
 fs/udf/symlink.c          |    9 +-
 fs/udf/truncate.c         |  100 +++--
 fs/udf/udf_i.h            |   16 -
 fs/udf/udf_sb.h           |   88 +----
 fs/udf/udfdecl.h          |   11 +-
 fs/udf/udftime.c          |   59 ++--
 fs/udf/unicode.c          |   85 ++--
 include/linux/udf_fs.h    |    4 +-
 include/linux/udf_fs_sb.h |   12 +-
 20 files changed, 2261 insertions(+), 1649 deletions(-)

This patchset depends on udf patches in -mm.
Runtime tested: mount, open, read, seek, close, unmount.

Marcin Slusarz

^ permalink raw reply	[flat|nested] 28+ messages in thread

end of thread, other threads:[~2008-01-14  9:57 UTC | newest]

Thread overview: 28+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04   ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14   ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15   ` Jan Kara
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` [PATCH 08/16] udf: fix coding style marcin.slusarz
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19   ` Jan Kara
2008-01-10 22:06 ` [PATCH 10/16] udf: create common function for changing free space counter marcin.slusarz
2008-01-10 23:24   ` Jan Kara
2008-01-12 13:13     ` Marcin Slusarz
2008-01-14  9:56       ` Jan Kara
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26   ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28   ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30   ` Jan Kara
2008-01-11  9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).