LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: marcin.slusarz@gmail.com
To: LKML <linux-kernel@vger.kernel.org>
Cc: Marcin Slusarz <marcin.slusarz@gmail.com>
Subject: [PATCH 08/16] udf: fix coding style
Date: Thu, 10 Jan 2008 23:06:24 +0100	[thread overview]
Message-ID: <1200002792-8449-9-git-send-email-marcin.slusarz@gmail.com> (raw)
In-Reply-To: <1200002792-8449-1-git-send-email-marcin.slusarz@gmail.com>

fix coding style errors found by checkpatch:
- assignments in if conditions
- braces {} around single statement blocks
- no spaces after commas
- printks without KERN_*
- lines longer than 80 characters
- spaces between "type *" and variable name

before: 192 errors, 561 warnings, 8987 lines checked
after: 1 errors, 38 warnings, 9468 lines checked

Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
---
 fs/udf/balloc.c    |  231 +++++++++++-------
 fs/udf/crc.c       |    2 +-
 fs/udf/directory.c |   83 ++++---
 fs/udf/file.c      |   18 +-
 fs/udf/ialloc.c    |   24 ++-
 fs/udf/inode.c     |  665 +++++++++++++++++++++++++++++++---------------------
 fs/udf/misc.c      |   76 ++++---
 fs/udf/namei.c     |  298 ++++++++++++++----------
 fs/udf/partition.c |  160 ++++++++-----
 fs/udf/super.c     |  383 +++++++++++++++++++-----------
 fs/udf/symlink.c   |    3 +-
 fs/udf/truncate.c  |   58 +++--
 fs/udf/udftime.c   |   59 +++---
 fs/udf/unicode.c   |   85 ++++---
 14 files changed, 1311 insertions(+), 834 deletions(-)

patch (160kB) available at: http://www.kadu.net/~joi/kernel/2008.01.10/0008-udf-fix-coding-style.patch
md5: 00816fa02cf2541bee51e71a05d9dd94

Tell me if I should post it to LKML...

  parent reply	other threads:[~2008-01-10 22:08 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04   ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14   ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15   ` Jan Kara
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` marcin.slusarz [this message]
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19   ` Jan Kara
2008-01-10 22:06 ` [PATCH 10/16] udf: create common function for changing free space counter marcin.slusarz
2008-01-10 23:24   ` Jan Kara
2008-01-12 13:13     ` Marcin Slusarz
2008-01-14  9:56       ` Jan Kara
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26   ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28   ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30   ` Jan Kara
2008-01-11  9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1200002792-8449-9-git-send-email-marcin.slusarz@gmail.com \
    --to=marcin.slusarz@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: [PATCH 08/16] udf: fix coding style' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).