From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753501AbbBXRmE (ORCPT ); Tue, 24 Feb 2015 12:42:04 -0500 Received: from mail-we0-f175.google.com ([74.125.82.175]:38986 "EHLO mail-we0-f175.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753346AbbBXRmC (ORCPT ); Tue, 24 Feb 2015 12:42:02 -0500 From: Bartosz Golaszewski To: LKML Cc: Guenter Roeck , Jean Delvare , lm-sensors , Bartosz Golaszewski Subject: [PATCH 0/4] find_closest() macro Date: Tue, 24 Feb 2015 18:42:10 +0100 Message-Id: <1424799734-2170-1-git-send-email-bgolaszewski@baylibre.com> X-Mailer: git-send-email 2.1.4 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This series proposes to unduplicate the code used to find the member in an array closest to 'x'. The first patch adds a macro implementing the algorithm in two flavors - for arrays sorted in ascending and descending order. Other three patches replace duplicated code with calls to one of these macros in some hwmon drivers. Bartosz Golaszewski (4): kernel.h: add find_closest() macro hwmon: (ina2xx) replace ina226_avg_bits() with find_closest() hwmon: (lm85) replace XXX_TO_REG() functions with find_closest() hwmon: (w83795) use find_closest_desc() in pwm_freq_to_reg() drivers/hwmon/ina2xx.c | 16 ++-------------- drivers/hwmon/lm85.c | 43 ++++++++++++------------------------------- drivers/hwmon/w83795.c | 7 ++----- include/linux/kernel.h | 23 +++++++++++++++++++++++ 4 files changed, 39 insertions(+), 50 deletions(-) -- 2.1.4