LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Ivan T. Ivanov" <ivan.ivanov@linaro.org>
To: Chanwoo Choi <cw00.choi@samsung.com>
Cc: Roger Quadros <rogerq@ti.com>,
myungjoo.ham@samsung.com, balbi@ti.com, tony@atomide.com,
nsekhar@ti.com, devicetree@vger.kernel.org,
linux-usb@vger.kernel.org, linux-omap@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 1/1] extcon: usb-gpio: Introduce gpio usb extcon driver
Date: Tue, 17 Mar 2015 09:52:18 +0200 [thread overview]
Message-ID: <1426578738.2330.18.camel@linaro.org> (raw)
In-Reply-To: <55078B0F.1040800@samsung.com>
Hi,
On Tue, 2015-03-17 at 11:01 +0900, Chanwoo Choi wrote:
> Hi Ivan,
>
> On 03/16/2015 11:23 PM, Ivan T. Ivanov wrote:
> > Hi Roger,
> >
> > On Mon, 2015-03-16 at 15:11 +0200, Roger Quadros wrote:
> > > Hi Ivan,
> > >
> > > On 16/03/15 14:32, Ivan T. Ivanov wrote:
> > > > Hi,
> > > >
> > > > On Mon, 2015-02-02 at 12:21 +0200, Roger Quadros wrote:
> > > > > This driver observes the USB ID pin connected over a GPIO and
> > > > > updates the USB cable extcon states accordingly.
> > > > >
> > > > > The existing GPIO extcon driver is not suitable for this purpose
> > > > > as it needs to be taught to understand USB cable states and it
> > > > > can't handle more than one cable per instance.
> > > > >
> > > > > For the USB case we need to handle 2 cable states.
> > > > > 1) USB (attach/detach)
> > > > > 2) USB-HOST (attach/detach)
> > > > >
> > > > > This driver can be easily updated in the future to handle VBUS
> > > > > events in case it happens to be available on GPIO for any platform.
> > > > >
> > > > > Signed-off-by: Roger Quadros <rogerq@ti.com>
> > > > > ---
> > > > > v4:
> > > > > - got rid of id_irqwake flag. Fail if enable/disable_irq_wake() fails
> > > > > - changed host cable name to "USB-HOST"
> > > >
> > > > I am sorry that I am getting a bit little late into this.
> > > >
> > > > Isn't supposed that we have to use strings defined in
> > > > const char extcon_cable_name[][]?
> > > >
> > > >
> > > > > +
> > > > > +/* List of detectable cables */
> > > > > +enum {
> > > > > + EXTCON_CABLE_USB = 0,
> > > > > + EXTCON_CABLE_USB_HOST,
> > > > > +
> > > >
> > > > Same here: duplicated with enum extcon_cable_name
> > > >
> > > > > + EXTCON_CABLE_END,
> > > > > +};
> > > > > +
> > > > > +static const char *usb_extcon_cable[] = {
> > > > > + [EXTCON_CABLE_USB] = "USB",
> > > > > + [EXTCON_CABLE_USB_HOST] = "USB-HOST",
> > > > > + NULL,
> > > > > +};
> > >
> > > I'm not exactly sure how else it is supposed to work if we
> > > support only a subset of cables from the global extcon_cable_name[][].
> >
> > I don't see issue that we use just 2 events. I think that we can
> > reuse enum extcon_cable_name
Now I see that extcon_dev_register() expect NULL terminated array of
pointers, so it will not be possible to use enum extcon_cable_name
as index in the above array, sorry.
> > and strings already defined in
> > extcon_cable_name[][] global variable. It is defined extern in
> > extcon.h file exactly for this purpose, no?
>
> 'extcon_cable_name' global variable is not used on extcon driver directly.
> It is just recommended cable name.
Hm, this is what bothers me. How client drivers will know cable name if
every provider start using its own naming scheme?
If I write client driver I will use:
extcon_register_interest(obj, name, extcon_cable_name[EXTCON_USB_HOST], nb);
and this will now work with this driver because it define string differently.
... Well, I see that string is changed because your recommendation :-),
then lets fix extcon_cable_name strings and not let drivers define its own
names.
> I have plan to use standard cable name for extcon driver instead of that
> each extcon driver define the cable name.
>
Sound like a good plan :-)
Regards,
Ivan
next prev parent reply other threads:[~2015-03-17 7:52 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-01-26 12:15 [PATCH v2 0/7] extcon: usb: Introduce USB GPIO extcon driver. Fix DRA7 & AM57xx USB Roger Quadros
2015-01-26 12:15 ` [PATCH v2 1/7] extcon: usb-gpio: Introduce gpio usb extcon driver Roger Quadros
2015-01-26 13:56 ` Chanwoo Choi
2015-01-26 16:27 ` Roger Quadros
2015-01-27 1:54 ` Chanwoo Choi
2015-01-27 15:38 ` Roger Quadros
2015-01-28 2:19 ` Chanwoo Choi
2015-01-28 12:12 ` Roger Quadros
2015-01-28 17:09 ` Tony Lindgren
2015-01-29 11:31 ` Roger Quadros
2015-01-29 16:56 ` Tony Lindgren
2015-01-30 10:58 ` Roger Quadros
2015-01-28 12:15 ` [PATCH v3 " Roger Quadros
2015-01-29 1:49 ` Chanwoo Choi
2015-01-29 11:26 ` Roger Quadros
2015-01-30 0:06 ` Chanwoo Choi
2015-01-30 11:09 ` Roger Quadros
2015-01-30 13:57 ` Roger Quadros
2015-01-30 0:11 ` Chanwoo Choi
2015-01-30 14:03 ` Roger Quadros
2015-02-02 5:06 ` Chanwoo Choi
2015-02-02 10:21 ` [PATCH v4 1/1] " Roger Quadros
2015-02-03 1:13 ` Chanwoo Choi
2015-03-16 12:32 ` Ivan T. Ivanov
2015-03-16 13:11 ` Roger Quadros
2015-03-16 14:23 ` Ivan T. Ivanov
2015-03-17 2:01 ` Chanwoo Choi
2015-03-17 7:52 ` Ivan T. Ivanov [this message]
2015-03-17 8:00 ` Ivan T. Ivanov
2015-01-26 12:15 ` [PATCH v2 2/7] usb: extcon: Fix USB-Host cable name Roger Quadros
2015-01-30 11:04 ` Roger Quadros
2015-01-30 14:05 ` Roger Quadros
2015-02-02 5:04 ` Chanwoo Choi
2015-02-02 9:09 ` Roger Quadros
2015-02-02 9:55 ` Chanwoo Choi
2015-02-02 10:01 ` Roger Quadros
2015-02-02 10:06 ` Chanwoo Choi
2015-01-26 12:15 ` [PATCH v2 3/7] ARM: dts: dra7-evm: Add extcon nodes for USB Roger Quadros
2015-01-26 12:15 ` [PATCH v2 4/7] ARM: dts: dra72-evm: " Roger Quadros
2015-01-26 12:15 ` [PATCH v2 5/7] ARM: dts: am57xx-beagle-x15: " Roger Quadros
2015-01-26 12:15 ` [PATCH v2 6/7] ARM: dts: am57xx-beagle-x15: Fix USB2 mode Roger Quadros
2015-01-26 12:15 ` [PATCH v2 7/7] ARM: omap2plus_defconfig: Enable EXTCON_GPIO_USB Roger Quadros
2015-03-16 17:53 ` Tony Lindgren
2015-03-17 9:29 ` Roger Quadros
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1426578738.2330.18.camel@linaro.org \
--to=ivan.ivanov@linaro.org \
--cc=balbi@ti.com \
--cc=cw00.choi@samsung.com \
--cc=devicetree@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-omap@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=myungjoo.ham@samsung.com \
--cc=nsekhar@ti.com \
--cc=rogerq@ti.com \
--cc=tony@atomide.com \
--subject='Re: [PATCH v4 1/1] extcon: usb-gpio: Introduce gpio usb extcon driver' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).