LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Geert Uytterhoeven <geert+renesas@glider.be>
To: Michael Turquette <mturquette@baylibre.com>,
Stephen Boyd <sboyd@kernel.org>
Cc: Rob Herring <robh+dt@kernel.org>,
Frank Rowand <frowand.list@gmail.com>,
Daniel Lezcano <daniel.lezcano@linaro.org>,
Thomas Gleixner <tglx@linutronix.de>,
Maxime Ripard <maxime.ripard@bootlin.com>,
Chen-Yu Tsai <wens@csie.org>,
Linus Walleij <linus.walleij@linaro.org>,
Heiko Stuebner <heiko@sntech.de>,
Thierry Reding <thierry.reding@gmail.com>,
Jonathan Hunter <jonathanh@nvidia.com>,
linux-clk@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-gpio@vger.kernel.org, linux-rockchip@lists.infradead.org,
linux-tegra@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org,
Geert Uytterhoeven <geert+renesas@glider.be>
Subject: [PATCH v2 0/5] Use of_clk_get_parent_count() instead of open coding
Date: Tue, 10 Apr 2018 14:51:36 +0200 [thread overview]
Message-ID: <1523364701-15383-1-git-send-email-geert+renesas@glider.be> (raw)
Hi Mike, Stephen, et al,
This patch series replaces open-coded versions of
of_clk_get_parent_count() by calls to the helper function.
Changes compared to v1:
- Move OF clock helpers (a.o. of_clk_get_parent_count()) to their own
include file <linux/of_clk.h>, as suggested by Stephen,
- Update includes for the above change,
- Fix timer-sp804, now a dummy is available in the !CONFIG_COMMON_CLK
case,
- Fix a new occurrence.
Note that patches 2-5 depend on the first patch. To simplify
dependencies, perhaps the first patch can still make it in v4.17-rc1?
Thanks!
Geert Uytterhoeven (5):
clk: Extract OF clock helpers in <linux/of_clk.h>
ARM: timer-sp: Use of_clk_get_parent_count() instead of open coding
soc: rockchip: power-domain: Use of_clk_get_parent_count() instead of
open coding
soc/tegra: pmc: Use of_clk_get_parent_count() instead of open coding
pinctrl: sunxi: Use of_clk_get_parent_count() instead of open coding
drivers/clocksource/timer-sp804.c | 3 ++-
drivers/pinctrl/sunxi/pinctrl-sunxi.c | 4 ++--
drivers/soc/rockchip/pm_domains.c | 4 ++--
drivers/soc/tegra/pmc.c | 3 ++-
include/linux/clk-provider.h | 14 +-------------
include/linux/of_clk.h | 29 +++++++++++++++++++++++++++++
6 files changed, 38 insertions(+), 19 deletions(-)
create mode 100644 include/linux/of_clk.h
--
2.7.4
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
next reply other threads:[~2018-04-10 12:52 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-04-10 12:51 Geert Uytterhoeven [this message]
2018-04-10 12:51 ` [PATCH v2 1/5] clk: Extract OF clock helpers in <linux/of_clk.h> Geert Uytterhoeven
2018-04-10 13:15 ` Heiko Stuebner
2018-04-13 21:16 ` Rob Herring
2018-04-16 16:05 ` Stephen Boyd
2018-04-10 12:51 ` [PATCH v2 2/5] ARM: timer-sp: Use of_clk_get_parent_count() instead of open coding Geert Uytterhoeven
2018-04-17 8:50 ` Daniel Lezcano
2018-04-26 11:56 ` Linus Walleij
2018-04-10 12:51 ` [PATCH v2 3/5] soc: rockchip: power-domain: " Geert Uytterhoeven
2018-04-10 13:17 ` Heiko Stuebner
2018-04-10 12:51 ` [PATCH v2 4/5] soc/tegra: pmc: " Geert Uytterhoeven
2018-04-11 9:07 ` Jon Hunter
2018-04-10 12:51 ` [PATCH v2 5/5] pinctrl: sunxi: " Geert Uytterhoeven
2018-04-10 13:01 ` Maxime Ripard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1523364701-15383-1-git-send-email-geert+renesas@glider.be \
--to=geert+renesas@glider.be \
--cc=daniel.lezcano@linaro.org \
--cc=devicetree@vger.kernel.org \
--cc=frowand.list@gmail.com \
--cc=heiko@sntech.de \
--cc=jonathanh@nvidia.com \
--cc=linus.walleij@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-clk@vger.kernel.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-tegra@vger.kernel.org \
--cc=maxime.ripard@bootlin.com \
--cc=mturquette@baylibre.com \
--cc=robh+dt@kernel.org \
--cc=sboyd@kernel.org \
--cc=tglx@linutronix.de \
--cc=thierry.reding@gmail.com \
--cc=wens@csie.org \
--subject='Re: [PATCH v2 0/5] Use of_clk_get_parent_count() instead of open coding' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).