LKML Archive on lore.kernel.org help / color / mirror / Atom feed
From: Stephen Boyd <swboyd@chromium.org> To: Doug Anderson <dianders@chromium.org>, Matthias Kaehlcke <mka@chromium.org> Cc: Maulik Shah <mkshah@codeaurora.org>, Andy Gross <agross@kernel.org>, Bjorn Andersson <bjorn.andersson@linaro.org>, Rajendra Nayak <rnayak@codeaurora.org>, Evan Green <evgreen@chromium.org>, Lina Iyer <ilina@codeaurora.org>, linux-arm-msm <linux-arm-msm@vger.kernel.org>, LKML <linux-kernel@vger.kernel.org> Subject: Re: [RFT PATCH 1/9] drivers: qcom: rpmh-rsc: Clean code reading/writing regs/cmds Date: Wed, 11 Mar 2020 12:30:02 -0700 [thread overview] Message-ID: <158395500244.149997.1358582842144222001@swboyd.mtv.corp.google.com> (raw) In-Reply-To: <20200311161726.GA144492@google.com> Quoting Matthias Kaehlcke (2020-03-11 09:17:26) > Hi, > > On Wed, Mar 11, 2020 at 08:03:27AM -0700, Doug Anderson wrote: > > Hi, > > > > On Wed, Mar 11, 2020 at 1:47 AM Maulik Shah <mkshah@codeaurora.org> wrote: > > > > > > Hi, > > > > > > On 3/7/2020 5:29 AM, Douglas Anderson wrote: > > > > This patch makes two changes, both of which should be no-ops: > > > > > > > > 1. Make read_tcs_reg() / read_tcs_cmd() symmetric to write_tcs_reg() / > > > > write_tcs_cmd(). > > > > > > i agree that there are two different write function doing same thing except last addition (RSC_DRV_CMD_OFFSET * cmd_id) > > > > > > can you please rename write_tcs_cmd() to write_tcs_reg(), add above operation in it, and then remove existing write_tcs_reg(). > > > this way we have only one read and one write function. > > > > > > so at the end we will two function as, > > > > > > static u32 read_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id) > > > { > > > return readl_relaxed(drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > > RSC_DRV_CMD_OFFSET * cmd_id); > > > } > > > > > > static void write_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id, > > > u32 data) > > > { > > > writel_relaxed(data, drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > > RSC_DRV_CMD_OFFSET * cmd_id); > > > } > > > > I can if you insist and this is still better than the existing > > (inconsistent) code. > > > > ...but I still feel that having two functions adds value here. > > > > > > Anyone else who is CCed want to weigh in and tie break? > > I agree with Doug, having two functions makes the code that calls them > clearer. It makes it evident when a command is read/written and doesn't require > a useless extra parameter when accessing a non-command register. Me too! In fact, I asked for this when this driver was introduced and I was half-ignored[1]. Making sure we never have to pass 0 to one of these functions should be a goal. From two years ago: > > Is m the type of TCS (sleep, active, wake) and n is just an offset? > Maybe you can replace m with 'tcs_type' and n with 'index' or 'i' or > 'offset'. And then don't use this function to write the random TCS > registers that don't have to do with the TCS command slots? I see > various places where there are things like: > > > + write_tcs_reg(drv, RSC_DRV_CMD_ENABLE, m, 0, 0); > > + write_tcs_reg(drv, RSC_DRV_CMD_WAIT_FOR_CMPL, m, 0, cmd_complete); > > + write_tcs_reg(drv, RSC_DRV_CMD_ENABLE, m, 0, cmd_enable); > > And 'n' is 0, meaning you rely on that 0 killing that last part of the > equation (RSC_DRV_CMD_OFFSET * n). But if we had a write_tcs_reg(drv, > reg, m, data) and a write_tcs_cmd(drv, reg, m, n, data) then it would be > clearer. > > Even better, add a void *base to a 'struct tcs' and then pass that > struct to the tcs_read/write APIs and then have that pull out a > tcs->base + reg or tcs->base + reg + RSC_DRV_CMD_OFFSET * index. > [1] https://lore.kernel.org/linux-arm-msm/152364140661.51482.261490347611407195@swboyd.mtv.corp.google.com/
next prev parent reply other threads:[~2020-03-11 19:30 UTC|newest] Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top 2020-03-06 23:59 [RFT PATCH 0/9] drivers: qcom: rpmh-rsc: Cleanup / add lots of comments Douglas Anderson 2020-03-06 23:59 ` [RFT PATCH 1/9] drivers: qcom: rpmh-rsc: Clean code reading/writing regs/cmds Douglas Anderson 2020-03-11 8:47 ` Maulik Shah 2020-03-11 15:03 ` Doug Anderson 2020-03-11 16:17 ` Matthias Kaehlcke 2020-03-11 19:30 ` Stephen Boyd [this message] 2020-03-06 23:59 ` [RFT PATCH 2/9] drivers: qcom: rpmh-rsc: Document the register layout better Douglas Anderson 2020-03-11 9:35 ` Maulik Shah 2020-03-11 15:27 ` Doug Anderson 2020-03-11 18:49 ` Evan Green 2020-03-11 20:08 ` Stephen Boyd 2020-03-11 22:35 ` Doug Anderson 2020-03-06 23:59 ` [RFT PATCH 3/9] drivers: qcom: rpmh-rsc: Fold tcs_ctrl_write() into its single caller Douglas Anderson 2020-03-11 9:50 ` Maulik Shah 2020-03-06 23:59 ` [RFT PATCH 4/9] drivers: qcom: rpmh-rsc: Remove get_tcs_of_type() abstraction Douglas Anderson 2020-03-11 12:02 ` Maulik Shah 2020-03-06 23:59 ` [RFT PATCH 5/9] drivers: qcom: rpmh-rsc: A lot of comments Douglas Anderson 2020-03-06 23:59 ` [RFT PATCH 6/9] drivers: qcom: rpmh-rsc: Only use "tcs_in_use" for ACTIVE_ONLY Douglas Anderson 2020-03-11 0:33 ` Doug Anderson 2020-03-06 23:59 ` [RFT PATCH 7/9] drivers: qcom: rpmh-rsc: Warning if tcs_write() used for non-active Douglas Anderson 2020-03-06 23:59 ` [RFT PATCH 8/9] drivers: qcom: rpmh-rsc: spin_lock_irqsave() for tcs_invalidate() Douglas Anderson 2020-03-06 23:59 ` [RFT PATCH 9/9] drivers: qcom: rpmh-rsc: Kill cmd_cache and find_match() with fire Douglas Anderson 2020-03-11 0:35 ` Doug Anderson 2020-03-11 9:48 ` [RFT PATCH 0/9] drivers: qcom: rpmh-rsc: Cleanup / add lots of comments Maulik Shah
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=158395500244.149997.1358582842144222001@swboyd.mtv.corp.google.com \ --to=swboyd@chromium.org \ --cc=agross@kernel.org \ --cc=bjorn.andersson@linaro.org \ --cc=dianders@chromium.org \ --cc=evgreen@chromium.org \ --cc=ilina@codeaurora.org \ --cc=linux-arm-msm@vger.kernel.org \ --cc=linux-kernel@vger.kernel.org \ --cc=mka@chromium.org \ --cc=mkshah@codeaurora.org \ --cc=rnayak@codeaurora.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).