LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Neil Brown <neilb@cse.unsw.edu.au>
To: Linus Torvalds <torvalds@osdl.org>
Cc: linux-kernel@vger.kernel.org
Subject: md/raid devices don't show up in /proc/partitions in 2.6 :-(
Date: Thu, 27 Nov 2003 11:15:10 +1100	[thread overview]
Message-ID: <16325.16910.697589.124844@notabene.cse.unsw.edu.au> (raw)


I just noticed that md devices do not show up in /proc/partitions in
2.6.

I realise that they don't actually have partitions and are just 'whole
devices', but other whole devices do appear in /proc/partitions (Along
with their partitions if any).

This seems to be a regression from 2.4 where md devices do appear in
/proc/partitions.

The cause appears to be a patch from 'torvalds' some 15 months ago
(in version 1.36 for drivers/block/genhd.c) which has the comment:

      Avoid confusion "mount" and "fsck" - don't show things like
      floppies and CD's in /proc/partitions.

It excluded devices that cannot be partitioned, and devices with zero
size from /proc/partitions.

The 'zero size' possibly makes sense (2.4 excludes those), but I would
like to register a vote against excluding devices without partitions,
as this excluded 'md' devices and I would really like them to be
included.


Is there really a good reason for this?  How badly does mount get
confused? and is that not the fault of mount?

NeilBrown

             reply	other threads:[~2003-11-27  0:15 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-11-27  0:15 Neil Brown [this message]
2003-11-27  4:09 ` Lincoln Dale
2003-11-27 10:36 ` Lars Marowsky-Bree

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=16325.16910.697589.124844@notabene.cse.unsw.edu.au \
    --to=neilb@cse.unsw.edu.au \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@osdl.org \
    --subject='Re: md/raid devices don'\''t show up in /proc/partitions in 2.6 :-(' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).