LKML Archive on
help / color / mirror / Atom feed
* AMD viper chipset and UDMA100
@ 2001-09-27 21:26 Sean Swallow
  2001-09-27 21:36 ` Nicholas Knight
  2001-09-27 21:59 ` Vojtech Pavlik
  0 siblings, 2 replies; 10+ messages in thread
From: Sean Swallow @ 2001-09-27 21:26 UTC (permalink / raw)
  To: linux-kernel


I just got a tyan tiger w/ the AMD Viper chipset on it. For some reason
Linux will only set the onboard (AMD viper) chains to UDMA33.

I'm using linux 2.4.9, and I have also tried 2.4.10. Is there a limitation
to the AMD Viper driver?

PS. The cables (2) are BRAND new ata100 cables.


Sean J. Swallow
pgp (6.5.2) keyfile @

^ permalink raw reply	[flat|nested] 10+ messages in thread
* Re: [patch] Re: AMD viper chipset and UDMA100
@ 2001-10-05 21:26 Steven Newbury
  0 siblings, 0 replies; 10+ messages in thread
From: Steven Newbury @ 2001-10-05 21:26 UTC (permalink / raw)
  To: linux-kernel; +Cc: vojtech

On Sep 28, 2001 at 10:21:14, Vojetch Pavlik wrote:
> On Thu, Sep 27, 2001 at 04:37:50PM -0700, Sean
Swallow wrote:
> > Vojtech,
> > I would be interested in trying out your code.
> Ok. It should make your ViperPlus work with UDMA100.
> The patch is
> against 2.4.10, but will probably work with any
similar kernel. It
> completely replaces Andre's driver with mine. Find
it > attached.
> Good luck. 
[patch snipped]
I have a Tyan K7 Thunder and I have tried this patch
and the patch from Andre, synced with 2.4.10 by Jacob
Luna and have had the same problem with both.  Without
the patch I can only do UDMA33 but the hw supports
UDMA100.  I have a Quantum FireballPlus AS40 on my
primary IDE channel which I have tested on an MSI
K7Master and works fine in UDMA100.

When I reboot with the driver enabled, as soon as hda
is detected the kernel locks up with a DIVIDE (0)
error.  I will try it again and take notes of more
details if it helps.

Without the driver, using the generic code I am able
to use the drive, in I think UDMA100 by letting the
BIOS set the drive to UDMA100 then manually setting
DMA mode on with hdparm.  However if I try to set the
modes manually with hdparm I can not select above

I have tried this with kernel 2.4.10 and 2.4.11pre1.
My system is a Dual K7, SMP kernel, 512MB RAM.

My root filesystem is on a RAID0 array across 4
Quantum AtlasV 9GB U160 SCSI disks, two on each
channel of the onboard Adaptec.

I have tried to use the Fireball in the array as well
but for some reason performance reduced!  110MB/s with
hdparm -t compared to 70MB/s. Could this be because of
the lack of chipset driver?

One other thing is I am running with the preemt patch,
though I tested it without as well as I remember.

Please CC any replys to
as  I am not on the list.
Steven Newbury

Do You Yahoo!?
Get your free address at
or your free address at

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2001-10-05 21:26 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2001-09-27 21:26 AMD viper chipset and UDMA100 Sean Swallow
2001-09-27 21:36 ` Nicholas Knight
2001-09-27 21:59 ` Vojtech Pavlik
2001-09-27 22:16   ` Dan Hollis
2001-09-27 22:24     ` Vojtech Pavlik
2001-09-27 22:54       ` Dan Hollis
2001-09-28  2:21         ` Jacob Luna Lundberg
2001-09-27 23:37       ` Sean Swallow
2001-09-28 10:21         ` [patch] " Vojtech Pavlik
2001-10-05 21:26 Steven Newbury

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).