LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: florin@iucha.net (Florin Iucha)
To: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Cc: Jiri Kosina <jikos@jikos.cz>,
	linux-usb-devel@lists.sourceforge.net,
	Adrian Bunk <bunk@stusta.de>,
	Alan Stern <stern@rowland.harvard.edu>,
	Trond Myklebust <trond.myklebust@fys.uio.no>
Subject: heavy nfs[4]] causes fs badness Was: 2.6.20-rc4: known unfixed regressions (v2)
Date: Sun, 14 Jan 2007 17:58:17 -0600	[thread overview]
Message-ID: <20070114235816.GB6053@iucha.net> (raw)
In-Reply-To: <20070114225701.GA6053@iucha.net>

[-- Attachment #1: Type: text/plain, Size: 1827 bytes --]

On Sun, Jan 14, 2007 at 04:57:01PM -0600,  wrote:
> On Wed, Jan 10, 2007 at 10:54:34AM -0500, Alan Stern wrote:
> > It's still possible that this is hardware related; perhaps some component
> > just began to wear out.  If you return to an earlier kernel, does the 
> > problem go away?
> 
> As reported in my original e-mail and verified just minutes ago, the
> copy succeeds with 2.6.19 (kernel.org vanilla, compiled with the same
> config as 2.6.20-rcX).  I will begin bisecting between .19 and .20-rc1
> after re-reading Jiri's messages.

All the testing was done via a ssh into the workstation.  The console
was left as booted into, with the gdm running.  The remote nfs4
directory was mounted on "/mnt".

After copying the 60+ GB and testing that the keyboard was still
functioning, I did not reboot but stayed in the same kernel and pulled
the latest git then started bisecting.  After recompiling, I moved
over to the workstation to reboot it, but the keyboard was not
functioning ;(

I ran "lsusb" and it displayed all the devices. "dmesg" did not show
any oops, anything for that matter.  I have unplugged the keyboard and
run "lsusb" again, but it hang.  I ran "ls /mnt" and it hang as well.
Stracing "lsusb" showed it hang (entered the kernel) at opening the device
that used to be the keyboard.  Stracing "ls /mnt" showed that it
hang at "stat(/mnt)".  Both processes were in "D" state.  "ls /root"
worked without problem, so it appears that crossing mountpoints causes
some hang in the kernel.

Based on this info, I think we can rule out any USB.  I will try
testing with NFS3 to see if the problem persists.  Unfortunately there
is no oops or anything in "dmesg".

florin

-- 
Bruce Schneier expects the Spanish Inquisition.
      http://geekz.co.uk/schneierfacts/fact/163

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 189 bytes --]

  reply	other threads:[~2007-01-14 23:58 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20070109214431.GH24369@iucha.net>
     [not found] ` <Pine.LNX.4.44L0.0701101052310.3289-100000@iolanthe.rowland.org>
2007-01-14 22:57   ` [linux-usb-devel] " Florin Iucha
2007-01-14 23:58     ` Florin Iucha [this message]
2007-01-15  0:14       ` heavy nfs[4]] causes fs badness Was: " Jiri Kosina
2007-01-15  2:02         ` Florin Iucha
2007-01-15 15:58           ` Alan Stern
2007-01-24  3:04             ` Florin Iucha
2007-01-24 19:07               ` Alan Stern
2007-01-15  0:14       ` Trond Myklebust
2007-01-15  2:11       ` Horst H. von Brand
2007-01-15 15:46         ` Florin Iucha

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070114235816.GB6053@iucha.net \
    --to=florin@iucha.net \
    --cc=bunk@stusta.de \
    --cc=jikos@jikos.cz \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb-devel@lists.sourceforge.net \
    --cc=stern@rowland.harvard.edu \
    --cc=trond.myklebust@fys.uio.no \
    --subject='Re: heavy nfs[4]] causes fs badness Was: 2.6.20-rc4: known unfixed regressions (v2)' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).