LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Eric Buddington <ebuddington@verizon.net>
To: David Hollis <dhollis@davehollis.com>
Cc: ebuddington@wesleyan.edu, linux-kernel@vger.kernel.org
Subject: Re: 2.6.20-rc4-mm1 USB (asix) problem
Date: Tue, 16 Jan 2007 17:59:15 -0500	[thread overview]
Message-ID: <20070116225909.GA6932@pool-71-123-123-29.spfdma.east.verizon.net> (raw)
In-Reply-To: <1168893137.19899.109.camel@dhollis-lnx.sunera.com>

On Mon, Jan 15, 2007 at 08:32:17PM +0000, David Hollis wrote:
> Interesting.  It would really be something if your devices happen to
> work better with 0.  Wouldn't make much sense at all unfortunately.  If
> 0 works, could you also try setting it to 2 or 3?  The PHY select value
> is a bit field with the 0 bit being to select the onboard PHY, and 1 bit
> being to 'auto-select' the PHY based on link status.  The data sheet
> indicates that 3 should be the default, but all of the literature I have
> seen from ASIX says to write a 1 to it.

My hardware is ver. B1.

0, 2, and 3 all worked for me. 1, as before, does not.

'rmmod asix' takes a really long time (45-80s) with any setting, and
sometimes coincides with ksoftirqd pegging (99.9% CPU) for several
seconds.

-Eric

  reply	other threads:[~2007-01-16 23:59 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-01-13 20:31 Eric Buddington
2007-01-15 19:27 ` David Hollis
2007-01-15 19:50   ` Eric Buddington
2007-01-15 20:32     ` David Hollis
2007-01-16 22:59       ` Eric Buddington [this message]
2007-01-17 12:00         ` David Hollis
2007-01-17 13:54           ` Eric Buddington

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070116225909.GA6932@pool-71-123-123-29.spfdma.east.verizon.net \
    --to=ebuddington@verizon.net \
    --cc=dhollis@davehollis.com \
    --cc=ebuddington@wesleyan.edu \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: 2.6.20-rc4-mm1 USB (asix) problem' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).