LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: ananth@in.ibm.com
Cc: Adrian Bunk <bunk@stusta.de>,
	prasanna@in.ibm.com, anil.s.keshavamurthy@intel.com,
	davem@davemloft.net, linux-kernel@vger.kernel.org
Subject: Re: [2.6 patch] include/linux/kprobes.h: always offer show_registers() prototype
Date: Fri, 27 Apr 2007 16:32:51 -0700	[thread overview]
Message-ID: <20070427163251.209fa828.akpm@linux-foundation.org> (raw)
In-Reply-To: <20070427051056.GB9787@in.ibm.com>

On Fri, 27 Apr 2007 10:40:57 +0530
Ananth N Mavinakayanahalli <ananth@in.ibm.com> wrote:

> On Fri, Apr 27, 2007 at 01:47:49AM +0200, Adrian Bunk wrote:
> > Allow gcc to perform show_registers() type checking also with 
> > CONFIG_KPROBES=n.
> 
> Is kprobes.h the correct place to allow for this change? Perhaps, with
> Christoph's patch http://marc.info/?l=linux-kernel&m=117432009501114&w=2
> consolidating the die_notifier code, this could be moved to
> include/linux/kdebug.h instead?
> 

Yes, I think something is definitely wrong here.  If the code is presently
calling show_registers() with no prototype in scope, it should be emitting
warnings?

Also, yes, kprobes.h is an inappropriate place for this declaration.  It
should be in include/asm-foo/, I guess.

But if we do that, there's an excellent chance of a compile explosion,
because we also have implementations of show_registers() in
drivers/net/wireless/ipw2100.c, drivers/usb/gadget/net2280.c,
drivers/usb/host/ehci-dbg.c, drivers/usb/host/ohci-dbg.c and who knows
where else.

So what I'd suggest is that we rename show_registers() to something saner,
then put the declaration into some arch header file then include that
header in kprobes.


  reply	other threads:[~2007-04-27 23:33 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-04-26 23:47 Adrian Bunk
2007-04-27  5:10 ` Ananth N Mavinakayanahalli
2007-04-27 23:32   ` Andrew Morton [this message]
2007-04-28 12:42     ` Adrian Bunk
2007-06-17 23:43 Adrian Bunk
2007-06-18  6:27 ` S. P. Prasanna

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070427163251.209fa828.akpm@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=ananth@in.ibm.com \
    --cc=anil.s.keshavamurthy@intel.com \
    --cc=bunk@stusta.de \
    --cc=davem@davemloft.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=prasanna@in.ibm.com \
    --subject='Re: [2.6 patch] include/linux/kprobes.h: always offer show_registers() prototype' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).