LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Alexey Dobriyan <adobriyan@gmail.com>
To: Ulrich Drepper <drepper@redhat.com>
Cc: akpm@linux-foundation.org, linux-kernel@vger.kernel.org,
adobriyan@openvz.org
Subject: Re: [PATCH] v4: merged utimensat implementation
Date: Fri, 27 Apr 2007 21:32:47 +0400 [thread overview]
Message-ID: <20070427173247.GA5986@martell.zuzino.mipt.ru> (raw)
In-Reply-To: <200704271523.l3RFNwGN031209@devserv.devel.redhat.com>
On Fri, Apr 27, 2007 at 11:23:58AM -0400, Ulrich Drepper wrote:
> I took Alexey's lutimes patches and merged it with the utimensat patch.
> Fortunately Alexey already did most of the work, the conversion to
> timespec. I just changed the name of the syscall, made the flag part
> of the syscall parameters, and did away with the old do_utimes definition
> (the new do_utimes takes a timespec and a flag now). All five patches
> patches are rolled into one.
erm, utime(2) cleanup is technically independent from all this nanosecond
business, but ok.
> --- a/arch/alpha/kernel/osf_sys.c
> +++ b/arch/alpha/kernel/osf_sys.c
> @@ -955,15 +955,25 @@ osf_setitimer(int which, struct itimerval32 __user *in, struct itimerval32 __use
> asmlinkage int
> osf_utimes(char __user *filename, struct timeval32 __user *tvs)
> {
> - struct timeval ktvs[2];
> + struct timespec tv[2];
It should be tiny little bit nicer to call them "ts[2]" because they're
timeSpecs.
next prev parent reply other threads:[~2007-04-27 17:32 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-04-27 15:23 Ulrich Drepper
2007-04-27 17:32 ` Alexey Dobriyan [this message]
2007-04-27 17:46 ` Ulrich Drepper
2007-04-27 21:04 ` Andrew Morton
2007-04-27 21:30 ` Ulrich Drepper
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070427173247.GA5986@martell.zuzino.mipt.ru \
--to=adobriyan@gmail.com \
--cc=adobriyan@openvz.org \
--cc=akpm@linux-foundation.org \
--cc=drepper@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--subject='Re: [PATCH] v4: merged utimensat implementation' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).