LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: "Ed L. Cashin" <ecashin@coraid.com>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] stacked ifs (was Re: [PATCH 02/12] handle multiple network paths to AoE device)
Date: Mon, 16 Jul 2007 17:01:51 -0700 [thread overview]
Message-ID: <20070717000151.GA5982@kroah.com> (raw)
In-Reply-To: <20070716153155.8a63c15d.akpm@linux-foundation.org>
On Mon, Jul 16, 2007 at 03:31:55PM -0700, Andrew Morton wrote:
> On Mon, 16 Jul 2007 18:17:44 -0400
> "Ed L. Cashin" <ecashin@coraid.com> wrote:
>
> > > ugh. Do this:
> > >
> > > do {
> > > if (t == d->htgt)
> > > continue;
> > > if (!(*t)->ifp->nd)
> > > continue;
> > > if ((*t)->nout >= (*t)->maxout)
> > > continue;
> > >
> > > <stuff>
> > > } while (++t ...)
> >
> > Do you think the "stacked ifs" in the first version above could be
> > accepted as a convenient extension to the K&R-based conventions in
> > Documentation/CodingStyle?
>
> Maybe. I don't recall seeing any kernel code which uses that convention:
> everyone uses &&. So personally I'd prefer to see kernel code stick to the
> one convention, given that there is not, afacit, any significant advantage
> to the alternative one.
I agree, let's stick with the convention we already have and use
instead.
thanks,
greg k-h
next prev parent reply other threads:[~2007-07-17 0:13 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-06-26 18:50 [PATCH 01/12] bring driver version number to 47 Ed L. Cashin
2007-06-26 18:50 ` [PATCH 03/12] mac_addr: avoid 64-bit arch compiler warnings Ed L. Cashin
2007-06-26 18:50 ` [PATCH 02/12] handle multiple network paths to AoE device Ed L. Cashin
2007-07-03 4:29 ` Andrew Morton
2007-07-11 14:46 ` Ed L. Cashin
2007-07-16 22:17 ` [PATCH] stacked ifs (was Re: [PATCH 02/12] handle multiple network paths to AoE device) Ed L. Cashin
2007-07-16 22:31 ` Andrew Morton
2007-07-17 0:01 ` Greg KH [this message]
2007-07-18 15:24 ` Jan Engelhardt
2007-06-26 18:50 ` [PATCH 05/12] eliminate goto and improve readability Ed L. Cashin
2007-06-26 18:50 ` [PATCH 07/12] use a dynamic pool of sk_buffs to keep up with fast targets Ed L. Cashin
2007-07-03 4:36 ` Andrew Morton
2007-07-03 4:40 ` David Miller
2007-07-03 18:45 ` Matt Mackall
2007-07-03 19:18 ` Stephen Hemminger
2007-07-06 17:09 ` Ed L. Cashin
2007-06-26 18:50 ` [PATCH 06/12] user can ask driver to forget previously detected devices Ed L. Cashin
2007-06-26 18:50 ` [PATCH 04/12] clean up udev configuration example Ed L. Cashin
2007-06-26 18:50 ` [PATCH 12/12] the aoeminor doesn't need a long format Ed L. Cashin
2007-06-26 19:51 ` Randy Dunlap
2007-06-26 19:59 ` Ed L. Cashin
2007-06-26 18:50 ` [PATCH 10/12] add module parameter for users who need more outstanding I/O Ed L. Cashin
2007-07-03 4:41 ` Andrew Morton
2007-06-26 18:50 ` [PATCH 11/12] remove extra space in prototypes for consistency Ed L. Cashin
2007-06-26 18:50 ` [PATCH 09/12] remove race between use and initialization of locks Ed L. Cashin
2007-07-03 4:38 ` Andrew Morton
2007-06-26 18:50 ` [PATCH 08/12] only schedule work once Ed L. Cashin
2007-07-03 4:37 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070717000151.GA5982@kroah.com \
--to=greg@kroah.com \
--cc=akpm@linux-foundation.org \
--cc=ecashin@coraid.com \
--cc=linux-kernel@vger.kernel.org \
--subject='Re: [PATCH] stacked ifs (was Re: [PATCH 02/12] handle multiple network paths to AoE device)' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).