LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: marcin.slusarz@gmail.com
Cc: LKML <linux-kernel@vger.kernel.org>,
	Ben Fennema <bfennema@falcon.csc.calpoly.edu>,
	Christoph Hellwig <hch@infradead.org>
Subject: Re: [PATCH 06/16] udf: move calculating of nr_groups into helper function
Date: Fri, 11 Jan 2008 00:15:12 +0100	[thread overview]
Message-ID: <20080110231512.GD17430@duck.suse.cz> (raw)
In-Reply-To: <1200002792-8449-7-git-send-email-marcin.slusarz@gmail.com>

On Thu 10-01-08 23:06:22, marcin.slusarz@gmail.com wrote:
> Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
> CC: Ben Fennema <bfennema@falcon.csc.calpoly.edu>
> CC: Jan Kara <jack@suse.cz>
> CC: Christoph Hellwig <hch@infradead.org>
  Acked-by: Jan Kara <jack@suse.cz>

> ---
>  fs/udf/balloc.c |    4 +---
>  fs/udf/super.c  |   16 ++++++++++------
>  fs/udf/udf_sb.h |    2 ++
>  3 files changed, 13 insertions(+), 9 deletions(-)
> 
> diff --git a/fs/udf/balloc.c b/fs/udf/balloc.c
> index 8c0c279..3f67d9d 100644
> --- a/fs/udf/balloc.c
> +++ b/fs/udf/balloc.c
> @@ -231,9 +231,7 @@ static int udf_bitmap_prealloc_blocks(struct super_block *sb,
>  		block_count = part_len - first_block;
>  
>  repeat:
> -	nr_groups = (sbi->s_partmaps[partition].s_partition_len +
> -		     (sizeof(struct spaceBitmapDesc) << 3) +
> -		     (sb->s_blocksize * 8) - 1) / (sb->s_blocksize * 8);
> +	nr_groups = udf_compute_nr_groups(sb, partition);
>  	block = first_block + (sizeof(struct spaceBitmapDesc) << 3);
>  	block_group = block >> (sb->s_blocksize_bits + 3);
>  	group_start = block_group ? 0 : sizeof(struct spaceBitmapDesc);
> diff --git a/fs/udf/super.c b/fs/udf/super.c
> index 2344157..187aff9 100644
> --- a/fs/udf/super.c
> +++ b/fs/udf/super.c
> @@ -937,18 +937,22 @@ static void udf_load_fileset(struct super_block *sb, struct buffer_head *bh,
>  		  root->logicalBlockNum, root->partitionReferenceNum);
>  }
>  
> +int udf_compute_nr_groups(struct super_block *sb, u32 partition)
> +{
> +	struct udf_part_map *map = &UDF_SB(sb)->s_partmaps[partition];
> +	return (map->s_partition_len +
> +		(sizeof(struct spaceBitmapDesc) << 3) +
> +		(sb->s_blocksize * 8) - 1) /
> +		(sb->s_blocksize * 8);
> +}
> +
>  static struct udf_bitmap *udf_sb_alloc_bitmap(struct super_block *sb, u32 index)
>  {
> -	struct udf_part_map *map = &UDF_SB(sb)->s_partmaps[index];
>  	struct udf_bitmap *bitmap;
>  	int nr_groups;
>  	int size;
>  
> -	/* TODO: move calculating of nr_groups into helper function */
> -	nr_groups = (map->s_partition_len +
> -			(sizeof(struct spaceBitmapDesc) << 3) +
> -			(sb->s_blocksize * 8) - 1) /
> -			(sb->s_blocksize * 8);
> +	nr_groups = udf_compute_nr_groups(sb, index);
>  	size = sizeof(struct udf_bitmap) +
>  		(sizeof(struct buffer_head *) * nr_groups);
>  
> diff --git a/fs/udf/udf_sb.h b/fs/udf/udf_sb.h
> index 2c05f82..d9adb0f 100644
> --- a/fs/udf/udf_sb.h
> +++ b/fs/udf/udf_sb.h
> @@ -43,6 +43,8 @@ static inline struct udf_sb_info *UDF_SB(struct super_block *sb)
>  
>  struct logicalVolIntegrityDescImpUse *udf_sb_lvidiu(struct udf_sb_info *sbi);
>  
> +int udf_compute_nr_groups(struct super_block *sb, u32 partition);
> +
>  #define UDF_QUERY_FLAG(X,Y)			( UDF_SB(X)->s_flags & ( 1 << (Y) ) )
>  #define UDF_SET_FLAG(X,Y)			( UDF_SB(X)->s_flags |= ( 1 << (Y) ) )
>  #define UDF_CLEAR_FLAG(X,Y)			( UDF_SB(X)->s_flags &= ~( 1 << (Y) ) )
> -- 
> 1.5.3.7
> 

								Honza
-- 
Jan Kara <jack@suse.cz>
SUSE Labs, CR

  reply	other threads:[~2008-01-10 23:15 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04   ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14   ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15   ` Jan Kara [this message]
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` [PATCH 08/16] udf: fix coding style marcin.slusarz
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19   ` Jan Kara
2008-01-10 22:06 ` [PATCH 10/16] udf: create common function for changing free space counter marcin.slusarz
2008-01-10 23:24   ` Jan Kara
2008-01-12 13:13     ` Marcin Slusarz
2008-01-14  9:56       ` Jan Kara
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26   ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28   ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30   ` Jan Kara
2008-01-11  9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080110231512.GD17430@duck.suse.cz \
    --to=jack@suse.cz \
    --cc=bfennema@falcon.csc.calpoly.edu \
    --cc=hch@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcin.slusarz@gmail.com \
    --subject='Re: [PATCH 06/16] udf: move calculating of nr_groups into helper function' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).