LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: marcin.slusarz@gmail.com
Cc: LKML <linux-kernel@vger.kernel.org>, Jan Kara <jack@suse.cz>,
Christoph Hellwig <hch@infradead.org>
Subject: Re: [PATCH 16/16] udf: improve readability of udf_load_partition
Date: Fri, 11 Jan 2008 00:30:51 +0100 [thread overview]
Message-ID: <20080110233051.GI17430@duck.suse.cz> (raw)
In-Reply-To: <1200002792-8449-17-git-send-email-marcin.slusarz@gmail.com>
On Thu 10-01-08 23:06:32, marcin.slusarz@gmail.com wrote:
> Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
> CC: Jan Kara <jack@suse.cz>
> CC: Christoph Hellwig <hch@infradead.org>
Acked-by: Jan Kara <jack@suse.cz>
> ---
> fs/udf/super.c | 59 ++++++++++++++++++++++++++++---------------------------
> 1 files changed, 30 insertions(+), 29 deletions(-)
>
> diff --git a/fs/udf/super.c b/fs/udf/super.c
> index 52d2c32..2048351 100644
> --- a/fs/udf/super.c
> +++ b/fs/udf/super.c
> @@ -1447,44 +1447,45 @@ static int udf_load_partition(struct super_block *sb, kernel_lb_addr *fileset)
> sbi = UDF_SB(sb);
>
> for (i = 0; i < ARRAY_SIZE(sbi->s_anchor); i++) {
> - if (sbi->s_anchor[i] &&
> - (bh = udf_read_tagged(sb, sbi->s_anchor[i],
> - sbi->s_anchor[i], &ident))) {
> - anchor = (struct anchorVolDescPtr *)bh->b_data;
> -
> - /* Locate the main sequence */
> - main_s = le32_to_cpu(
> - anchor->mainVolDescSeqExt.extLocation);
> - main_e = le32_to_cpu(
> - anchor->mainVolDescSeqExt.extLength);
> - main_e = main_e >> sb->s_blocksize_bits;
> - main_e += main_s;
> -
> - /* Locate the reserve sequence */
> - reserve_s = le32_to_cpu(
> + if (!sbi->s_anchor[i])
> + continue;
> + bh = udf_read_tagged(sb, sbi->s_anchor[i], sbi->s_anchor[i],
> + &ident);
> + if (!bh)
> + continue;
> +
> + anchor = (struct anchorVolDescPtr *)bh->b_data;
> +
> + /* Locate the main sequence */
> + main_s = le32_to_cpu(anchor->mainVolDescSeqExt.extLocation);
> + main_e = le32_to_cpu(anchor->mainVolDescSeqExt.extLength);
> + main_e = main_e >> sb->s_blocksize_bits;
> + main_e += main_s;
> +
> + /* Locate the reserve sequence */
> + reserve_s = le32_to_cpu(
> anchor->reserveVolDescSeqExt.extLocation);
> - reserve_e = le32_to_cpu(
> + reserve_e = le32_to_cpu(
> anchor->reserveVolDescSeqExt.extLength);
> - reserve_e = reserve_e >> sb->s_blocksize_bits;
> - reserve_e += reserve_s;
> + reserve_e = reserve_e >> sb->s_blocksize_bits;
> + reserve_e += reserve_s;
>
> - brelse(bh);
> + brelse(bh);
>
> - /* Process the main & reserve sequences */
> - /* responsible for finding the PartitionDesc(s) */
> - if (!(udf_process_sequence(sb, main_s, main_e,
> - fileset) &&
> - udf_process_sequence(sb, reserve_s, reserve_e,
> - fileset)))
> - break;
> - }
> + /* Process the main & reserve sequences */
> + /* responsible for finding the PartitionDesc(s) */
> + if (!(udf_process_sequence(sb, main_s, main_e,
> + fileset) &&
> + udf_process_sequence(sb, reserve_s, reserve_e,
> + fileset)))
> + break;
> }
>
> if (i == ARRAY_SIZE(sbi->s_anchor)) {
> udf_debug("No Anchor block found\n");
> return 1;
> - } else
> - udf_debug("Using anchor in block %d\n", sbi->s_anchor[i]);
> + }
> + udf_debug("Using anchor in block %d\n", sbi->s_anchor[i]);
>
> for (i = 0; i < sbi->s_partitions; i++) {
> kernel_lb_addr uninitialized_var(ino);
> --
> 1.5.3.7
>
Honza
--
Jan Kara <jack@suse.cz>
SUSE Labs, CR
next prev parent reply other threads:[~2008-01-10 23:31 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04 ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14 ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15 ` Jan Kara
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` [PATCH 08/16] udf: fix coding style marcin.slusarz
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19 ` Jan Kara
2008-01-10 22:06 ` [PATCH 10/16] udf: create common function for changing free space counter marcin.slusarz
2008-01-10 23:24 ` Jan Kara
2008-01-12 13:13 ` Marcin Slusarz
2008-01-14 9:56 ` Jan Kara
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26 ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28 ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30 ` Jan Kara [this message]
2008-01-11 9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080110233051.GI17430@duck.suse.cz \
--to=jack@suse.cz \
--cc=hch@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marcin.slusarz@gmail.com \
--subject='Re: [PATCH 16/16] udf: improve readability of udf_load_partition' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).