LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Marcin Slusarz <marcin.slusarz@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
Christoph Hellwig <hch@infradead.org>
Subject: Re: [PATCH 10/16] udf: create common function for changing free space counter
Date: Mon, 14 Jan 2008 10:56:55 +0100 [thread overview]
Message-ID: <20080114095655.GA4214@duck.suse.cz> (raw)
In-Reply-To: <20080112131309.GA24828@joi>
On Sat 12-01-08 14:13:31, Marcin Slusarz wrote:
> On Fri, Jan 11, 2008 at 12:24:49AM +0100, Jan Kara wrote:
> > On Thu 10-01-08 23:06:26, marcin.slusarz@gmail.com wrote:
> > > Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
> > > CC: Jan Kara <jack@suse.cz>
> > > CC: Christoph Hellwig <hch@infradead.org>
> > Just two minor comment...
> >
> > > ---
> > > fs/udf/balloc.c | 49 ++++++++++++++++++++-----------------------------
> > > 1 files changed, 20 insertions(+), 29 deletions(-)
> > >
> > > diff --git a/fs/udf/balloc.c b/fs/udf/balloc.c
> > > index dc9f8a9..78dbf1d 100644
> > > --- a/fs/udf/balloc.c
> > > +++ b/fs/udf/balloc.c
> > > @@ -140,6 +140,20 @@ static inline int load_block_bitmap(struct super_block *sb,
> > > return slot;
> > > }
> > >
> > > +static bool udf_inc_free_space(struct udf_sb_info *sbi,
> > Maybe because you use the function for both increasing and decreasing
> > free space, you could call is udf_add_free_space?
> Ok. Done.
>
> >
> > > + u16 partition, u32 cnt)
> > > +{
> > > + struct logicalVolIntegrityDesc *lvid;
> > > +
> > > + if (sbi->s_lvid_bh)
> > > + return false;
> > > +
> > > + lvid = (struct logicalVolIntegrityDesc *)sbi->s_lvid_bh->b_data;
> > > + lvid->freeSpaceTable[partition] = cpu_to_le32(le32_to_cpu(
> > > + lvid->freeSpaceTable[partition]) + cnt);
> > I think macro like le32_add_cpu() just went into the kernel so you could
> > use that...
> I didn't want to rely on too many patches, so I intentionally left it.
> I'll convert it together with other le*_add_cpu changes.
OK, fair enough.
> Can you ack this patch with udf_inc_free_space rename?
Yes.
Acked-by: Jan Kara <jack@suse.cz>
Honza
--
Jan Kara <jack@suse.cz>
SUSE Labs, CR
next prev parent reply other threads:[~2008-01-14 9:57 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-01-10 22:06 [PATCH 00/16] udf: cleanup marcin.slusarz
2008-01-10 22:06 ` [PATCH 01/16] udf: fix coding style of super.c marcin.slusarz
2008-01-10 22:06 ` [PATCH 02/16] udf: remove some ugly macros marcin.slusarz
2008-01-10 22:06 ` [PATCH 03/16] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function marcin.slusarz
2008-01-10 22:06 ` [PATCH 04/16] udf: check if udf_load_logicalvol failed marcin.slusarz
2008-01-10 23:04 ` Jan Kara
2008-01-10 22:06 ` [PATCH 05/16] udf: convert macros related to bitmaps to functions marcin.slusarz
2008-01-10 23:14 ` Jan Kara
2008-01-10 22:06 ` [PATCH 06/16] udf: move calculating of nr_groups into helper function marcin.slusarz
2008-01-10 23:15 ` Jan Kara
2008-01-10 22:06 ` [PATCH 07/16] udf: fix sparse warnings (shadowing & mismatch between declaration and definition) marcin.slusarz
2008-01-10 22:06 ` [PATCH 08/16] udf: fix coding style marcin.slusarz
2008-01-10 22:06 ` [PATCH 09/16] udf: create common function for tag checksumming marcin.slusarz
2008-01-10 23:19 ` Jan Kara
2008-01-10 22:06 ` [PATCH 10/16] udf: create common function for changing free space counter marcin.slusarz
2008-01-10 23:24 ` Jan Kara
2008-01-12 13:13 ` Marcin Slusarz
2008-01-14 9:56 ` Jan Kara [this message]
2008-01-10 22:06 ` [PATCH 11/16] udf: replace loops coded with goto to real loops marcin.slusarz
2008-01-10 23:26 ` Jan Kara
2008-01-10 22:06 ` [PATCH 12/16] udf: convert byte order of constant instead of variable marcin.slusarz
2008-01-10 22:06 ` [PATCH 13/16] udf: remove UDF_I_* macros and open code them marcin.slusarz
2008-01-10 22:06 ` [PATCH 14/16] udf: cache struct udf_inode_info marcin.slusarz
2008-01-10 22:06 ` [PATCH 15/16] udf: fix udf_debug macro marcin.slusarz
2008-01-10 23:28 ` Jan Kara
2008-01-10 22:06 ` [PATCH 16/16] udf: improve readability of udf_load_partition marcin.slusarz
2008-01-10 23:30 ` Jan Kara
2008-01-11 9:33 ` [PATCH 00/16] udf: cleanup Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080114095655.GA4214@duck.suse.cz \
--to=jack@suse.cz \
--cc=hch@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marcin.slusarz@gmail.com \
--subject='Re: [PATCH 10/16] udf: create common function for changing free space counter' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).