LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* Re: [Devel] LTP result output for container-init ( failure with 2.6.24 kernel )
       [not found] ` <47986165.4050407@openvz.org>
@ 2008-01-29 16:12   ` Rishikesh K Rajak
  2008-01-29 17:43     ` Serge E. Hallyn
  0 siblings, 1 reply; 2+ messages in thread
From: Rishikesh K Rajak @ 2008-01-29 16:12 UTC (permalink / raw)
  To: Pavel Emelyanov, vgusev
  Cc: balbir, containers, Poornima Nayak, serue, sukadev, linux-kernel,
	Andrew Morton



Hi Pavel/Vitaliy,

Pavel Emelyanov <xemul@openvz.org> wrote on 01/24/2008 03:29:01 PM:

> Rishikesh K. Rajak wrote:
> > Hi All,
> >
> > Today i ran full LTP on kernel 2.6.24-rc6 inside container-init and
also
> > on parent namespace and got some observations.
> >
> > Here is the machine information:
> >     Linux rishi.in.ibm.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT
> > 2007 i686 i686 i386 GNU/Linux
> >
> >     OS: SLES 10
> >
> > I found these fcntl are failing inside container and it pass on parent
> > namespace. I am attaching the log file with this mail.
> >
> > These failures are conceding with 2.6.23-mm1 itself. Just wanted to
know
> > if someone is working on this still.
> >
> >   fcntl11                        FAIL
> >   fcntl14                        FAIL
> >   fcntl17                        FAIL
> >   fcntl19                        FAIL
> >   fcntl20                        FAIL
> >   fcntl21                        FAIL

Today, I tested 2.6.24 kernel and ran LTP inside container, and found that
the above failure is still existing.
These failures are not occuring when i run LTP in parent namespace.

>
> As I already said, these are fixed in -mm tree with the
> pid-namespaces-vs-locks-interaction.patch patch.

I verified, the above patch is still not applied with 2.6.24 kernel.

Parden me ! if i have missed some earlier mail thread.

But one good thing, no syslog failure :)

Thanks
Rishi
>
> > And also other observation was:
> >
> > syslog is failing inside parent namespace but pass inside
> > container-init.
> >
> > syslog01                       FAIL
> > 1
> > syslog02                       FAIL
> > 1
> > syslog08                       FAIL
> > 1
>
> What really bothers me in this case is that in the "output"
> file you attached I see
>
> <<<test_output>>>
> syslog08    0  INFO  :   Test all the facilities at a particular level.
> syslog08    0  INFO  :   Facilities available are: LOG_KERN,
> LOG_USER, LOG_MAIL
> syslog08    0  INFO  :   LOG_DAEMON, LOG_AUTH, LOG_LPR.
> syslog08    0  INFO  :   Don't know how to send kernel messages from
syslog()
> syslog08    0  INFO  :   o Create seperate entries in config file
> for each facility.
> syslog08    0  INFO  :   o Send the message and grep for the entry
> in log file.
>
> syslog08    0  INFO  :  syslog: Testing all the facilities
>
> syslog08    0  INFO  :  Doing facility: user...
> syslog08    0  INFO  :  Restart /etc/init.d/syslog
> syslog08    0  INFO  :   Facility user passed
> syslog08    0  INFO  :  Doing facility: mail...
> syslog08    0  INFO  :  Restart /etc/init.d/syslog
> syslog08    0  INFO  :   Facility mail failed
> syslog08    0  INFO  :  Doing facility: daemon...
> syslog08    0  INFO  :  Restart /etc/init.d/syslog
> syslog08    0  INFO  :   Facility daemon passed
> syslog08    0  INFO  :  Doing facility: auth...
> syslog08    0  INFO  :  Restart /etc/init.d/syslog
> syslog08    0  INFO  :   Facility auth passed
> syslog08    0  INFO  :  Doing facility: lpr...
> syslog08    0  INFO  :  Restart /etc/init.d/syslog
> syslog08    0  INFO  :   Facility lpr passed
> syslog08    1  PASS  :  some facilities failed to work
> syslog08    0  INFO  :  restart /etc/init.d/syslog
>
> The says it passed, but the status is "some facilities failed to
> work" and the log file says that the test failed %)
>
> I launched ltp on my box but the 01, 02 and 08 syslog tests
> passed... I have a CentOS 4 setup on this node, maybe this
> is a SuSE issue? Rishikesh, can you try this on another OS?
>
> > Please let me know your opinion on this.
> >
> > Thanks
> >
> > Rishi
> > IBM LTC
> > Bangalore
> >
> >
> >
> >
------------------------------------------------------------------------
> >
> > _______________________________________________
> > Containers mailing list
> > Containers@lists.linux-foundation.org
> > https://lists.linux-foundation.org/mailman/listinfo/containers
> >
> >
> >
------------------------------------------------------------------------
> >
> > _______________________________________________
> > Devel mailing list
> > Devel@openvz.org
> > https://openvz.org/mailman/listinfo/devel
>


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [Devel] LTP result output for container-init ( failure with 2.6.24 kernel )
  2008-01-29 16:12   ` [Devel] LTP result output for container-init ( failure with 2.6.24 kernel ) Rishikesh K Rajak
@ 2008-01-29 17:43     ` Serge E. Hallyn
  0 siblings, 0 replies; 2+ messages in thread
From: Serge E. Hallyn @ 2008-01-29 17:43 UTC (permalink / raw)
  To: Rishikesh K Rajak
  Cc: Pavel Emelyanov, vgusev, balbir, containers, Poornima Nayak,
	serue, sukadev, linux-kernel, Andrew Morton

Quoting Rishikesh K Rajak (risrajak@in.ibm.com):
> 
> 
> Hi Pavel/Vitaliy,
> 
> Pavel Emelyanov <xemul@openvz.org> wrote on 01/24/2008 03:29:01 PM:
> 
> > Rishikesh K. Rajak wrote:
> > > Hi All,
> > >
> > > Today i ran full LTP on kernel 2.6.24-rc6 inside container-init and
> also
> > > on parent namespace and got some observations.
> > >
> > > Here is the machine information:
> > >     Linux rishi.in.ibm.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT
> > > 2007 i686 i686 i386 GNU/Linux
> > >
> > >     OS: SLES 10
> > >
> > > I found these fcntl are failing inside container and it pass on parent
> > > namespace. I am attaching the log file with this mail.
> > >
> > > These failures are conceding with 2.6.23-mm1 itself. Just wanted to
> know
> > > if someone is working on this still.
> > >
> > >   fcntl11                        FAIL
> > >   fcntl14                        FAIL
> > >   fcntl17                        FAIL
> > >   fcntl19                        FAIL
> > >   fcntl20                        FAIL
> > >   fcntl21                        FAIL
> 
> Today, I tested 2.6.24 kernel and ran LTP inside container, and found that
> the above failure is still existing.
> These failures are not occuring when i run LTP in parent namespace.

Vitaliy's fix is in 2.6.24-rc8-mm1, but not in 2.6.24.

thanks,
-serge

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2008-01-29 17:43 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <1200497268.3999.17.camel@localhost.localdomain>
     [not found] ` <47986165.4050407@openvz.org>
2008-01-29 16:12   ` [Devel] LTP result output for container-init ( failure with 2.6.24 kernel ) Rishikesh K Rajak
2008-01-29 17:43     ` Serge E. Hallyn

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).