LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Gene Heskett <gene.heskett@gmail.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: Jeff Garzik <jeff@garzik.org>, Chris Rankin <rankincj@yahoo.com>,
	linux-ide@vger.kernel.org, LKML <linux-kernel@vger.kernel.org>
Subject: Re: [BUG] 2.6.24 refuses to boot - ATA problem?
Date: Sun, 03 Feb 2008 01:25:23 -0500	[thread overview]
Message-ID: <200802030125.24663.gene.heskett@gmail.com> (raw)
In-Reply-To: <20080203055807.GA25545@elte.hu>

On Sunday 03 February 2008, Ingo Molnar wrote:
>* Gene Heskett <gene.heskett@gmail.com> wrote:
>> I believe its the same, but lemme paste it for sure, yes:
>> [   26.339926] ENABLING IO-APIC IRQs
>> [   26.340119] ..TIMER: vector=0x31 apic1=0 pin1=0 apic2=-1 pin2=-1
>> [   26.350129] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
>> [   26.350182] ...trying to set up timer (IRQ0) through the 8259A ... 
>> failed. [   26.350185] ...trying to set up timer as Virtual Wire IRQ...
>> failed. [   26.360186] ...trying to set up timer as ExtINT IRQ... works.
>>
>> The third line is the only line that makes it to the screen during the
>> boot trace.
>>
>> Now, what does this tell us?
>
>the question would be:
>
> - if you remove the acpi_use_timer_override boot flag
> - and if you boot a kernel with this hack applied
>
>=> do those weird PATA failures come back?
>
>If the failues do _not_ come back then the problem is somehow
>affected/worked-around by the IO-APIC code that generates the above 4
>lines. If the failures are still the same then the above 4 lines are
>really just an uninteresting side-effect of the acpi_use_timer_override
>flag - and the real side-effects (that fixes PATA on your box) are to be
>found elsewhere.
>
>Sadly, the latter variant is the expected answer.
>
>	Ingo

And at this point, I can't tell.  This reboot was from a cold start, without 
the argument, and cold by long enough to make the rounds about the house and 
pick up a beer, but not take my evening pillbox.  A minute cold, maybe 2 max.  
The log is clean since except for a kudzu nag of some sort:

[   50.535388] warning: process `kudzu' used the deprecated sysctl system call 
with 1.23.

which isn't your problem, but fedora's.

As I said before, that error has not returned since the first time I used that 
argument, and I have booted several times now without it.  Uptime now is just 
over an hour though, so I'm not taking bets just yet. :)

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Now I lay me down to sleep
I pray the double lock will keep;
May no brick through the window break,
And, no one rob me till I awake.

  reply	other threads:[~2008-02-03  6:26 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <745427.71265.qm@web52907.mail.re2.yahoo.com>
2008-02-03  1:37 ` Jeff Garzik
2008-02-03  3:43   ` Gene Heskett
2008-02-03  4:44     ` Ingo Molnar
2008-02-03  4:50       ` Ingo Molnar
2008-02-03  5:11       ` Gene Heskett
2008-02-03  5:58         ` Ingo Molnar
2008-02-03  6:25           ` Gene Heskett [this message]
2008-02-04 19:13             ` Mark Lord
2008-02-05  4:44               ` Gene Heskett
2008-02-02 23:40 Chris Rankin
2008-02-03  0:38 ` Daniel Hazelton
2008-02-03 17:36   ` Jeff Garzik
2008-02-03 18:16     ` Daniel Hazelton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200802030125.24663.gene.heskett@gmail.com \
    --to=gene.heskett@gmail.com \
    --cc=jeff@garzik.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=rankincj@yahoo.com \
    --subject='Re: [BUG] 2.6.24 refuses to boot - ATA problem?' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).