LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Gene Heskett <gene.heskett@gmail.com>
Cc: Jeff Garzik <jeff@garzik.org>, Chris Rankin <rankincj@yahoo.com>,
	linux-ide@vger.kernel.org, LKML <linux-kernel@vger.kernel.org>
Subject: Re: [BUG] 2.6.24 refuses to boot - ATA problem?
Date: Sun, 3 Feb 2008 05:50:40 +0100	[thread overview]
Message-ID: <20080203045040.GA12160@elte.hu> (raw)
In-Reply-To: <20080203044428.GA10139@elte.hu>


* Ingo Molnar <mingo@elte.hu> wrote:

> > [   27.097095] ENABLING IO-APIC IRQs
> > [   27.097287] ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
> > [   27.107291] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
> > [   27.107343] ...trying to set up timer (IRQ0) through the 8259A ...  failed.
> > [   27.107346] ...trying to set up timer as Virtual Wire IRQ... failed.
> > [   27.117353] ...trying to set up timer as ExtINT IRQ... works.
> > 
> > The last 4 lines above are not logged without that argument.  So my 
> > theory ATM is that this forced the kernel to initialize something in 
> > the boards registers that it does not initialize without that 
> > command, and that its going fubar as shown in the msg quoted above 
> > is a totally random thing, perhaps dependent on the phase of one of 
> > jupiters moons as to what state it powers up in.  And I got lucky, 
> > so far in that my single powerdown reset didn't trigger it again...  
> > And you _know_ what that knocking sound is by now. :)
> 
> that's weird. Could you try the hack below and _remove_ the 
> acpi_use_timer_override flag? The change should artificially cause the 
> above 4 lines to appear again, in all cases.
> 
> This would test the following aspects of your theory: is this unknown 
> side-effect of the the acpi_use_timer_override flag related to the 
> timer setup sequence in io_apic_32.c? If not, then the difference most 
> likely lies in the different ACPI setup sequence.

i tried that patch on a box here, and it produces similar 4 lines:

[    0.172141] ENABLING IO-APIC IRQs
[    0.175498] init IO_APIC IRQs
[    0.176059]  IO-APIC (apicid-pin) 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23 not connected.
[    0.187942] ..TIMER: vector=0x31 apic1=0 pin1=0 apic2=-1 pin2=-1
[    0.233859] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
[    0.236014] ...trying to set up timer (IRQ0) through the 8259A ...  failed.
[    0.236014] ...trying to set up timer as Virtual Wire IRQ... failed.
[    0.236014] ...trying to set up timer as ExtINT IRQ... works.
[    0.277879] Using local APIC timer interrupts.

but ... in all likelyhood it's some ACPI side-effects of the 
acpi_use_timer_override flag, not really this IO-APIC/timer-setup detail 
that matters.

	Ingo

  reply	other threads:[~2008-02-03  4:51 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <745427.71265.qm@web52907.mail.re2.yahoo.com>
2008-02-03  1:37 ` Jeff Garzik
2008-02-03  3:43   ` Gene Heskett
2008-02-03  4:44     ` Ingo Molnar
2008-02-03  4:50       ` Ingo Molnar [this message]
2008-02-03  5:11       ` Gene Heskett
2008-02-03  5:58         ` Ingo Molnar
2008-02-03  6:25           ` Gene Heskett
2008-02-04 19:13             ` Mark Lord
2008-02-05  4:44               ` Gene Heskett
2008-02-02 23:40 Chris Rankin
2008-02-03  0:38 ` Daniel Hazelton
2008-02-03 17:36   ` Jeff Garzik
2008-02-03 18:16     ` Daniel Hazelton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080203045040.GA12160@elte.hu \
    --to=mingo@elte.hu \
    --cc=gene.heskett@gmail.com \
    --cc=jeff@garzik.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rankincj@yahoo.com \
    --subject='Re: [BUG] 2.6.24 refuses to boot - ATA problem?' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).