LKML Archive on
help / color / mirror / Atom feed
* netatalk slow after system upgrade (possibly kernel problem?)
@ 2008-01-25 11:55 Michael Monnerie
  2008-01-26  3:33 ` [Netatalk-admins] " Didier
  2008-01-27  6:00 ` Andrew Morton
  0 siblings, 2 replies; 7+ messages in thread
From: Michael Monnerie @ 2008-01-25 11:55 UTC (permalink / raw)
  To: netatalk-admins; +Cc: linux-kernel

[-- Attachment #1: Type: text/plain, Size: 2170 bytes --]

Dear lists,

I've been spending a LOT of time trying to find out where's the problem, 
but can't find it and therefore seek urgent help now. We have the 
following system:

Server with VMware server
-> VM running a webserver and netatalk
-> 2 other VMs not related

The VM with netatalk was SUSE 10.0 with kernel 2.6.13-15.15-smp (from 
SUSE), and things were pretty fun and quick. Then we upgraded to SUSE 
10.2 and now 10.3, where everything EXCEPT netatalk runs perfect. Since 
this upgrade, Apple clients (MacOS X) now do READ very very slowly 
(about 512KB/s over the gigabit LAN), while writing to the server still 
is normal (>20MB/s). I've even retried with the newest kernel, tried different /proc/sys/net/ipv4/tcp_congestion_control 
(cubic, reno, bic, etc.) and nothing helps. I've then tried to install 
Samba and found that we have similar problems reading with it from 
MacOS clients. Now I'm pretty sure it should be something with the 
linux kernel, but I don't understand what.

Here are the wireshark dumps in pcap format:
-> you can see writing to the server ( is normal and fast
-> reading is horribly slow. Lots of "unknown", because of netatalk or 
-> another dump while reading, you see "unknown" reads. I'm not sure if 
it's just wireshark not understanding the packets or netatalk.

And trying with samba:
you can see that it's also slow.

Now why did it work with the old 2.6.13 kernel? I still have that old 
VM, and when I start it, it is always perfectly fast. Only newer 
versions are slow. Can somebody give me a hint please?

mfg zmi
// Michael Monnerie, Ing.BSc    -----
// Tel: 0676/846 914 666                      .network.your.ideas.
// PGP Key:         "curl -s | gpg --import"
// Fingerprint: AC19 F9D5 36ED CD8A EF38  500E CE14 91F7 1C12 09B4
// Keyserver:                   Key-ID: 1C1209B4

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread
* Re: netatalk slow after system upgrade (possibly kernel problem?)
@ 2008-01-27 13:34 Rachel Greenham
  0 siblings, 0 replies; 7+ messages in thread
From: Rachel Greenham @ 2008-01-27 13:34 UTC (permalink / raw)
  To: linux-kernel

(this thread came up in searching about the problem myself, so joined  
to post this, hence the 'broken' threading, I expect:)

Andrew Morton asked:

> It would be interesting if this could be repeated on bare hardware,  
> so we
> can eliminate the possibility that it is some weird interaction with  
> vmware.

I can confirm this; I'm seeing exactly these symptoms where the linux  
box running netatalk is running natively, not in VMWare. VMWare server  
is *installed* but only running in the sense that the vmnet interfaces  
are active.

Which begs an obvious test... There's no change when I kill the vmware  
networking (and all other) services. It still reckons it's going to  
take 24 minutes to transfer a file a little under a gigabyte.

Although, in fact, this thread does present a likely temporary  
workaround; to install a linux with an older kernel into vmware and  
use that to serve my content. :-D

That Linux system is Ubuntu Gutsy all up to date on amd64.

rachel@mab:~$ uname -a
Linux mab.local 2.6.22-14-generic #1 SMP Tue Dec 18 05:28:27 UTC 2007  
x86_64 GNU/Linux

netatalk 2.0.3-6ubuntu1 (built with ssl)

I'm getting between 500KB/s and 1MB/s on copies from that machine to a  
couple of macs on the local (gigabit) LAN. (They're both Intel macs  
running Leopard all up to date.)

Conversely I'm getting between 20MB/s and 40MB/s on copies from the  
macs to the netatalk server. (The variance is between the macs; one of  
them seems to be copying about twice as fast as the other probably due  
to issues of their own, but both clearly show that reading from  
netatalk is heavily crippled.

NB: I also posted this as a bug on ubuntu launchpad here:

But I noticed your precise question and thought I'd answer it. Don't  
know how useful I can be in here but I can certainly respond to  
requests for further info.


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2008-03-12  2:27 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-01-25 11:55 netatalk slow after system upgrade (possibly kernel problem?) Michael Monnerie
2008-01-26  3:33 ` [Netatalk-admins] " Didier
2008-01-27  6:00 ` Andrew Morton
2008-02-05 15:26   ` Michael Monnerie
     [not found]     ` <>
2008-02-07  0:49       ` [Netatalk-admins] " Michael Monnerie
2008-03-12  2:26   ` Michael Monnerie
2008-01-27 13:34 Rachel Greenham

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).