LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* netatalk slow after system upgrade (possibly kernel problem?)
@ 2008-01-25 11:55 Michael Monnerie
  2008-01-26  3:33 ` [Netatalk-admins] " Didier
  2008-01-27  6:00 ` Andrew Morton
  0 siblings, 2 replies; 6+ messages in thread
From: Michael Monnerie @ 2008-01-25 11:55 UTC (permalink / raw)
  To: netatalk-admins; +Cc: linux-kernel

[-- Attachment #1: Type: text/plain, Size: 2170 bytes --]

Dear lists,

I've been spending a LOT of time trying to find out where's the problem, 
but can't find it and therefore seek urgent help now. We have the 
following system:

Server with VMware server
-> VM running a webserver and netatalk
-> 2 other VMs not related

The VM with netatalk was SUSE 10.0 with kernel 2.6.13-15.15-smp (from 
SUSE), and things were pretty fun and quick. Then we upgraded to SUSE 
10.2 and now 10.3, where everything EXCEPT netatalk runs perfect. Since 
this upgrade, Apple clients (MacOS X) now do READ very very slowly 
(about 512KB/s over the gigabit LAN), while writing to the server still 
is normal (>20MB/s). I've even retried with the newest kernel 
2.6.23.13, tried different /proc/sys/net/ipv4/tcp_congestion_control 
(cubic, reno, bic, etc.) and nothing helps. I've then tried to install 
Samba and found that we have similar problems reading with it from 
MacOS clients. Now I'm pretty sure it should be something with the 
linux kernel, but I don't understand what.

Here are the wireshark dumps in pcap format:
http://zmi.at/x/atalk-write-fast.pcap
-> you can see writing to the server (192.168.120.9) is normal and fast

http://zmi.at/x/atalk-read-slow.pcap
-> reading is horribly slow. Lots of "unknown", because of netatalk or 
what?

http://zmi.at/x/unknown-atalk.pcap
-> another dump while reading, you see "unknown" reads. I'm not sure if 
it's just wireshark not understanding the packets or netatalk.

And trying with samba:
http://zmi.at/x/smb-read-slow.pcap
http://zmi.at/x/smb-write-quick.pcap
you can see that it's also slow.

Now why did it work with the old 2.6.13 kernel? I still have that old 
VM, and when I start it, it is always perfectly fast. Only newer 
versions are slow. Can somebody give me a hint please?

mfg zmi
-- 
// Michael Monnerie, Ing.BSc    -----      http://it-management.at
// Tel: 0676/846 914 666                      .network.your.ideas.
// PGP Key:         "curl -s http://zmi.at/zmi.asc | gpg --import"
// Fingerprint: AC19 F9D5 36ED CD8A EF38  500E CE14 91F7 1C12 09B4
// Keyserver: www.keyserver.net                   Key-ID: 1C1209B4

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2008-03-12  2:27 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-01-25 11:55 netatalk slow after system upgrade (possibly kernel problem?) Michael Monnerie
2008-01-26  3:33 ` [Netatalk-admins] " Didier
2008-01-27  6:00 ` Andrew Morton
2008-02-05 15:26   ` Michael Monnerie
     [not found]     ` <73F08C2B-C3F9-4846-962E-A3D2692804E0@supported.de>
2008-02-07  0:49       ` [Netatalk-admins] " Michael Monnerie
2008-03-12  2:26   ` Michael Monnerie

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).