LKML Archive on
help / color / mirror / Atom feed
From: Henrique de Moraes Holschuh <>
To: "Richard Purdie" <>,
	"Márton Németh" <>
Cc: LKML <>
Subject: Re: [GIT PULL] LED updates
Date: Thu, 7 Feb 2008 19:38:45 -0200	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

On Thu, 07 Feb 2008, Richard Purdie wrote:
> Márton Németh:
>       leds: Add support for hardware accelerated LED flashing
>       leds: hw acceleration for Clevo mail LED driver

This one has a loose end: when you call brightness_set on a led with
hardware flash acceleration, you will leave the trigger armed, BUT the led
won't blink anymore.  That's just wrong.

Either we should always remove *any* (hardware accelerated or not!) active
trigger when a write to brightness_set is done, or the stuff about "calling
brightness_set will disable the hardware accelerated blink" has to go.

I personally prefer that we would always remove any active trigger if
brightness_set is to be called.  IMHO, it is neater, and it is also the
least-surprise-behaviour from an user perspective with the LED_OFF:LED_FULL
triggers we have right now.

Which one will be?  If it is "remove any active trigger", I'd not mind
writing the patch.

> Richard Purdie:
>       leds: Standardise LED naming scheme

This one causes trouble (at least on 2.6.23 -- I backported the patch) due
to the 20-byte length limit on sysfs names.  I had to use "tp::<somecrap>"
instead of "thinkpad::<somecrap>" to name LEDs, and still had to reduce
ultrabase_battery to ultrabase_batt :-)

Anyway, IMHO, the LED function should come first, and we should not even
need the led driver name anywhere.  In case of clashes in the class sysfs
dir, just tack a .# to the end or somesuch.  The device the LED is tied to
already differentiates them.  That would save a lot of chars for something
much more useful (the function).

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

  reply	other threads:[~2008-02-07 21:40 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-02-07 10:35 Richard Purdie
2008-02-07 21:38 ` Henrique de Moraes Holschuh [this message]
2008-02-07 22:13   ` Richard Purdie
2008-02-07 23:23     ` [PATCH] leds: disable triggers on brightness set Henrique de Moraes Holschuh
2008-02-10 11:52       ` Németh Márton
2008-02-17 23:30         ` Richard Purdie
2008-02-18  1:59           ` Henrique de Moraes Holschuh
2008-02-08  7:03     ` [GIT PULL] LED updates Németh Márton
2008-02-08 11:20       ` Henrique de Moraes Holschuh
2008-02-10 11:52         ` Németh Márton
2008-03-16 18:18     ` Henrique de Moraes Holschuh
2008-03-16 19:29       ` Richard Purdie
2008-03-16 19:48         ` Henrique de Moraes Holschuh
2008-03-17  3:34           ` LED naming standard for LED class Henrique de Moraes Holschuh
2008-03-17  9:51             ` Richard Purdie
2008-03-18  3:35               ` Henrique de Moraes Holschuh
2008-03-18  4:55                 ` Henrique de Moraes Holschuh
  -- strict thread matches above, loose matches on Subject: below --
2007-10-11 21:38 [GIT PULL] LED updates Richard Purdie
2007-07-16  8:39 Richard Purdie
2007-02-15 22:18 Richard Purdie

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \
    --subject='Re: [GIT PULL] LED updates' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).