LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
@ 2008-02-12  7:40 Kamalesh Babulal
  2008-02-12  7:59 ` Andrew Morton
  0 siblings, 1 reply; 6+ messages in thread
From: Kamalesh Babulal @ 2008-02-12  7:40 UTC (permalink / raw)
  To: Ivan Kokshaysky
  Cc: LKML, Adrian Bunk, Andrew Morton, Richard Henderson, tony.luck,
	anton, paulus, rusty

This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
in the 2.6.25-rc1-git1.

drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
make[2]: *** [drivers/input/mouse] Error 2
make[1]: *** [drivers/input] Error 2

The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
2.6.25-rc1-git(s). Is there any new patch i am missing out.
-- 
Thanks & Regards,
Kamalesh Babulal,
Linux Technology Center,
IBM, ISTL.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
  2008-02-12  7:40 [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base Kamalesh Babulal
@ 2008-02-12  7:59 ` Andrew Morton
  2008-02-12  9:36   ` Adrian Bunk
  0 siblings, 1 reply; 6+ messages in thread
From: Andrew Morton @ 2008-02-12  7:59 UTC (permalink / raw)
  To: Kamalesh Babulal
  Cc: Ivan Kokshaysky, LKML, Adrian Bunk, Richard Henderson, tony.luck,
	anton, paulus, rusty

On Tue, 12 Feb 2008 13:10:02 +0530 Kamalesh Babulal <kamalesh@linux.vnet.ibm.com> wrote:

> This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
> in the 2.6.25-rc1-git1.
> 
> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
> make[2]: *** [drivers/input/mouse] Error 2
> make[1]: *** [drivers/input] Error 2
> 
> The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
> 2.6.25-rc1-git(s). Is there any new patch i am missing out.

I have it queued up, along with quite a few other things, but for the next
couple of days I have logistical problems which are preventing me from
doing runtime testing.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
  2008-02-12  7:59 ` Andrew Morton
@ 2008-02-12  9:36   ` Adrian Bunk
  2008-02-12  9:47     ` Kamalesh Babulal
  0 siblings, 1 reply; 6+ messages in thread
From: Adrian Bunk @ 2008-02-12  9:36 UTC (permalink / raw)
  To: Andrew Morton
  Cc: Kamalesh Babulal, Ivan Kokshaysky, LKML, Richard Henderson,
	tony.luck, anton, paulus, rusty

On Mon, Feb 11, 2008 at 11:59:29PM -0800, Andrew Morton wrote:
> On Tue, 12 Feb 2008 13:10:02 +0530 Kamalesh Babulal <kamalesh@linux.vnet.ibm.com> wrote:
> 
> > This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
> > in the 2.6.25-rc1-git1.
> > 
> > drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> > drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> > make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
> > make[2]: *** [drivers/input/mouse] Error 2
> > make[1]: *** [drivers/input] Error 2
> > 
> > The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
> > 2.6.25-rc1-git(s). Is there any new patch i am missing out.
> 
> I have it queued up, along with quite a few other things, but for the next
> couple of days I have logistical problems which are preventing me from
> doing runtime testing.

And this really isn't a regression.

It seems Kamalesh has upgraded his gcc to 4.2 between trying 
2.6.24-git18 and trying 2.6.25-rc1-git1?

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
  2008-02-12  9:36   ` Adrian Bunk
@ 2008-02-12  9:47     ` Kamalesh Babulal
  2008-02-12  9:55       ` Adrian Bunk
  0 siblings, 1 reply; 6+ messages in thread
From: Kamalesh Babulal @ 2008-02-12  9:47 UTC (permalink / raw)
  To: Adrian Bunk
  Cc: Andrew Morton, Ivan Kokshaysky, LKML, Richard Henderson,
	tony.luck, anton, paulus, rusty

Adrian Bunk wrote:
> On Mon, Feb 11, 2008 at 11:59:29PM -0800, Andrew Morton wrote:
>> On Tue, 12 Feb 2008 13:10:02 +0530 Kamalesh Babulal <kamalesh@linux.vnet.ibm.com> wrote:
>>
>>> This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
>>> in the 2.6.25-rc1-git1.
>>>
>>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
>>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
>>> make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
>>> make[2]: *** [drivers/input/mouse] Error 2
>>> make[1]: *** [drivers/input] Error 2
>>>
>>> The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
>>> 2.6.25-rc1-git(s). Is there any new patch i am missing out.
>> I have it queued up, along with quite a few other things, but for the next
>> couple of days I have logistical problems which are preventing me from
>> doing runtime testing.
> 
> And this really isn't a regression.
> 
> It seems Kamalesh has upgraded his gcc to 4.2 between trying 
> 2.6.24-git18 and trying 2.6.25-rc1-git1?
> 
> cu
> Adrian
> 
Hi Adrian,

I am using the gcc version

gcc (GCC) 4.2.3 20071014 (prerelease) (Debian 4.2.2-3)

It has been the same gcc version from 2.6.24-git18 to 2.6.25-rc1-git{1,2).
This build failure is seen from 2.6.24-git18 and is still seen in 2.6.25-rc1-git{1,2}.

-- 
Thanks & Regards,
Kamalesh Babulal,
Linux Technology Center,
IBM, ISTL.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
  2008-02-12  9:47     ` Kamalesh Babulal
@ 2008-02-12  9:55       ` Adrian Bunk
  2008-02-12 12:10         ` Kamalesh Babulal
  0 siblings, 1 reply; 6+ messages in thread
From: Adrian Bunk @ 2008-02-12  9:55 UTC (permalink / raw)
  To: Kamalesh Babulal
  Cc: Andrew Morton, Ivan Kokshaysky, LKML, Richard Henderson,
	tony.luck, anton, paulus, rusty

On Tue, Feb 12, 2008 at 03:17:02PM +0530, Kamalesh Babulal wrote:
> Adrian Bunk wrote:
> > On Mon, Feb 11, 2008 at 11:59:29PM -0800, Andrew Morton wrote:
> >> On Tue, 12 Feb 2008 13:10:02 +0530 Kamalesh Babulal <kamalesh@linux.vnet.ibm.com> wrote:
> >>
> >>> This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
> >>> in the 2.6.25-rc1-git1.
> >>>
> >>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> >>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
> >>> make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
> >>> make[2]: *** [drivers/input/mouse] Error 2
> >>> make[1]: *** [drivers/input] Error 2
> >>>
> >>> The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
> >>> 2.6.25-rc1-git(s). Is there any new patch i am missing out.
> >> I have it queued up, along with quite a few other things, but for the next
> >> couple of days I have logistical problems which are preventing me from
> >> doing runtime testing.
> > 
> > And this really isn't a regression.
> > 
> > It seems Kamalesh has upgraded his gcc to 4.2 between trying 
> > 2.6.24-git18 and trying 2.6.25-rc1-git1?
> > 
> > cu
> > Adrian
> > 
> Hi Adrian,
> 
> I am using the gcc version
> 
> gcc (GCC) 4.2.3 20071014 (prerelease) (Debian 4.2.2-3)
> 
> It has been the same gcc version from 2.6.24-git18 to 2.6.25-rc1-git{1,2).
> This build failure is seen from 2.6.24-git18 and is still seen in 2.6.25-rc1-git{1,2}.

I misread what you meant with the word "from".

But my point is still that this is not a regression in the kernel but a 
problem when using gcc 4.2 on powerpc (no matter whether the kernel or 
gcc is wrong in this case).

Or am I wrong here and you are able to compile older powerpc kernels 
with the same gcc and .config?

> Kamalesh Babulal,

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base
  2008-02-12  9:55       ` Adrian Bunk
@ 2008-02-12 12:10         ` Kamalesh Babulal
  0 siblings, 0 replies; 6+ messages in thread
From: Kamalesh Babulal @ 2008-02-12 12:10 UTC (permalink / raw)
  To: Adrian Bunk
  Cc: Andrew Morton, Ivan Kokshaysky, LKML, Richard Henderson,
	tony.luck, anton, paulus, rusty

Adrian Bunk wrote:
> On Tue, Feb 12, 2008 at 03:17:02PM +0530, Kamalesh Babulal wrote:
>> Adrian Bunk wrote:
>>> On Mon, Feb 11, 2008 at 11:59:29PM -0800, Andrew Morton wrote:
>>>> On Tue, 12 Feb 2008 13:10:02 +0530 Kamalesh Babulal <kamalesh@linux.vnet.ibm.com> wrote:
>>>>
>>>>> This build failure is seen on the powerpc from the 2.6.24-git18 kernel and is still visible
>>>>> in the 2.6.25-rc1-git1.
>>>>>
>>>>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
>>>>> drivers/input/mouse/psmouse-base.c:44: error: __param_proto causes a section type conflict
>>>>> make[3]: *** [drivers/input/mouse/psmouse-base.o] Error 1
>>>>> make[2]: *** [drivers/input/mouse] Error 2
>>>>> make[1]: *** [drivers/input] Error 2
>>>>>
>>>>> The patch http://lkml.org/lkml/2008/2/8/514 seems to have not taken into 2.6.25-rc1 and 
>>>>> 2.6.25-rc1-git(s). Is there any new patch i am missing out.
>>>> I have it queued up, along with quite a few other things, but for the next
>>>> couple of days I have logistical problems which are preventing me from
>>>> doing runtime testing.
>>> And this really isn't a regression.
>>>
>>> It seems Kamalesh has upgraded his gcc to 4.2 between trying 
>>> 2.6.24-git18 and trying 2.6.25-rc1-git1?
>>>
>>> cu
>>> Adrianhttp://sydgsa.ibm.com/gsa/sydgsa/projects/k/kernel.org/korg/
>>>
>> Hi Adrian,
>>
>> I am using the gcc version
>>
>> gcc (GCC) 4.2.3 20071014 (prerelease) (Debian 4.2.2-3)
>>
>> It has been the same gcc version from 2.6.24-git18 to 2.6.25-rc1-git{1,2).
>> This build failure is seen from 2.6.24-git18 and is still seen in 2.6.25-rc1-git{1,2}.
> 
> I misread what you meant with the word "from".
> 
> But my point is still that this is not a regression in the kernel but a 
> problem when using gcc 4.2 on powerpc (no matter whether the kernel or 
> gcc is wrong in this case).
> 
> Or am I wrong here and you are able to compile older powerpc kernels 
> with the same gcc and .config?
> 
>> Kamalesh Babulal,
> 
> cu
> Adrian
> 
Sorry for the term using "regression in the kernel", this seems not to be the regression from the 
kernel.I tried compiling older versions of kernels on the machine. I was able to reproduce the
same build failure with 2.6.23 and similar one with 2.6.22.

drivers/char/ipmi/ipmi_si_intf.c:1095: error: __param_hotmod causes a section type conflict
drivers/char/ipmi/ipmi_si_intf.c:1095: error: __param_hotmod causes a section type conflict

-- 
Thanks & Regards,
Kamalesh Babulal,
Linux Technology Center,
IBM, ISTL.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2008-02-12 12:10 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-02-12  7:40 [BUID_FAILURE] regression from 2.6.24-git18 to 2.6.25-rc1-git1 on section type conflict psmouse-base Kamalesh Babulal
2008-02-12  7:59 ` Andrew Morton
2008-02-12  9:36   ` Adrian Bunk
2008-02-12  9:47     ` Kamalesh Babulal
2008-02-12  9:55       ` Adrian Bunk
2008-02-12 12:10         ` Kamalesh Babulal

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).