LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Fabio Coatti <cova@ferrara.linux.it>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: Randy Dunlap <randy.dunlap@oracle.com>, linux-kernel@vger.kernel.org
Subject: Re: stuck with 2.6.23.14 on x86_64
Date: Wed, 13 Feb 2008 10:21:23 +0100	[thread overview]
Message-ID: <200802131021.23974.cova@ferrara.linux.it> (raw)
In-Reply-To: <200802122155.13959.rjw@sisk.pl>

Alle martedì 12 febbraio 2008, Rafael J. Wysocki ha scritto:
> On Tuesday, 12 of February 2008, Fabio Coatti wrote:
> > Alle martedì 12 febbraio 2008, Randy Dunlap ha scritto:
> > > On Tue, 12 Feb 2008 15:03:41 +0100 Fabio Coatti wrote:
> > > > Hi all,
> > > > I'm stuck in a weird situation: I'm unable to go beyond 2.6.23.14, so
> > > > to fix the splice bug I've had to apply by hand the patch. (x86_64)
> > > >
> > > > Basically, with 2.6.24.2 (the same with 2.6.24 and .1), tha machine
> > > > won't boot due to a problem with cciss driver, that prevents to find
> > > > the / partition. (bug described here: Kernel Bug Tracker Bug 9859
> > > > http://bugzilla.kernel.org/show_bug.cgi?id=9859 );
> > > >
> > > > With kernels 2.6.23, the lastest that I can compile is 2.6.23.14;
> > > > starting from .15 (and .16) I get this message:
> > > >
> > > > ======================
> > > >   UPD     include/linux/compile.h
> > > >   CC      init/version.o
> > > >   LD      init/built-in.o
> > > >   LD      .tmp_vmlinux1
> > > > drivers/built-in.o: In function `acpi_init':
> > > > bus.c:(.init.text+0x1713): undefined reference to `pm_flags'
> > > > bus.c:(.init.text+0x1756): undefined reference to `pm_flags'
> > > > ======================
> > > >
> > > > All .config are the same, (make oldconfig) beside the obvious
> > > > differences between .23 and .24
> > > >
> > > > Hardware: x86_64 AMD 2216HE
> > > > SCSI controller: HP Smart Array E200i Controller
> > > > Compiler: gcc (GCC) 4.1.1
> > > > binutils: 2.16.1
> > > >
> > > > On a x86 machine, Intel(R) Xeon(TM) CPU 3.20GHz
> > > > with a cciss0: HP Smart Array 6i Controller,
> > > > the 2.6.24.2 compiles just fine and works, so the cciss problems
> > > > seems related only to E200i controller.
> > > >
> > > > Right now, on AMD64 machines, I'm forced to patch by hand the kernel,
> > > > that's quite uncomfortable :)
> > > >
> > > > Can someone point me in the right direction to get out of this
> > > > situation? Of course I can provide any further information. (.config
> > > > not inlcuded now to avoid cluttering  )
> > > >
> > > > Thanks for any answer.
> > >
> > > a/ send .config file for the build problem above
> > > b/ How do you download and/or apply 2.6.23.{15,16} ?
> > > 	Full tarball or base tarball + patches?
> > > 	If patches, what base tree are they applied to?
> >
> > full tarball from kernel.org (.16), tried also applying patches to 2.6.23
> > vanilla.(.15,.16) Same process leads to successful compilation for .14
>
> You're not supposed to have CONFIG_PM unset and CONFIG_ACPI set at the same
> time.  The oldconfig generation must have gone wrong at one point.

Maybe it's not supposed to have this situation, but maybe you should tell this 
to the kernel itself :)

# zcat /proc/config.gz | egrep "PM|ACPI"
CONFIG_X86_64_ACPI_NUMA=y
# CONFIG_PM is not set
CONFIG_ACPI=y
# CONFIG_ACPI_PROCFS is not set

# uname -rv
2.6.23.12 #3 SMP Tue Feb 12 11:22:16 CET 2008

And you can easily get this situation from menuconfig: just fire up make 
menuconfig without any .config, go to power management options and turn 
off "Power Management support". exit and look at .config:

# CONFIG_PM is not set
CONFIG_SUSPEND_SMP_POSSIBLE=y
CONFIG_HIBERNATION_SMP_POSSIBLE=y
CONFIG_ACPI=y

Maybe if this is not supposed to be the right situation, some dependencies are 
not respected... (tested on .16)

Anyway, with .16 and CONFIG_PM set, I get this :
===================
WARNING: vmlinux.o(.text+0x1f6395): Section mismatch: reference 
to .init.data.14:pxm_to_node_map (between 'pxm_to_node' and 'node_to_pxm')
WARNING: vmlinux.o(.text+0x1f63a7): Section mismatch: reference 
to .init.data.14:node_to_pxm_map (between 'node_to_pxm' 
and '__acpi_map_pxm_to_node')
WARNING: vmlinux.o(.text+0x1f63b2): Section mismatch: reference 
to .init.data.14:pxm_to_node_map (between '__acpi_map_pxm_to_node' 
and 'acpi_get_pxm')
WARNING: vmlinux.o(.text+0x1f63bc): Section mismatch: reference 
to .init.data.14:node_to_pxm_map (between '__acpi_map_pxm_to_node' 
and 'acpi_get_pxm')
WARNING: vmlinux.o(.text+0x1f6412): Section mismatch: reference 
to .init.data.14:pxm_to_node_map (between 'acpi_map_pxm_to_node' 
and 'acpi_get_node')
WARNING: vmlinux.o(.text+0x1f6458): Section mismatch: reference 
to .init.data.14:pxm_to_node_map (between 'acpi_map_pxm_to_node' 
and 'acpi_get_node')
WARNING: vmlinux.o(.text+0x1f645f): Section mismatch: reference 
to .init.data.14:node_to_pxm_map (between 'acpi_map_pxm_to_node' 
and 'acpi_get_node')
=========================

Anyway, it booted and so far it runs without "splice" problem, thanks.


-- 
Fabio "Cova" Coatti    http://members.ferrara.linux.it/cova     
Ferrara Linux Users Group           http://ferrara.linux.it
GnuPG fp:9765 A5B6 6843 17BC A646  BE8C FA56 373A 5374 C703
Old SysOps never die... they simply forget their password.

  reply	other threads:[~2008-02-13  9:21 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-02-12 14:03 Fabio Coatti
2008-02-12 17:18 ` Randy Dunlap
2008-02-12 17:47   ` Fabio Coatti
2008-02-12 20:45     ` Randy Dunlap
2008-02-12 20:52       ` Rafael J. Wysocki
2008-02-12 20:55     ` Rafael J. Wysocki
2008-02-13  9:21       ` Fabio Coatti [this message]
2008-02-13 17:15         ` Randy Dunlap
2008-02-13 17:16         ` Randy Dunlap
2008-02-13 17:46           ` Fabio Coatti
2008-02-14  5:48         ` Len Brown
2008-02-14  8:03           ` Fabio Coatti
     [not found] <fa.d3EyknDimPJIlJNA2Y25+wmntNM@ifi.uio.no>
2008-02-13 16:05 ` mikem13
2008-02-13 19:27   ` Andrew Morton
2008-02-14  7:49     ` Fabio Coatti

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200802131021.23974.cova@ferrara.linux.it \
    --to=cova@ferrara.linux.it \
    --cc=linux-kernel@vger.kernel.org \
    --cc=randy.dunlap@oracle.com \
    --cc=rjw@sisk.pl \
    --subject='Re: stuck with 2.6.23.14 on x86_64' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).