LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: Miles Lane <miles.lane@gmail.com>
Cc: pcihpd-discuss@lists.sourceforge.net,
	Kristen Accardi <kristen.c.accardi@intel.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [Pcihpd-discuss] 2.6.25-rc3 -- SHPC hotplug driver - very long timeouts?
Date: Mon, 25 Feb 2008 20:54:41 -0800	[thread overview]
Message-ID: <20080226045441.GA4469@kroah.com> (raw)
In-Reply-To: <a44ae5cd0802252030m77bb2b9p7de615a9f863b81d@mail.gmail.com>

On Mon, Feb 25, 2008 at 11:30:03PM -0500, Miles Lane wrote:
> Hello,
> 
> When I booted this kernel, the process was hugely delayed in shpchp.
> I don't think I usually build this driver, so perhaps this is its
> standard behavior when the hardware is missing, or some such?  Or, is
> this a bug in the driver?  Either way, the timeouts seem excessively
> long.
> 
> [   24.471137] CPA self-test:
> [   24.474565]  4k 8192 large 216 gb 0 x 8408[c0000000-f7fff000] miss 0
> [   24.491200]  4k 196608 large 32 gb 0 x 196640[c0000000-f7fff000] miss 0
> [   24.503549]  4k 196608 large 32 gb 0 x 196640[c0000000-f7fff000] miss 0
> [   24.504440] ok.
> [   42.209886] shpchp: gave up waiting for init of module pci_hotplug.
> [   42.213190] shpchp: Unknown symbol acpi_run_oshp
> [   72.052520] shpchp: gave up waiting for init of module pci_hotplug.
> [   72.055826] shpchp: Unknown symbol pci_hp_change_slot_info
> [  101.931221] shpchp: gave up waiting for init of module pci_hotplug.
> [  101.934526] shpchp: Unknown symbol pci_hp_register
> [  131.789952] shpchp: gave up waiting for init of module pci_hotplug.
> [  131.793258] shpchp: Unknown symbol pci_hp_deregister
> [  161.683306] shpchp: gave up waiting for init of module pci_hotplug.
> [  161.686611] shpchp: Unknown symbol acpi_get_hp_params_from_firmware
> [  162.935681] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4

This is not a hotplug-specific bug, but rather one in the module loading
logic.  People who had seen this on -rc1 said it went away in -rc3.  I
suggest poking Rusty about it...

thanks,

greg k-h

  reply	other threads:[~2008-02-26  5:22 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-02-26  4:30 Miles Lane
2008-02-26  4:54 ` Greg KH [this message]
2008-03-04 19:37 ` [Pcihpd-discuss] " Kristen Carlson Accardi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080226045441.GA4469@kroah.com \
    --to=greg@kroah.com \
    --cc=kristen.c.accardi@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=miles.lane@gmail.com \
    --cc=pcihpd-discuss@lists.sourceforge.net \
    --subject='Re: [Pcihpd-discuss] 2.6.25-rc3 -- SHPC hotplug driver - very long timeouts?' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).