LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Mark Brown <broonie@opensource.wolfsonmicro.com>
To: Liam Girdwood <lrg@kernel.org>
Cc: Samuel Ortiz <sameo@openedhand.com>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] mfd: Core support for the WM8400 AudioPlus HiFi CODEC and PMU
Date: Wed, 10 Sep 2008 20:13:35 +0100 [thread overview]
Message-ID: <20080910191335.GA26985@rakim.wolfsonmicro.main> (raw)
In-Reply-To: <1221072422.17091.253.camel@odin>
On Wed, Sep 10, 2008 at 07:47:01PM +0100, Liam Girdwood wrote:
> On Wed, 2008-09-10 at 19:28 +0100, Mark Brown wrote:
> > +}
> > +EXPORT_SYMBOL_GPL(wm8400_block_read);
> Slight formatting difference with read and block read.
Erk, yeah. Will fix.
> > +void wm8400_notify_codec_reset(struct wm8400 *wm8400)
> > +{
> > + int i;
> > +
> > + mutex_lock(&wm8400->io_lock);
> > +
> > + /* Reset all codec registers to their initial value */
> > + for (i = 0; i < ARRAY_SIZE(wm8400->reg_cache); i++)
> > + if (reg_data[i].is_codec)
> > + wm8400->reg_cache[i] = reg_data[i].default_val;
> > +
> > + mutex_unlock(&wm8400->io_lock);
> > +}
> > +EXPORT_SYMBOL_GPL(wm8400_notify_codec_reset);
> > +
> I would probably rename this since it's really resetting the codec cache
> and not resetting the codec.
The notify in the name was supposed to cover that (implying that it's
notifying the core rather than actually doing the reset) but it's
obviously not doing the job. I think wm8400_reset_codec_reg_cache()
should be obvious enough?
> Fwiw, I've separated out the different wm8350 functions into separate
> headers - Imho, It just makes it a little easier to read.
Yeah, I considered doing that but decided that it was more trouble than
it was worth - the device has far fewer functions than the WM8350.
next prev parent reply other threads:[~2008-09-10 19:13 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-09-10 18:28 [PATCH 0/2] WM8400 support Mark Brown
2008-09-10 18:28 ` [PATCH 1/2] mfd: Core support for the WM8400 AudioPlus HiFi CODEC and PMU Mark Brown
2008-09-10 18:28 ` [PATCH 2/2] regulator: Add WM8400 regulator support Mark Brown
2008-09-10 18:39 ` Liam Girdwood
2008-09-10 19:40 ` Mark Brown
2008-09-10 19:58 ` Liam Girdwood
2008-09-10 18:47 ` [PATCH 1/2] mfd: Core support for the WM8400 AudioPlus HiFi CODEC and PMU Liam Girdwood
2008-09-10 19:13 ` Mark Brown [this message]
2008-09-10 19:38 ` Liam Girdwood
2008-09-11 10:02 ` Mark Brown
2008-09-12 10:54 ` Samuel Ortiz
2008-09-12 12:05 ` Mark Brown
2008-09-12 10:58 ` [PATCH 0/2] WM8400 support Samuel Ortiz
2008-09-16 9:42 [PATCH 0/2] WM8400 support v2 Mark Brown
2008-09-16 9:43 ` [PATCH 1/2] mfd: Core support for the WM8400 AudioPlus HiFi CODEC and PMU Mark Brown
2008-09-18 2:28 ` Andrew Morton
2008-09-18 10:29 ` Mark Brown
2008-09-22 18:33 ` Samuel Ortiz
2008-09-23 0:27 ` Liam Girdwood
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080910191335.GA26985@rakim.wolfsonmicro.main \
--to=broonie@opensource.wolfsonmicro.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lrg@kernel.org \
--cc=sameo@openedhand.com \
--subject='Re: [PATCH 1/2] mfd: Core support for the WM8400 AudioPlus HiFi CODEC and PMU' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).