LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH] wireless: fix regression caused by regulatory config option
@ 2008-10-26 17:30 Arjan van de Ven
  2008-10-26 20:09 ` John W. Linville
  2008-10-28 15:13 ` Bob Copeland
  0 siblings, 2 replies; 10+ messages in thread
From: Arjan van de Ven @ 2008-10-26 17:30 UTC (permalink / raw)
  To: torvalds; +Cc: netdev, linux-kernel, rjw, rodriguez, johannes

>From 9095a0f6005a8f50c79e51f4aaceda95e361a891 Mon Sep 17 00:00:00 2001
From: Arjan van de Ven <arjan@linux.intel.com>
Date: Sun, 26 Oct 2008 10:25:30 -0700
Subject: [PATCH] wireless: fix regression caused by regulatory config option

The default for the regulatory compatibility option is wrong;
if you picked the default you ended up with a non-functional wifi
system (at least I did on Fedora 9 with iwl4965).
I don't think even the October 2008 releases of the various distros
has the new userland so clearly the default is wrong, and also
we can't just go about deleting this in 2.6.29...

Change the default to "y" and also adjust the config text a little to
reflect this.

This patch fixes regression #11859

With thanks to Johannes Berg for the diagnostics

Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>
---
 net/wireless/Kconfig |   11 +++++------
 1 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/net/wireless/Kconfig b/net/wireless/Kconfig
index 7d82be0..646c712 100644
--- a/net/wireless/Kconfig
+++ b/net/wireless/Kconfig
@@ -16,7 +16,7 @@ config NL80211
 
 config WIRELESS_OLD_REGULATORY
 	bool "Old wireless static regulatory definitions"
-	default n
+	default y
 	---help---
 	  This option enables the old static regulatory information
 	  and uses it within the new framework. This is available
@@ -40,11 +40,10 @@ config WIRELESS_OLD_REGULATORY
 	  ieee80211_regdom module parameter. This is being phased out and you
 	  should stop using them ASAP.
 
-	  Say N unless you cannot install a new userspace application
-	  or have one currently depending on the ieee80211_regdom module
-	  parameter and cannot port it to use the new userspace interfaces.
-
-	  This is scheduled for removal for 2.6.29.
+	  Say Y unless you have installed a new userspace application.
+	  Also say Y if have one currently depending on the ieee80211_regdom
+	  module parameter and cannot port it to use the new userspace
+	  interfaces.
 
 config WIRELESS_EXT
 	bool "Wireless extensions"
-- 
1.5.6.5



-- 
Arjan van de Ven 	Intel Open Source Technology Centre
For development, discussion and tips for power savings, 
visit http://www.lesswatts.org

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2008-10-28 15:13 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-10-26 17:30 [PATCH] wireless: fix regression caused by regulatory config option Arjan van de Ven
2008-10-26 20:09 ` John W. Linville
2008-10-26 20:16   ` Linus Torvalds
2008-10-26 20:18   ` Arjan van de Ven
2008-10-26 20:22     ` Johannes Berg
2008-10-27 20:42       ` Pavel Machek
2008-10-28  7:29         ` Johannes Berg
2008-10-26 20:44     ` John W. Linville
2008-10-26 22:12     ` Marcel Holtmann
2008-10-28 15:13 ` Bob Copeland

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).