LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Bernhard Schmidt <berni@birkenwald.de>
To: Yves-Alexis Perez <corsac@debian.org>
Cc: Frans Pop <elendil@planet.nl>,
	linux-kernel@vger.kernel.org,
	"Carlos R. Mafra" <crmafra2@gmail.com>,
	Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@elte.hu>,
	Arjan van de Ven <arjan@linux.intel.com>
Subject: Re: Long delays and keystrokes required - related to disk encryption?
Date: Wed, 5 Nov 2008 03:03:40 +0100	[thread overview]
Message-ID: <20081105020340.GA6399@schleppi.birkenwald.de> (raw)
In-Reply-To: <20081103073647.GB6313@corsac.net>

In gmane.linux.kernel, Yves-Alexis Perez wrote:

> On Mon, Nov 03, 2008 at 08:23:27AM +0100, Yves-Alexis Perez wrote:
>> FTR, it seems fixed in 2.6.28-rc3 (I just git pull-ed the tree, so I
>> don't know which commit has fixed the problem)
>>
>> Could anyone (Frans?) confirm this?
>
> Hmhm ok, it's *not* fixed, it just appears a bit better, but it's
> still slow and hangs during boot process until I type some random
> keys.

I can confirm that (unfortunately).

Dell Latitude D630 amd64, Ubuntu Intrepid (8.10), unencrypted ext4 root
and encrypted (dm-crypt) ext4 /home.

After upgrading from the shipped 2.6.27 ubuntu kernel to 2.6.28-rc2 due
to totally buggy iwlagn (I had more crashes the last four weeks than
running devel kernels for years) I experienced exactly the same issue,
after entering the password into cryptsetup the machine did not continue
booting until I pressed a key. Any key, even holding down the ctrl-key
during bootup is fine. 2.6.28-rc3 shows the same behaviour.

However, I have a slight difference compared with Yves. I don't only
experience these hangs until all my filesystems are mounted, but during
the whole startup process at random stages. I usually have at least
three hangs during startup, with almost 100% certainity between entering
the keyphrase and getting the "Keyslot 0 unlocked" message from
dm-crypt, then at random daemons at startup and even on X startup
(before kdm shows the login screen). Pressing the Ctrl-key just once and
holding it during the whole bootup fixes it 100%.

Interestingly, since just my /home is on dm-crypt I tried to disable
that to ensure it is related to crypto and it seems to be. However, in
four bootups without crypt it showed the same symptoms, so it definitely
does happen without crypto as well, but by far not that frequent.

Regards,
Bernhard

  reply	other threads:[~2008-11-05  2:11 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-28 16:44 Frans Pop
2008-10-28 17:11 ` Carlos R. Mafra
2008-10-28 21:52   ` Yves-Alexis Perez
2008-10-29  0:53 ` Frans Pop
2008-10-29  3:32   ` Arjan van de Ven
2008-10-29  6:54     ` Yves-Alexis Perez
2008-10-29  7:11       ` Yves-Alexis Perez
2008-11-03  7:23         ` Yves-Alexis Perez
2008-11-03  7:36           ` Yves-Alexis Perez
2008-11-05  2:03             ` Bernhard Schmidt [this message]
2008-11-05 15:13               ` Arjan van de Ven
2008-11-05 16:12                 ` Bernhard Schmidt
2008-11-05 18:17                 ` Yves-Alexis Perez
2008-11-05 20:41                 ` Frans Pop
2008-11-06 15:41                 ` Tony Vroon
2008-11-06 15:56                   ` Yves-Alexis Perez
2008-10-29 10:43     ` Frans Pop
2008-10-30 19:50 ` Pavel Machek
2008-10-31  0:04   ` Frans Pop
2008-10-31  7:57     ` Pavel Machek
2008-10-31 11:40       ` Yves-Alexis Perez

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20081105020340.GA6399@schleppi.birkenwald.de \
    --to=berni@birkenwald.de \
    --cc=arjan@linux.intel.com \
    --cc=corsac@debian.org \
    --cc=crmafra2@gmail.com \
    --cc=elendil@planet.nl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    --subject='Re: Long delays and keystrokes required - related to disk encryption?' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).