LKML Archive on
help / color / mirror / Atom feed
From: "Rogério Brito" <>
To: Justin Mattock <>
Cc: Andrew Morton <>,
	Arjan van de Ven <>,,,,,,,
Subject: Re: [Bugme-new] [Bug 11717] New: Pressing suspend button suspends, but does not wakes up
Date: Sun, 9 Nov 2008 00:45:14 -0200	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

Hi, Justin and others.

On Nov 08 2008, Justin Mattock wrote:
> On Fri, Nov 7, 2008 at 11:50 PM, Rogério Brito <> wrote:
> > I think that I have some more information regarding the suspend/hibernate
> > issue: with Ubuntu's 2.6.27 kernel, I can't hibernate my laptop, but with
> > vanilla 2.6.28-rc3, I can hibernate (I have not tested it much, but it
> > seems to work).

Just some extra information here: while I can hibernate with vanilla
2.6.28-rc3, upon resuming, it takes *minutes* (I don't know how many
minutes, but probably something like 5 minutes or so!) for the desktop to
have any effect (despite the fact that I can move the mouse without any

A new reboot is *much* faster than what I get with hibernate.

I can film that if desired.

> > But seeing the behaviour of this in comparison with Windows Vista, two
> > things still stand out:
> >
> > 1 - pressing the suspend button suspends the machine, but upon a second
> >    press, the machine still turns itself off and all work is lost. :-(

This problem still persists.

> > 2 - closing the lid, no matter what I program in GNOME's Power Preferences,
> >    doesn't even blackens the screen, let alone suspend or hibernate the
> >    notebook.

A correction here: when I close the lid, the laptop suspends. I can try to
see if it hibernates.

> > Again, for those that I just included in the carbon copies now, I have
> > given extensive information on the bugzilla report, but I can recompile
> > kernels, get dumps of debugging information, get dumps under Windows (if
> > that helps and if I am instructed how to do that). You name it. I am really
> > willing to help as much as possible with all efforts that are possible to
> > me.

Again, I am willing to get any debugging information or anything that is
asked me. I am testing things and I still don't have any production data on
that notebook.

BTW, I installed Windows Vista with a dual boot. I'm feeling tainted
now. :-(

> I think you might be experiencing the dreaded black screen upon
> wakeup.(after seeing you're quick video);

Nice that the video proved useful to demonstrate the issue. I can take
another video to show the current behaviour with 2.6.28-rc3.

> I was having the same with my macbook pro, when running
> radeonhd(haven't tried s2ram yet to see if this resolves the issue).
> Although was told it should fix the issue.

Right. Just for further information, this notebook here has a plain ICH8
chipset. The only thing that I think that is not from intel is the gigabit
ethernet, which is a Realtek one (it seems that the r8169 driver is loaded,
but I still have not tested wired connections).

> Did have the same(black screen of death wakeup); with a dell
> inspiron, but then realized my graphics modules weren't configured
> properly.

Weird. I have a Dell Latitude D520 here (which I'm using for this e-mail)
and everything that I tried works fine (suspend, wifi, hibernation and even
the compiz stuff---which I promptly disable). It has a broadcom ethernet
that seems to use the b44 driver, but I have also not used the wired
connection here.

I'm streaming audio via daap to this notebook from a Kurobox (powerpc box)
with kernel 2.6.27 kernel (and my patches that were included in

> As for the pressing of buttons, the initial pressing of the power button send's
> shutdown to the machine for me, but when suspending the system, the power button
> wakes the machine up, or closing and opening the lid.

For me, nothing like this works. :-( I can open the lid and it still stays
sleeping. Pressing the suspend (poweron/poweroff?) button while suspended
only turns off the machine. :-(

Thanks again for any feedback, Rogério Brito.

Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8 :
Projects: : :

  reply	other threads:[~2008-11-09  2:45 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-11-06 19:47 [Bugme-new] [Bug 11717] New: Pressing suspend button suspends, but does not wakes up Rogério Brito
2008-11-07  1:45 ` Rogério Brito
2008-11-07  8:00   ` Rogerio Theodoro de Brito
2008-11-08  7:50     ` Rogério Brito
2008-11-08  8:20       ` Justin Mattock
2008-11-09  2:45         ` Rogério Brito [this message]
2008-11-09  4:38           ` Justin P. Mattock
2008-11-10 14:06             ` Rogério Brito
2008-11-09 11:33           ` Pavel Machek
2008-11-10  5:17             ` Justin Mattock
2008-11-10  7:45               ` Pavel Machek
2008-11-10 15:00                 ` Justin Mattock
2008-11-11  9:37                   ` Rogério Brito
2009-08-20  2:54                     ` Rogério Brito
2009-08-12  4:10                 ` Rogério Brito
2009-08-12  4:31                   ` Justin P. Mattock
2008-11-10 14:15             ` Rogério Brito
2008-11-11  9:53               ` Pavel Machek
2008-11-11 15:22                 ` Justin Mattock

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).