LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
To: Sergei Shtylyov <sshtylyov@ru.mvista.com>, linux-m68k@vger.kernel.org
Cc: linux-ide@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: ->ack_intr in m68k IDE drivers [was: Re: [PATCH 2/5] ide: ->ide_dma_clear_irq() -> ->clear_irq()]
Date: Fri, 22 May 2009 20:44:42 +0200 [thread overview]
Message-ID: <200905222044.42688.bzolnier@gmail.com> (raw)
In-Reply-To: <4A15600A.40906@ru.mvista.com>
On Thursday 21 May 2009 16:07:06 Sergei Shtylyov wrote:
> Hello, I wrote:
>
> >>> * Rename ->ide_dma_clear_irq method to ->clear_irq
> >>> and move it from ide_hwif_t to struct ide_port_ops.
>
> >>> * Move ->waiting_for_dma check inside ->clear_irq method.
>
> >>> * Move ->dma_base check inside ->clear_irq method.
>
> >>> piix.c:
> >>> * Add ich_port_ops and remove init_hwif_ich() wrapper.
>
> >>> There should be no functional changes caused by this patch.
>
> [...]
>
> >> It may also be worth considering turning this method into
> >> test-and-clear, so that we can get the actual IDE interrupt state on
> >> the chips that implement this...
>
> > Probably might add the test_irq() method to be called on
> > !hwif->waiting_for_dma. Cleraing the status at once seems impractical...
>
> Yet this seems what ack_intr() method is doing already...
> What it does is testing IRQ status and "acknowledging" it (the semantics
> of "acknowledge" is not clear to me, yet it seems that it's clearing the
> interrupt latch in the drivers where it's implemented). And the call site of
> ack_intr() method corresponds to where test_irq() should have been called,
> so it seems we don't need yet another method and probably didn't even need
> clear_irq() method in the first place?..
They have different goals -- the main purpose of ack_intr() (despite its name)
seems to be testing whether the IRQ is ours, OTOH in clear_irq() we know that
already and we just want to clear the pending IRQ status.
So I'm not sure if unification is desirable... though some improvements are
definitely possibly there (less confusing naming at least)...
> Bart, could you clarify about how ack_intr() is supposed to work?
Good question, m68k list would be the best place to look for an answer..
next prev parent reply other threads:[~2009-05-22 18:55 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-08-19 18:31 [PATCH 2/5] ide: ->ide_dma_clear_irq() -> ->clear_irq() Bartlomiej Zolnierkiewicz
2008-08-19 22:22 ` Sergei Shtylyov
2008-09-15 22:11 ` Sergei Shtylyov
2008-09-15 22:29 ` Bartlomiej Zolnierkiewicz
2008-09-16 9:16 ` Sergei Shtylyov
2008-11-12 2:01 ` Jeremy Higdon
2009-05-21 14:07 ` Sergei Shtylyov
2009-05-22 18:44 ` Bartlomiej Zolnierkiewicz [this message]
2009-05-22 19:19 ` ->ack_intr in m68k IDE drivers [was: Re: [PATCH 2/5] ide: ->ide_dma_clear_irq() -> ->clear_irq()] Sergei Shtylyov
2009-05-22 19:19 ` Sergei Shtylyov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200905222044.42688.bzolnier@gmail.com \
--to=bzolnier@gmail.com \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@vger.kernel.org \
--cc=sshtylyov@ru.mvista.com \
--subject='->ack_intr in m68k IDE drivers [was: Re: [PATCH 2/5] ide: ->ide_dma_clear_irq() -> ->clear_irq()]' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).