LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Pali Rohár" <pali.rohar@gmail.com>
To: Pavel Machek <pavel@ucw.cz>
Cc: "Aaro Koskinen" <aaro.koskinen@iki.fi>,
	sre@kernel.org, "kernel list" <linux-kernel@vger.kernel.org>,
	linux-arm-kernel <linux-arm-kernel@lists.infradead.org>,
	linux-omap@vger.kernel.org, tony@atomide.com, khilman@kernel.org,
	ivo.g.dimitrov.75@gmail.com, patrikbachan@gmail.com,
	serge@hallyn.com, abcloriens@gmail.com, clayton@craftyguy.net,
	martijn@brixit.nl, sakari.ailus@linux.intel.com,
	"Filip Matijević" <filip.matijevic.pz@gmail.com>,
	"Thorsten Leemhuis" <regressions@leemhuis.info>
Subject: Re: v4.17-rc1: regressions on N900, N950
Date: Tue, 22 May 2018 10:02:50 +0200	[thread overview]
Message-ID: <20180522080250.4fzyvqrgw5oigexn@pali> (raw)
In-Reply-To: <20180521213952.GA11596@amd>

On Monday 21 May 2018 23:39:53 Pavel Machek wrote:
> HI!
> 
> > On Sun, Apr 22, 2018 at 09:42:13AM +0200, Pavel Machek wrote:
> > > v4.17-rc1 broke display for me on Nokia N900. (I don't know if system
> > > boots, but I can see on red flash LED that at least that driver
> > > succeeded. So it should not be early boot crash).
> > > 
> > > v4.17-rc1 also broke boot on N950.
> > > 
> > > Any ideas? Does it work for you?
> > 
> > Below config works for me on N900 and N950. (On N950, I need to disable to
> > display DTS entry as discussed in other threads.)
> 
> Thanks... On N900 it works for me in v4.16, but display stays blank in
> v4.17-rc1...
> 
> And I'm starting to suspect I have somehow special N900, or maybe
> special gcc version... Whether display on N900 works or not seems to
> depend on completely unrelated config options :-(. Maybe it is timing
> during boot or something.
> 
> Best regards,

Hi! I remember that in time of migration from platform board code to
device tree structures there appeared some bug which caused that
sometimes display were not initialized. And somebody figured out that
display initialization is failing when some other SPI devices are
initialized before or after display... This behavior was observed only
on real N900 hardware, not in qemu. Real reason was never explained. In
old platform board code there was hardcoded order of SPI devices in
which initialization happened. And in device tree it is probably in
(pseudo)-random order. Enabling/disabling various config option can
affect some timings and order in which kernel starts probing and
initializing devices...

-- 
Pali Rohár
pali.rohar@gmail.com

  reply	other threads:[~2018-05-22  8:03 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-22  7:42 Pavel Machek
2018-04-23 20:29 ` Aaro Koskinen
2018-05-21 21:39   ` Pavel Machek
2018-05-22  8:02     ` Pali Rohár [this message]
2018-05-22 19:41       ` Aaro Koskinen
2018-05-22 20:58         ` Pavel Machek
2018-05-22 21:56           ` Aaro Koskinen
2018-05-23 14:06             ` Pavel Machek
2018-05-23 20:12               ` Pavel Machek
2018-05-23 22:04                 ` Tony Lindgren
2018-05-24  9:23                   ` Pavel Machek
2018-05-24  9:47                   ` Pavel Machek
2018-05-29 20:45                     ` Pavel Machek
2018-05-29 21:09                       ` Sebastian Reichel
2018-05-29 22:34                         ` Pavel Machek
2018-05-23 22:02             ` Aaro Koskinen
2018-05-24  6:25               ` Tomi Valkeinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180522080250.4fzyvqrgw5oigexn@pali \
    --to=pali.rohar@gmail.com \
    --cc=aaro.koskinen@iki.fi \
    --cc=abcloriens@gmail.com \
    --cc=clayton@craftyguy.net \
    --cc=filip.matijevic.pz@gmail.com \
    --cc=ivo.g.dimitrov.75@gmail.com \
    --cc=khilman@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=martijn@brixit.nl \
    --cc=patrikbachan@gmail.com \
    --cc=pavel@ucw.cz \
    --cc=regressions@leemhuis.info \
    --cc=sakari.ailus@linux.intel.com \
    --cc=serge@hallyn.com \
    --cc=sre@kernel.org \
    --cc=tony@atomide.com \
    --subject='Re: v4.17-rc1: regressions on N900, N950' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).