LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Tony Lindgren <tony@atomide.com>
To: Pavel Machek <pavel@ucw.cz>
Cc: "Aaro Koskinen" <aaro.koskinen@iki.fi>,
	"Pali Rohár" <pali.rohar@gmail.com>,
	sre@kernel.org, "kernel list" <linux-kernel@vger.kernel.org>,
	linux-arm-kernel <linux-arm-kernel@lists.infradead.org>,
	linux-omap@vger.kernel.org, khilman@kernel.org,
	ivo.g.dimitrov.75@gmail.com, patrikbachan@gmail.com,
	serge@hallyn.com, abcloriens@gmail.com, clayton@craftyguy.net,
	martijn@brixit.nl, sakari.ailus@linux.intel.com,
	"Filip Matijević" <filip.matijevic.pz@gmail.com>,
	"Thorsten Leemhuis" <regressions@leemhuis.info>
Subject: Re: v4.17-rc1: regressions on N900, N950
Date: Wed, 23 May 2018 15:04:56 -0700	[thread overview]
Message-ID: <20180523220456.GY98604@atomide.com> (raw)
In-Reply-To: <20180523201208.GA31731@amd>

* Pavel Machek <pavel@ucw.cz> [180523 20:14]:
> On Wed 2018-05-23 16:06:15, Pavel Machek wrote:
> > On Wed 2018-05-23 00:56:38, Aaro Koskinen wrote:
> > > Hi,
> > > 
> > > On Tue, May 22, 2018 at 10:58:26PM +0200, Pavel Machek wrote:
> > > > On Tue 2018-05-22 22:41:39, Aaro Koskinen wrote:
> > > > > My device worked with v4.17-rc1 (haven't found time to test newer kernels),
> > > > > but if you say the probe order is random then we must find some proper way
> > > > > to express the dependency.
> > > > 
> > > > I started bisect, but.. that will probably not be useful.
> > > > 
> > > > If your device works ok in v4.17-rc1, it probably works in newer -rcs,
> > > > too.
> > > 
> > > Actually, my statement may be bogus... Now I tried again with -rc1
> > > (and also -rc6) and it fails... But v4.16 works.
> > > 
> > > > Thanks for the ordering hint, I'll try to figure out what is going on
> > > > there.
> > > 
> > > My bisection pointed to 6fa7324ac5489ad43c4b6351355b869bc5458bef which
> > > doesn't seem to make any sense...?! So maybe there really is something
> > > random stuff going on? :-(
> > 
> > So... I did some experiments on v4.16.
> > 
> > Swapping tsc2005@0 and lcd: acx565akm@2 entries in the dts does break
> > stuff.
> > 
> > I thought it might be due to vio regulator, but it does not appear
> > so... screen still works with tsc2005 driver disabled in .config. (so
> > there's noone to enable vio regulator).
> 
> Deleting tsc2005@0 entry also breaks screen.
> 
> Replacing tsc2005@0 entry with 
> 
>         foobar@0 {
> 	               compatible = "not really with anything";
>  		       spi-max-frequency = <6000000>;
>  		       reg = <0>;
>  };
> 
> still results in working touchscreen, removing any of the three fields
> breaks it again.

I bisected one regression down, see "omapdrm regression in v4.17-rc series"
not sure if it covers all the issues being discussed here though.

Regards,

Tony

  reply	other threads:[~2018-05-23 22:05 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-22  7:42 Pavel Machek
2018-04-23 20:29 ` Aaro Koskinen
2018-05-21 21:39   ` Pavel Machek
2018-05-22  8:02     ` Pali Rohár
2018-05-22 19:41       ` Aaro Koskinen
2018-05-22 20:58         ` Pavel Machek
2018-05-22 21:56           ` Aaro Koskinen
2018-05-23 14:06             ` Pavel Machek
2018-05-23 20:12               ` Pavel Machek
2018-05-23 22:04                 ` Tony Lindgren [this message]
2018-05-24  9:23                   ` Pavel Machek
2018-05-24  9:47                   ` Pavel Machek
2018-05-29 20:45                     ` Pavel Machek
2018-05-29 21:09                       ` Sebastian Reichel
2018-05-29 22:34                         ` Pavel Machek
2018-05-23 22:02             ` Aaro Koskinen
2018-05-24  6:25               ` Tomi Valkeinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180523220456.GY98604@atomide.com \
    --to=tony@atomide.com \
    --cc=aaro.koskinen@iki.fi \
    --cc=abcloriens@gmail.com \
    --cc=clayton@craftyguy.net \
    --cc=filip.matijevic.pz@gmail.com \
    --cc=ivo.g.dimitrov.75@gmail.com \
    --cc=khilman@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=martijn@brixit.nl \
    --cc=pali.rohar@gmail.com \
    --cc=patrikbachan@gmail.com \
    --cc=pavel@ucw.cz \
    --cc=regressions@leemhuis.info \
    --cc=sakari.ailus@linux.intel.com \
    --cc=serge@hallyn.com \
    --cc=sre@kernel.org \
    --subject='Re: v4.17-rc1: regressions on N900, N950' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).