LKML Archive on lore.kernel.org help / color / mirror / Atom feed
From: "Joel Fernandes (Google)" <joel@joelfernandes.org> To: linux-kernel@vger.kernel.org, rcu@vger.kernel.org Cc: "Joel Fernandes (Google)" <joel@joelfernandes.org>, "Paul E. McKenney" <paulmck@linux.ibm.com>, Josh Triplett <josh@joshtriplett.org>, Steven Rostedt <rostedt@goodmis.org>, Mathieu Desnoyers <mathieu.desnoyers@efficios.com>, Lai Jiangshan <jiangshanlai@gmail.com>, Jonathan Corbet <corbet@lwn.net>, linux-doc@vger.kernel.org Subject: [PATCH] doc/rcu: Correct field_count field naming in examples Date: Sat, 4 May 2019 22:03:10 -0400 [thread overview] Message-ID: <20190505020328.165839-1-joel@joelfernandes.org> (raw) I believe this field should be called field_count instead of file_count. Correct the doc with the same. Signed-off-by: Joel Fernandes (Google) <joel@joelfernandes.org> --- Documentation/RCU/listRCU.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Documentation/RCU/listRCU.txt b/Documentation/RCU/listRCU.txt index adb5a3782846..190e666fc359 100644 --- a/Documentation/RCU/listRCU.txt +++ b/Documentation/RCU/listRCU.txt @@ -175,7 +175,7 @@ otherwise, the added fields would need to be filled in): list_for_each_entry(e, list, list) { if (!audit_compare_rule(rule, &e->rule)) { e->rule.action = newaction; - e->rule.file_count = newfield_count; + e->rule.field_count = newfield_count; write_unlock(&auditsc_lock); return 0; } @@ -204,7 +204,7 @@ RCU ("read-copy update") its name. The RCU code is as follows: return -ENOMEM; audit_copy_rule(&ne->rule, &e->rule); ne->rule.action = newaction; - ne->rule.file_count = newfield_count; + ne->rule.field_count = newfield_count; list_replace_rcu(&e->list, &ne->list); call_rcu(&e->rcu, audit_free_rule); return 0; -- 2.21.0.1020.gf2820cf01a-goog
next reply other threads:[~2019-05-05 2:04 UTC|newest] Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-05-05 2:03 Joel Fernandes (Google) [this message] 2019-05-07 0:04 ` [PATCH] doc/rcu: Correct field_count field naming in examples Paul E. McKenney 2019-05-08 16:26 ` Joel Fernandes 2019-05-08 18:16 ` Paul E. McKenney 2019-05-11 22:11 ` Andrea Parri 2019-05-12 0:41 ` Paul E. McKenney 2019-05-12 1:09 ` Andrea Parri 2019-05-13 3:43 ` Joel Fernandes 2019-05-14 22:13 ` Paul E. McKenney 2019-05-25 10:07 ` Joel Fernandes
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20190505020328.165839-1-joel@joelfernandes.org \ --to=joel@joelfernandes.org \ --cc=corbet@lwn.net \ --cc=jiangshanlai@gmail.com \ --cc=josh@joshtriplett.org \ --cc=linux-doc@vger.kernel.org \ --cc=linux-kernel@vger.kernel.org \ --cc=mathieu.desnoyers@efficios.com \ --cc=paulmck@linux.ibm.com \ --cc=rcu@vger.kernel.org \ --cc=rostedt@goodmis.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).