LKML Archive on lore.kernel.org help / color / mirror / Atom feed
From: "Paul E. McKenney" <paulmck@linux.ibm.com> To: Joel Fernandes <joel@joelfernandes.org> Cc: Steven Rostedt <rostedt@goodmis.org>, linux-kernel@vger.kernel.org, Benjamin Herrenschmidt <benh@kernel.crashing.org>, Ingo Molnar <mingo@redhat.com>, Jonathan Corbet <corbet@lwn.net>, Josh Triplett <josh@joshtriplett.org>, kvm-ppc@vger.kernel.org, Lai Jiangshan <jiangshanlai@gmail.com>, linux-doc@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, Mathieu Desnoyers <mathieu.desnoyers@efficios.com>, Michael Ellerman <mpe@ellerman.id.au>, Miguel Ojeda <miguel.ojeda.sandonis@gmail.com>, Paul Mackerras <paulus@ozlabs.org>, rcu@vger.kernel.org Subject: Re: [PATCH RFC 0/5] Remove some notrace RCU APIs Date: Sat, 25 May 2019 08:50:35 -0700 [thread overview] Message-ID: <20190525155035.GE28207@linux.ibm.com> (raw) In-Reply-To: <20190525141954.GA176647@google.com> On Sat, May 25, 2019 at 10:19:54AM -0400, Joel Fernandes wrote: > On Sat, May 25, 2019 at 07:08:26AM -0400, Steven Rostedt wrote: > > On Sat, 25 May 2019 04:14:44 -0400 > > Joel Fernandes <joel@joelfernandes.org> wrote: > > > > > > I guess the difference between the _raw_notrace and just _raw variants > > > > is that _notrace ones do a rcu_check_sparse(). Don't we want to keep > > > > that check? > > > > > > This is true. > > > > > > Since the users of _raw_notrace are very few, is it worth keeping this API > > > just for sparse checking? The API naming is also confusing. I was expecting > > > _raw_notrace to do fewer checks than _raw, instead of more. Honestly, I just > > > want to nuke _raw_notrace as done in this series and later we can introduce a > > > sparse checking version of _raw if need-be. The other option could be to > > > always do sparse checking for _raw however that used to be the case and got > > > changed in http://lists.infradead.org/pipermail/linux-afs/2016-July/001016.html > > > > What if we just rename _raw to _raw_nocheck, and _raw_notrace to _raw ? > > That would also mean changing 160 usages of _raw to _raw_nocheck in the > kernel :-/. > > The tracing usage of _raw_notrace is only like 2 or 3 users. Can we just call > rcu_check_sparse directly in the calling code for those and eliminate the APIs? > > I wonder what Paul thinks about the matter as well. My thought is that it is likely that a goodly number of the current uses of _raw should really be some form of _check, with lockdep expressions spelled out. Not that working out what exactly those lockdep expressions should be is necessarily a trivial undertaking. ;-) That aside, if we are going to change the name of an API that is used 160 places throughout the tree, we would need to have a pretty good justification. Without such a justification, it will just look like pointless churn to the various developers and maintainers on the receiving end of the patches. Thanx, Paul > thanks, Steven! >
next prev parent reply other threads:[~2019-05-25 15:50 UTC|newest] Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-05-24 23:49 [PATCH RFC 0/5] Remove some notrace RCU APIs Joel Fernandes (Google) 2019-05-24 23:49 ` [PATCH RFC 1/5] powerpc: Use regular rcu_dereference_raw API Joel Fernandes (Google) 2019-05-24 23:49 ` [PATCH RFC 2/5] trace: " Joel Fernandes (Google) 2019-05-24 23:49 ` [PATCH RFC 3/5] hashtable: Use the regular hlist_for_each_entry_rcu API Joel Fernandes (Google) 2019-05-24 23:49 ` [PATCH RFC 4/5] rculist: Remove hlist_for_each_entry_rcu_notrace since no users Joel Fernandes (Google) 2019-05-26 16:20 ` Miguel Ojeda 2019-05-24 23:49 ` [PATCH RFC 5/5] rcu: Remove rcu_dereference_raw_notrace " Joel Fernandes (Google) 2019-05-25 3:24 ` [PATCH RFC 0/5] Remove some notrace RCU APIs Steven Rostedt 2019-05-25 8:14 ` Joel Fernandes 2019-05-25 11:08 ` Steven Rostedt 2019-05-25 14:19 ` Joel Fernandes 2019-05-25 15:50 ` Paul E. McKenney [this message] 2019-05-25 18:14 ` Joel Fernandes 2019-05-25 18:18 ` Joel Fernandes 2019-05-28 12:24 ` Paul E. McKenney 2019-05-28 19:00 ` Joel Fernandes 2019-05-28 20:00 ` Paul E. McKenney
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20190525155035.GE28207@linux.ibm.com \ --to=paulmck@linux.ibm.com \ --cc=benh@kernel.crashing.org \ --cc=corbet@lwn.net \ --cc=jiangshanlai@gmail.com \ --cc=joel@joelfernandes.org \ --cc=josh@joshtriplett.org \ --cc=kvm-ppc@vger.kernel.org \ --cc=linux-doc@vger.kernel.org \ --cc=linux-kernel@vger.kernel.org \ --cc=linuxppc-dev@lists.ozlabs.org \ --cc=mathieu.desnoyers@efficios.com \ --cc=miguel.ojeda.sandonis@gmail.com \ --cc=mingo@redhat.com \ --cc=mpe@ellerman.id.au \ --cc=paulus@ozlabs.org \ --cc=rcu@vger.kernel.org \ --cc=rostedt@goodmis.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).