LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Paul E. McKenney" <firstname.lastname@example.org>
To: Joel Fernandes <email@example.com>
Cc: Steven Rostedt <firstname.lastname@example.org>,
Benjamin Herrenschmidt <email@example.com>,
Ingo Molnar <firstname.lastname@example.org>, Jonathan Corbet <email@example.com>,
Josh Triplett <firstname.lastname@example.org>,
email@example.com, Lai Jiangshan <firstname.lastname@example.org>,
Mathieu Desnoyers <email@example.com>,
Michael Ellerman <firstname.lastname@example.org>,
Miguel Ojeda <email@example.com>,
Paul Mackerras <firstname.lastname@example.org>,
Subject: Re: [PATCH RFC 0/5] Remove some notrace RCU APIs
Date: Tue, 28 May 2019 13:00:14 -0700 [thread overview]
Message-ID: <20190528200014.GV28207@linux.ibm.com> (raw)
On Tue, May 28, 2019 at 03:00:07PM -0400, Joel Fernandes wrote:
> On Tue, May 28, 2019 at 05:24:47AM -0700, Paul E. McKenney wrote:
> > On Sat, May 25, 2019 at 02:14:07PM -0400, Joel Fernandes wrote:
> > > On Sat, May 25, 2019 at 08:50:35AM -0700, Paul E. McKenney wrote:
> > > > On Sat, May 25, 2019 at 10:19:54AM -0400, Joel Fernandes wrote:
> > > > > On Sat, May 25, 2019 at 07:08:26AM -0400, Steven Rostedt wrote:
> > > > > > On Sat, 25 May 2019 04:14:44 -0400
> > > > > > Joel Fernandes <email@example.com> wrote:
> > > > > >
> > > > > > > > I guess the difference between the _raw_notrace and just _raw variants
> > > > > > > > is that _notrace ones do a rcu_check_sparse(). Don't we want to keep
> > > > > > > > that check?
> > > > > > >
> > > > > > > This is true.
> > > > > > >
> > > > > > > Since the users of _raw_notrace are very few, is it worth keeping this API
> > > > > > > just for sparse checking? The API naming is also confusing. I was expecting
> > > > > > > _raw_notrace to do fewer checks than _raw, instead of more. Honestly, I just
> > > > > > > want to nuke _raw_notrace as done in this series and later we can introduce a
> > > > > > > sparse checking version of _raw if need-be. The other option could be to
> > > > > > > always do sparse checking for _raw however that used to be the case and got
> > > > > > > changed in http://lists.infradead.org/pipermail/linux-afs/2016-July/001016.html
> > > > > >
> > > > > > What if we just rename _raw to _raw_nocheck, and _raw_notrace to _raw ?
> > > > >
> > > > > That would also mean changing 160 usages of _raw to _raw_nocheck in the
> > > > > kernel :-/.
> > > > >
> > > > > The tracing usage of _raw_notrace is only like 2 or 3 users. Can we just call
> > > > > rcu_check_sparse directly in the calling code for those and eliminate the APIs?
> > > > >
> > > > > I wonder what Paul thinks about the matter as well.
> > > >
> > > > My thought is that it is likely that a goodly number of the current uses
> > > > of _raw should really be some form of _check, with lockdep expressions
> > > > spelled out. Not that working out what exactly those lockdep expressions
> > > > should be is necessarily a trivial undertaking. ;-)
> > >
> > > Yes, currently where I am a bit stuck is the rcu_dereference_raw()
> > > cannot possibly know what SRCU domain it is under, so lockdep cannot check if
> > > an SRCU lock is held without the user also passing along the SRCU domain. I
> > > am trying to change lockdep to see if it can check if *any* srcu domain lock
> > > is held (regardless of which one) and complain if none are. This is at least
> > > better than no check at all.
> > >
> > > However, I think it gets tricky for mutexes. If you have something like:
> > > mutex_lock(some_mutex);
> > > p = rcu_dereference_raw(gp);
> > > mutex_unlock(some_mutex);
> > >
> > > This might be a perfectly valid invocation of _raw, however my checks (patch
> > > is still cooking) trigger a lockdep warning becase _raw cannot know that this
> > > is Ok. lockdep thinks it is not in a reader section. This then gets into the
> > > territory of a new rcu_derference_raw_protected(gp, assert_held(some_mutex))
> > > which sucks because its yet another API. To circumvent this issue, can we
> > > just have callers of rcu_dereference_raw ensure that they call
> > > rcu_read_lock() if they are protecting dereferences by a mutex? That would
> > > make things a lot easier and also may be Ok since rcu_read_lock is quite
> > > cheap.
> > Why not just rcu_dereference_protected(lockdep_is_held(some_mutex))?
> > The API is already there, and no need for spurious readers.
> Hmm, so I gave a bad example, here is a better example:
> fib_get_table calls hlist_for_each_entry_rcu()
> hlist_for_each_entry_rcu calls rcu_dereference_raw().
> This is perfectly Ok to be called under rtnl_mutex. However rcu_dererence_raw
> in hlist_for_each_entry_rcu has no way of knowing that the rtnl_mutex held is
> sufficient for the protection since it is not directly called by the caller.
Agreed, and this just happens to be one of the use cases that led to
rcu_dereference_raw(). The calling code (in this case, FIB) simply has
no idea what the synchronization strategy might be.
> I am almost sure I saw other examples of rcu_dereference_raw being called
> this way as well.
And I am OK with this sort of use case. The ones I am less happy with
are the ones where there really is a lockdep expression that could be
> I was trying to make an "automatic" lockdep check for all this, but it is
> quite hard to do so without passing down lockdep experessions down a call
> chain thus complicating all such callchains.
Understood! Not an easy task.
> Further I don't think code can trivially be converted from
> rcu_dereference_raw to rcu_dereference_protected even if the protection being
> offered is known, since the former does not do sparse checking and the latter
> might trigger false sparse checks in case the pointer in concern is protected
> both by RCU and non-RCU methods. I believe this is why you removed sparse
> checking from rcu_dereference_raw as well:
> > > > That aside, if we are going to change the name of an API that is
> > > > used 160 places throughout the tree, we would need to have a pretty
> > > > good justification. Without such a justification, it will just look
> > > > like pointless churn to the various developers and maintainers on the
> > > > receiving end of the patches.
> > >
> > > Actually, the API name change is not something I want to do, it is Steven
> > > suggestion. My suggestion is let us just delete _raw_notrace and just use the
> > > _raw API for tracing, since _raw doesn't do any tracing anyway. Steve pointed
> > > that _raw_notrace does sparse checking unlike _raw, but I think that isn't an
> > > issue since _raw doesn't do such checking at the moment anyway.. (if possible
> > > check my cover letter again for details/motivation of this series).
> > Understood, but regardless of who suggested it, if we are to go through
> > with it, good justification will be required. ;-)
> Ok ;-). About the names of the APIs, I thought of leaving rcu_dereference_raw
> and its callers intact, and just rename:
> * hlist_for_each_entry_rcu_notrace
> * rcu_dereference_raw_notrace
> * hlist_for_each_entry_rcu_sparse
> * rcu_dereference_raw_sparse
> The _sparse would stand for "sparse checking". However I am open to better
> Such renaming would avoid confusion and keep the fact about sparse checking
> less ambiguous.
Let's give people a few days to propose different names, and if nothing
compelling, those names look good. There are not very many of them, so
the penalty for having to rename is quite low.
prev parent reply other threads:[~2019-05-28 20:00 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-05-24 23:49 Joel Fernandes (Google)
2019-05-24 23:49 ` [PATCH RFC 1/5] powerpc: Use regular rcu_dereference_raw API Joel Fernandes (Google)
2019-05-24 23:49 ` [PATCH RFC 2/5] trace: " Joel Fernandes (Google)
2019-05-24 23:49 ` [PATCH RFC 3/5] hashtable: Use the regular hlist_for_each_entry_rcu API Joel Fernandes (Google)
2019-05-24 23:49 ` [PATCH RFC 4/5] rculist: Remove hlist_for_each_entry_rcu_notrace since no users Joel Fernandes (Google)
2019-05-26 16:20 ` Miguel Ojeda
2019-05-24 23:49 ` [PATCH RFC 5/5] rcu: Remove rcu_dereference_raw_notrace " Joel Fernandes (Google)
2019-05-25 3:24 ` [PATCH RFC 0/5] Remove some notrace RCU APIs Steven Rostedt
2019-05-25 8:14 ` Joel Fernandes
2019-05-25 11:08 ` Steven Rostedt
2019-05-25 14:19 ` Joel Fernandes
2019-05-25 15:50 ` Paul E. McKenney
2019-05-25 18:14 ` Joel Fernandes
2019-05-25 18:18 ` Joel Fernandes
2019-05-28 12:24 ` Paul E. McKenney
2019-05-28 19:00 ` Joel Fernandes
2019-05-28 20:00 ` Paul E. McKenney [this message]
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--subject='Re: [PATCH RFC 0/5] Remove some notrace RCU APIs' \
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).