LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH v3 0/1] wait_task_inactive() spend too much time on system startup
@ 2020-03-06  7:01 cl
  2020-03-06  7:01 ` [PATCH v3 1/1] kthread: do not preempt current task if it is going to call schedule() cl
  0 siblings, 1 reply; 5+ messages in thread
From: cl @ 2020-03-06  7:01 UTC (permalink / raw)
  To: heiko
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, akpm, tglx, mpe, surenb, ben.dooks,
	anshuman.khandual, catalin.marinas, will, keescook, luto, wad,
	mark.rutland, geert+renesas, george_davis, sudeep.holla, linux,
	gregkh, info, kstewart, allison, linux-arm-kernel, linux-kernel,
	huangtao, Liang Chen

From: Liang Chen <cl@rock-chips.com>

Changelog:
v1: wait_task_inactive() frequently call schedule_hrtimeout() and spend a lot of time,
i am trying to optimize it on rockchip platform.
v2: Use atomic_flags(PFA) instead of TIF flag, and add some comments.
v3: Use a new method fix this issue to make the code simple.

Liang Chen (1):
  kthread: do not preempt current task if it is going to call schedule()

 kernel/kthread.c | 17 +++++++++++++++--
 1 file changed, 15 insertions(+), 2 deletions(-)

-- 
2.17.1




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-03-20 12:58 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-03-06  7:01 [PATCH v3 0/1] wait_task_inactive() spend too much time on system startup cl
2020-03-06  7:01 ` [PATCH v3 1/1] kthread: do not preempt current task if it is going to call schedule() cl
2020-03-06 17:09   ` Steven Rostedt
2020-03-11 15:39   ` Peter Zijlstra
2020-03-20 12:58   ` [tip: sched/core] kthread: Do " tip-bot2 for Liang Chen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).