LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Alex Williamson <alex.williamson@redhat.com>
To: Amey Narkhede <ameynarkhede03@gmail.com>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
Raphael Norwitz <raphael.norwitz@nutanix.com>,
linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
kw@linux.com, Shanker Donthineni <sdonthineni@nvidia.com>,
Sinan Kaya <okaya@kernel.org>, Len Brown <lenb@kernel.org>,
"Rafael J . Wysocki" <rjw@rjwysocki.net>
Subject: Re: [PATCH v10 8/8] PCI: Change the type of probe argument in reset functions
Date: Mon, 12 Jul 2021 16:24:40 -0600 [thread overview]
Message-ID: <20210712162440.6338346a.alex.williamson@redhat.com> (raw)
In-Reply-To: <20210709123813.8700-9-ameynarkhede03@gmail.com>
On Fri, 9 Jul 2021 18:08:13 +0530
Amey Narkhede <ameynarkhede03@gmail.com> wrote:
> Introduce a new enum pci_reset_mode_t to make the context of probe argument
> in reset functions clear and the code easier to read. Change the type of
> probe argument in functions which implement reset methods from int to
> pci_reset_mode_t to make the intent clear.
>
> Add a new line in return statement of pci_reset_bus_function().
>
> Suggested-by: Alex Williamson <alex.williamson@redhat.com>
> Suggested-by: Krzysztof Wilczyński <kw@linux.com>
> Signed-off-by: Amey Narkhede <ameynarkhede03@gmail.com>
> ---
> drivers/crypto/cavium/nitrox/nitrox_main.c | 2 +-
> .../ethernet/cavium/liquidio/lio_vf_main.c | 2 +-
> drivers/pci/hotplug/pciehp.h | 2 +-
> drivers/pci/hotplug/pciehp_hpc.c | 4 +-
> drivers/pci/hotplug/pnv_php.c | 4 +-
> drivers/pci/pci-acpi.c | 10 ++-
> drivers/pci/pci-sysfs.c | 6 +-
> drivers/pci/pci.c | 85 ++++++++++++-------
> drivers/pci/pci.h | 12 +--
> drivers/pci/pcie/aer.c | 2 +-
> drivers/pci/quirks.c | 37 ++++----
> include/linux/pci.h | 8 +-
> include/linux/pci_hotplug.h | 2 +-
> 13 files changed, 107 insertions(+), 69 deletions(-)
Reviewed-by: Alex Williamson <alex.williamson@redhat.com>
next prev parent reply other threads:[~2021-07-12 22:24 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-07-09 12:38 [PATCH v10 0/8] Expose and manage PCI device reset Amey Narkhede
2021-07-09 12:38 ` [PATCH v10 1/8] PCI: Add pcie_reset_flr to follow calling convention of other reset methods Amey Narkhede
2021-07-12 22:07 ` Alex Williamson
2021-07-27 22:12 ` Bjorn Helgaas
2021-07-28 18:54 ` Shanker R Donthineni
2021-07-28 20:23 ` Bjorn Helgaas
2021-07-28 21:58 ` Shanker R Donthineni
2021-07-28 22:04 ` Shanker R Donthineni
2021-07-28 22:16 ` Bjorn Helgaas
2021-07-09 12:38 ` [PATCH v10 2/8] PCI: Add new array for keeping track of ordering of " Amey Narkhede
2021-07-27 22:59 ` Bjorn Helgaas
2021-07-28 17:45 ` Amey Narkhede
2021-07-28 17:59 ` Bjorn Helgaas
2021-07-28 18:17 ` Shanker R Donthineni
2021-07-28 18:08 ` Shanker R Donthineni
2021-07-28 18:31 ` Shanker R Donthineni
2021-07-28 20:25 ` Bjorn Helgaas
2021-07-28 22:01 ` Shanker R Donthineni
2021-07-09 12:38 ` [PATCH v10 3/8] PCI: Remove reset_fn field from pci_dev Amey Narkhede
2021-07-09 12:38 ` [PATCH v10 4/8] PCI/sysfs: Allow userspace to query and set device reset mechanism Amey Narkhede
2021-07-27 23:28 ` Bjorn Helgaas
2021-07-28 1:27 ` Krzysztof Wilczyński
2021-07-28 15:36 ` Bjorn Helgaas
2021-07-28 17:59 ` Amey Narkhede
2021-07-28 18:13 ` Bjorn Helgaas
2021-07-28 18:58 ` Amey Narkhede
2021-07-28 20:18 ` Bjorn Helgaas
2021-07-31 19:15 ` Amey Narkhede
2021-07-28 17:09 ` Bjorn Helgaas
2021-07-09 12:38 ` [PATCH v10 5/8] PCI: Define a function to set ACPI_COMPANION in pci_dev Amey Narkhede
2021-07-12 22:29 ` Alex Williamson
2021-07-09 12:38 ` [PATCH v10 6/8] PCI: Setup ACPI fwnode early and at the same time with OF Amey Narkhede
2021-07-12 23:09 ` Alex Williamson
2021-07-27 23:30 ` Bjorn Helgaas
2021-07-27 23:50 ` Shanker R Donthineni
2021-07-09 12:38 ` [PATCH v10 7/8] PCI: Add support for ACPI _RST reset method Amey Narkhede
2021-07-12 23:09 ` Alex Williamson
2021-07-13 0:51 ` Shanker R Donthineni
2021-07-14 22:56 ` Alex Williamson
2021-07-09 12:38 ` [PATCH v10 8/8] PCI: Change the type of probe argument in reset functions Amey Narkhede
2021-07-12 22:24 ` Alex Williamson [this message]
2021-07-27 22:22 ` Bjorn Helgaas
2021-07-28 17:35 ` Amey Narkhede
2021-07-28 17:55 ` Bjorn Helgaas
2021-07-09 12:46 ` [PATCH v10 0/8] Expose and manage PCI device reset Amey Narkhede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210712162440.6338346a.alex.williamson@redhat.com \
--to=alex.williamson@redhat.com \
--cc=ameynarkhede03@gmail.com \
--cc=bhelgaas@google.com \
--cc=kw@linux.com \
--cc=lenb@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=okaya@kernel.org \
--cc=raphael.norwitz@nutanix.com \
--cc=rjw@rjwysocki.net \
--cc=sdonthineni@nvidia.com \
--subject='Re: [PATCH v10 8/8] PCI: Change the type of probe argument in reset functions' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).