LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH 1/3] staging: r8188eu: rename odm_EVMdbToPercentage()
@ 2021-07-30 9:09 Michael Straube
2021-07-30 9:09 ` [PATCH 2/3] staging: r8188eu: rename parameter of odm_evm_db_to_percentage() Michael Straube
2021-07-30 9:09 ` [PATCH 3/3] staging: r8188eu: simplify odm_evm_db_to_percentage() Michael Straube
0 siblings, 2 replies; 3+ messages in thread
From: Michael Straube @ 2021-07-30 9:09 UTC (permalink / raw)
To: gregkh; +Cc: Larry.Finger, phil, linux-staging, linux-kernel, Michael Straube
Rename odm_EVMdbToPercentage() to avoid camel case.
odm_EVMdbToPercentage() -> odm_evm_db_to_percentage()
Signed-off-by: Michael Straube <straube.linux@gmail.com>
---
drivers/staging/r8188eu/hal/odm_HWConfig.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/r8188eu/hal/odm_HWConfig.c b/drivers/staging/r8188eu/hal/odm_HWConfig.c
index 4c9317833fbc..6afe3f9bc47c 100644
--- a/drivers/staging/r8188eu/hal/odm_HWConfig.c
+++ b/drivers/staging/r8188eu/hal/odm_HWConfig.c
@@ -77,7 +77,7 @@ static u8 odm_SQ_process_patch_RT_CID_819x_Lenovo(struct odm_dm_struct *dm_odm,
return 0;
}
-static u8 odm_EVMdbToPercentage(s8 Value)
+static u8 odm_evm_db_to_percentage(s8 Value)
{
/* -33dB~0dB to 0%~99% */
s8 ret_val;
@@ -338,7 +338,7 @@ static void odm_RxPhyStatus92CSeries_Parsing(struct odm_dm_struct *dm_odm,
/* Do not use shift operation like "rx_evmX >>= 1" because the compilor of free build environment */
/* fill most significant bit to "zero" when doing shifting operation which may change a negative */
/* value to positive one, then the dbm value (which is supposed to be negative) is not correct anymore. */
- EVM = odm_EVMdbToPercentage((pPhyStaRpt->stream_rxevm[i])); /* dbm */
+ EVM = odm_evm_db_to_percentage((pPhyStaRpt->stream_rxevm[i])); /* dbm */
if (pPktinfo->bPacketMatchBSSID) {
if (i == RF_PATH_A) /* Fill value in RFD, Get the first spatial stream only */
--
2.32.0
^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH 2/3] staging: r8188eu: rename parameter of odm_evm_db_to_percentage()
2021-07-30 9:09 [PATCH 1/3] staging: r8188eu: rename odm_EVMdbToPercentage() Michael Straube
@ 2021-07-30 9:09 ` Michael Straube
2021-07-30 9:09 ` [PATCH 3/3] staging: r8188eu: simplify odm_evm_db_to_percentage() Michael Straube
1 sibling, 0 replies; 3+ messages in thread
From: Michael Straube @ 2021-07-30 9:09 UTC (permalink / raw)
To: gregkh; +Cc: Larry.Finger, phil, linux-staging, linux-kernel, Michael Straube
Rename parameter of odm_evm_db_to_percentage() to avoid camel case.
Value -> value
Signed-off-by: Michael Straube <straube.linux@gmail.com>
---
drivers/staging/r8188eu/hal/odm_HWConfig.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/r8188eu/hal/odm_HWConfig.c b/drivers/staging/r8188eu/hal/odm_HWConfig.c
index 6afe3f9bc47c..51ae02805149 100644
--- a/drivers/staging/r8188eu/hal/odm_HWConfig.c
+++ b/drivers/staging/r8188eu/hal/odm_HWConfig.c
@@ -77,12 +77,12 @@ static u8 odm_SQ_process_patch_RT_CID_819x_Lenovo(struct odm_dm_struct *dm_odm,
return 0;
}
-static u8 odm_evm_db_to_percentage(s8 Value)
+static u8 odm_evm_db_to_percentage(s8 value)
{
/* -33dB~0dB to 0%~99% */
s8 ret_val;
- ret_val = Value;
+ ret_val = value;
if (ret_val >= 0)
ret_val = 0;
--
2.32.0
^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH 3/3] staging: r8188eu: simplify odm_evm_db_to_percentage()
2021-07-30 9:09 [PATCH 1/3] staging: r8188eu: rename odm_EVMdbToPercentage() Michael Straube
2021-07-30 9:09 ` [PATCH 2/3] staging: r8188eu: rename parameter of odm_evm_db_to_percentage() Michael Straube
@ 2021-07-30 9:09 ` Michael Straube
1 sibling, 0 replies; 3+ messages in thread
From: Michael Straube @ 2021-07-30 9:09 UTC (permalink / raw)
To: gregkh; +Cc: Larry.Finger, phil, linux-staging, linux-kernel, Michael Straube
Use clamp() to simplify odm_evm_db_to_percentage().
Signed-off-by: Michael Straube <straube.linux@gmail.com>
---
When this driver will be moved to drivers/net/wireless/realtek/rtlwifi
(if that's the plan?) the odm_evm_db_to_percentage() function could be
replaced by the generic version rtl_evm_db_to_percentage() from
drivers/net/wireless/realtek/rtlwifi/stats.c
drivers/staging/r8188eu/hal/odm_HWConfig.c | 13 ++-----------
1 file changed, 2 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/r8188eu/hal/odm_HWConfig.c b/drivers/staging/r8188eu/hal/odm_HWConfig.c
index 51ae02805149..19222c0eddf7 100644
--- a/drivers/staging/r8188eu/hal/odm_HWConfig.c
+++ b/drivers/staging/r8188eu/hal/odm_HWConfig.c
@@ -80,20 +80,11 @@ static u8 odm_SQ_process_patch_RT_CID_819x_Lenovo(struct odm_dm_struct *dm_odm,
static u8 odm_evm_db_to_percentage(s8 value)
{
/* -33dB~0dB to 0%~99% */
- s8 ret_val;
-
- ret_val = value;
-
- if (ret_val >= 0)
- ret_val = 0;
- if (ret_val <= -33)
- ret_val = -33;
-
- ret_val = 0 - ret_val;
- ret_val *= 3;
+ s8 ret_val = clamp(-value, 0, 33) * 3;
if (ret_val == 99)
ret_val = 100;
+
return ret_val;
}
--
2.32.0
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2021-07-30 9:10 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-30 9:09 [PATCH 1/3] staging: r8188eu: rename odm_EVMdbToPercentage() Michael Straube
2021-07-30 9:09 ` [PATCH 2/3] staging: r8188eu: rename parameter of odm_evm_db_to_percentage() Michael Straube
2021-07-30 9:09 ` [PATCH 3/3] staging: r8188eu: simplify odm_evm_db_to_percentage() Michael Straube
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).