LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: Amey Narkhede <ameynarkhede03@gmail.com>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
	alex.williamson@redhat.com,
	Raphael Norwitz <raphael.norwitz@nutanix.com>,
	linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
	kw@linux.com, Shanker Donthineni <sdonthineni@nvidia.com>,
	Sinan Kaya <okaya@kernel.org>, Len Brown <lenb@kernel.org>,
	"Rafael J . Wysocki" <rjw@rjwysocki.net>
Subject: Re: [PATCH v13 9/9] PCI: Change the type of probe argument in reset functions
Date: Mon, 2 Aug 2021 17:59:11 -0500	[thread overview]
Message-ID: <20210802225911.GA1473016@bjorn-Precision-5520> (raw)
In-Reply-To: <20210801142518.1224-10-ameynarkhede03@gmail.com>

On Sun, Aug 01, 2021 at 07:55:18PM +0530, Amey Narkhede wrote:
> Change the type of probe argument in functions which implement reset
> methods from int to bool to make the context and intent clear.
> 
> Suggested-by: Alex Williamson <alex.williamson@redhat.com>
> Suggested-by: Krzysztof Wilczyński <kw@linux.com>
> Signed-off-by: Amey Narkhede <ameynarkhede03@gmail.com>
> ---
>  drivers/crypto/cavium/nitrox/nitrox_main.c    |  2 +-
>  .../ethernet/cavium/liquidio/lio_vf_main.c    |  2 +-
>  drivers/pci/hotplug/pciehp.h                  |  2 +-
>  drivers/pci/hotplug/pciehp_hpc.c              |  4 +-
>  drivers/pci/hotplug/pnv_php.c                 |  4 +-
>  drivers/pci/pci-acpi.c                        |  7 +-
>  drivers/pci/pci.c                             | 69 ++++++++++---------
>  drivers/pci/pci.h                             | 12 ++--
>  drivers/pci/pcie/aer.c                        |  2 +-
>  drivers/pci/quirks.c                          | 34 ++++-----
>  include/linux/pci.h                           |  5 +-
>  include/linux/pci_hotplug.h                   |  2 +-
>  12 files changed, 75 insertions(+), 70 deletions(-)
> 
> diff --git a/drivers/crypto/cavium/nitrox/nitrox_main.c b/drivers/crypto/cavium/nitrox/nitrox_main.c
> index 15d6c8452807..f97fa8e997b5 100644
> --- a/drivers/crypto/cavium/nitrox/nitrox_main.c
> +++ b/drivers/crypto/cavium/nitrox/nitrox_main.c
> @@ -306,7 +306,7 @@ static int nitrox_device_flr(struct pci_dev *pdev)
>  		return -ENOMEM;
>  	}
>  
> -	pcie_reset_flr(pdev, 0);
> +	pcie_reset_flr(pdev, PCI_RESET_DO_RESET);
>  
>  	pci_restore_state(pdev);
>  
> diff --git a/drivers/net/ethernet/cavium/liquidio/lio_vf_main.c b/drivers/net/ethernet/cavium/liquidio/lio_vf_main.c
> index 336d149ee2e2..6e666be6907a 100644
> --- a/drivers/net/ethernet/cavium/liquidio/lio_vf_main.c
> +++ b/drivers/net/ethernet/cavium/liquidio/lio_vf_main.c
> @@ -526,7 +526,7 @@ static void octeon_destroy_resources(struct octeon_device *oct)
>  			oct->irq_name_storage = NULL;
>  		}
>  		/* Soft reset the octeon device before exiting */
> -		if (!pcie_reset_flr(oct->pci_dev, 1))
> +		if (!pcie_reset_flr(oct->pci_dev, PCI_RESET_PROBE))
>  			octeon_pci_flr(oct);
>  		else
>  			cn23xx_vf_ask_pf_to_do_flr(oct);
> diff --git a/drivers/pci/hotplug/pciehp.h b/drivers/pci/hotplug/pciehp.h
> index 4fd200d8b0a9..f12e1ef9f183 100644
> --- a/drivers/pci/hotplug/pciehp.h
> +++ b/drivers/pci/hotplug/pciehp.h
> @@ -181,7 +181,7 @@ void pciehp_release_ctrl(struct controller *ctrl);
>  
>  int pciehp_sysfs_enable_slot(struct hotplug_slot *hotplug_slot);
>  int pciehp_sysfs_disable_slot(struct hotplug_slot *hotplug_slot);
> -int pciehp_reset_slot(struct hotplug_slot *hotplug_slot, int probe);
> +int pciehp_reset_slot(struct hotplug_slot *hotplug_slot, bool mode);

Changing this to bool is ok, but I think changing the name from
"probe" to "mode" makes it worse.  It makes sense that "probe == true"
means do a probe instead of a reset, but "mode == true" tells me
nothing.

Bjorn

      reply	other threads:[~2021-08-02 22:59 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-01 14:25 [PATCH v13 0/9] PCI: Expose and manage PCI device reset Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 1/9] PCI: Cache PCIe FLR capability Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 2/9] PCI: Add pcie_reset_flr to follow calling convention of other reset methods Amey Narkhede
2021-08-01 17:04   ` kernel test robot
2021-08-01 17:05   ` [RFC PATCH] PCI: pcie_has_flr() can be static kernel test robot
2021-08-01 18:17   ` [PATCH v13 2/9] PCI: Add pcie_reset_flr to follow calling convention of other reset methods kernel test robot
2021-08-02 22:44   ` Bjorn Helgaas
2021-08-03  4:49     ` Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 3/9] PCI: Add new array for keeping track of ordering of " Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 4/9] PCI: Remove reset_fn field from pci_dev Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 5/9] PCI: Allow userspace to query and set device reset mechanism Amey Narkhede
2021-08-02 22:55   ` Bjorn Helgaas
2021-08-03  6:34     ` Amey Narkhede
2021-08-03 13:45   ` Shanker R Donthineni
2021-08-01 14:25 ` [PATCH v13 6/9] PCI: Define a function to set ACPI_COMPANION in pci_dev Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 7/9] PCI: Setup ACPI fwnode early and at the same time with OF Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 8/9] PCI: Add support for ACPI _RST reset method Amey Narkhede
2021-08-01 14:25 ` [PATCH v13 9/9] PCI: Change the type of probe argument in reset functions Amey Narkhede
2021-08-02 22:59   ` Bjorn Helgaas [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210802225911.GA1473016@bjorn-Precision-5520 \
    --to=helgaas@kernel.org \
    --cc=alex.williamson@redhat.com \
    --cc=ameynarkhede03@gmail.com \
    --cc=bhelgaas@google.com \
    --cc=kw@linux.com \
    --cc=lenb@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=okaya@kernel.org \
    --cc=raphael.norwitz@nutanix.com \
    --cc=rjw@rjwysocki.net \
    --cc=sdonthineni@nvidia.com \
    --subject='Re: [PATCH v13 9/9] PCI: Change the type of probe argument in reset functions' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
on how to clone and mirror all data and code used for this inbox