LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Ian Abbott <abbotti@mev.co.uk>
To: Chris Opperman <eklikeroomys@gmail.com>
Cc: H Hartley Sweeten <hsweeten@visionengravers.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Simo Koskinen <koskisoft@gmail.com>,
Frank Mori Hess <fmh6jj@gmail.com>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.
Date: Wed, 13 Jun 2018 13:01:35 +0100 [thread overview]
Message-ID: <202d1efe-fcd4-1155-ad80-f44a2345dc97@mev.co.uk> (raw)
In-Reply-To: <1528837793-11765-1-git-send-email-eklikeroomys@gmail.com>
On 12/06/18 22:09, Chris Opperman wrote:
> Changes since v3:
> a) Reverted u64 to unsigned long long and u32 to unsigned int.
> b) Added patch versioning.
> c) Changed type of scans_left to unsigned long long to avoid cast.
> d) Clarified and updated changelog.
>
>> 8-----------------------------------------------------------------------8<
>
> Improve readability of comedi_nsamples_left:
> a) Reduce nesting by using more return statements.
> b) Declare variables scans_left and samples_left at start of function.
> c) Change type of scans_Left to unsigned long long to avoid cast.
>
> Signed-off-by: Chris Opperman <eklikeroomys@gmail.com>
> ---
> drivers/staging/comedi/drivers.c | 26 +++++++++++++-------------
> 1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c
> index 9d73347..57dd63d 100644
> --- a/drivers/staging/comedi/drivers.c
> +++ b/drivers/staging/comedi/drivers.c
> @@ -473,21 +473,21 @@ unsigned int comedi_nsamples_left(struct comedi_subdevice *s,
> {
> struct comedi_async *async = s->async;
> struct comedi_cmd *cmd = &async->cmd;
> + unsigned long long scans_left;
> + unsigned long long samples_left;
>
> - if (cmd->stop_src == TRIG_COUNT) {
> - unsigned int scans_left = __comedi_nscans_left(s, cmd->stop_arg);
> - unsigned int scan_pos =
> - comedi_bytes_to_samples(s, async->scan_progress);
> - unsigned long long samples_left = 0;
> -
> - if (scans_left) {
> - samples_left = ((unsigned long long)scans_left *
> - cmd->scan_end_arg) - scan_pos;
> - }
> + if (cmd->stop_src != TRIG_COUNT)
> + return nsamples;
>
> - if (samples_left < nsamples)
> - nsamples = samples_left;
> - }
> + scans_left = __comedi_nscans_left(s, cmd->stop_arg);
> + if (!scans_left)
> + return 0;
> +
> + samples_left = scans_left * cmd->scan_end_arg -
> + comedi_bytes_to_samples(s, async->scan_progress);
> +
> + if (samples_left < nsamples)
> + return samples_left;
> return nsamples;
> }
> EXPORT_SYMBOL_GPL(comedi_nsamples_left);
> --
> 2.1.4
>
The code changes look fine. You just need to correct the commit
message, as pointed out by Dan Carpenter.
For reference, everything below the "---" cut-off line gets stripped out
of the commit message in the git repository, so that is a good place to
add comments about the patch itself (such as change logs) that do not
belong in the commit message.
--
-=( Ian Abbott <abbotti@mev.co.uk> || Web: www.mev.co.uk )=-
-=( MEV Ltd. is a company registered in England & Wales. )=-
-=( Registered number: 02862268. Registered address: )=-
-=( 15 West Park Road, Bramhall, STOCKPORT, SK7 3JZ, UK. )=-
prev parent reply other threads:[~2018-06-13 12:06 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-12 21:09 [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left Chris Opperman
2018-06-13 9:29 ` Dan Carpenter
2018-06-13 18:26 ` Chris Opperman
2018-06-13 17:33 ` Ian Abbott
2018-06-13 19:05 ` Dan Carpenter
2018-06-14 11:08 ` Ian Abbott
2018-06-14 16:18 ` Chris Opperman
2018-06-13 12:01 ` Ian Abbott [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=202d1efe-fcd4-1155-ad80-f44a2345dc97@mev.co.uk \
--to=abbotti@mev.co.uk \
--cc=devel@driverdev.osuosl.org \
--cc=eklikeroomys@gmail.com \
--cc=fmh6jj@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=hsweeten@visionengravers.com \
--cc=koskisoft@gmail.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).