LKML Archive on
help / color / mirror / Atom feed
From: "Condor" <>
To: "Kasper Sandberg" <>
Subject: Re: PROBLEM: writting files > 100 MB in FAT32
Date: Thu, 18 Jan 2007 16:41:45 +0200 (EET)	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <1169123236.12968.6.camel@localhost>

> On Thu, 2007-01-18 at 11:22 +0200, Condor wrote:
>> Hello,
>> [1.] Files if > 100 MB saving in USB memory stick 4 GB with FAT32. While
>> saving all files is broken.
> im sorry, i do not understand this.
> you are saying that if you copy files larger than 100mb into drive, all
> files die?

No, only file when i copy is die.

>> [2.] I have USB memory stick A-DATA 4 GB with FAT32. When i trying to
>> save
>> files in my USB and files is > of 100 MB, all files that i save is
>> broken.
>> I put my USB in my laptop and mount it as: mount /dev/sda1 /mnt/usb-win
>> While i mount it, i got in my local disk and copy one file that is 520
>> MB.
>> The file is copying very slow (10 min). and after i see again my console
>> i
>> wait light to my usb is off and i unmount it as: umount /mnt/usb-win
>> I get my USB stick and when i return to home i trying to copy file from
>> my
>> USB to my windows and linux. Both OS unable to read file.
>> After some tryings i format my USB in FAT16 and now every thing is work
>> fine. I copy files to my USB and back to my hard drive and all files
>> work
>> fine.
> okay, i think thats what you are saying, could you please try to run
> dosfsck on it so we can see 100% whats wrong?

Yes, i run and it found error, i also run in windows scan drive, also
found errors. I't correct them and i make test again. After copy file
(unmount, sync ... ) i insert adapter again in windows and again unable to
copy file from usb to windows (linux say may be missing sectors, mount it
with read-only), run scan drive from windows and windows again found lost

> also, try to do this:
> mount, copy, run command 'sync', unmount, pull out, and see if it works.

Yes this is that i make.

> finally, one more question. you said it does not work when you take it
> home, can you try this: mount, copy, unmount, mount, check to see if
> file works.

Yes i try one of the times and linux say may be sda1 have missing sectors
mount it with read-only.

>> [3.] lsmod
>> # lsmod
> <snip>
>> nvidia               4709172  22
> ohh, tainted ;P naughty. Though i dont think this affects vfat.
> <snip>
>> Regards,
>> Condor
>> -
>> To unsubscribe from this list: send the line "unsubscribe linux-kernel"
>> in
>> the body of a message to
>> More majordomo info at
>> Please read the FAQ at

I no longer can make tests because i remove my fat32 from my usb stick and
i put it in to FAT16 and i make the exact tests and file is worked but on
fat16 not in fat32. I just report the problem, to be investigate from
kernel developers.


  parent reply	other threads:[~2007-01-18 14:41 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-01-18  9:22 Condor
2007-01-18 12:27 ` Kasper Sandberg
2007-01-18 12:30   ` Jan Engelhardt
2007-01-18 14:41   ` Condor [this message]
2007-01-18 15:08     ` OGAWA Hirofumi
2007-01-19 12:32       ` Condor
2007-01-19 16:11         ` OGAWA Hirofumi
2007-01-20 15:30           ` Condor

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \
    --subject='Re: PROBLEM: writting files > 100 MB in FAT32' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).