LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* weird problem with hdb=scsi
@ 2001-10-09  4:12 Jordan Breeding
  0 siblings, 0 replies; only message in thread
From: Jordan Breeding @ 2001-10-09  4:12 UTC (permalink / raw)
  To: Linux Kernel

I am seeing a weird problem where if I set an ATAPI Zip 250 to be
ide-scsi using hdb=scsi at boot time everything works once booted into
multiuser but the initial partition check still tries to check the drive
as though it were being controlled by ide drivers.  Here is the
pertinent dmesg section:

== BEGIN OUTPUT ==
hda: IBM-DTLA-307075, ATA DISK drive
hdb: IOMEGA ZIP 250 ATAPI, ATAPI FLOPPY drive
hdc: KENWOOD CD-ROM UCR-421 V226G, ATAPI CD/DVD-ROM drive
hdd: PLEXTOR CD-R PX-W1210A, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 150136560 sectors (76870 MB) w/1916KiB Cache, CHS=73308/64/32,
UDMA(100)
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 < p5 p6 p7 p8 p9 p10 p11
>
 hdb:<3>ide-scsi: hdb: unsupported command in request queue (0)
end_request: I/O error, dev 03:40 (hdb), sector 0
 unable to read partition table
... SNIPPED ...
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: IOMEGA    Model: ZIP 250           Rev: 51.G
  Type:   Direct-Access                      ANSI SCSI revision: 00
  Vendor: KENWOOD   Model: CD-ROM UCR-421    Rev: 226G
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: PLEXTOR   Model: CD-R   PX-W1210A  Rev: 1.08
  Type:   CD-ROM                             ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 196608 512-byte hdwr sectors (101 MB)
sda: Write Protect is off
 /dev/scsi/host0/bus0/target0/lun0: p1
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 1, lun 0
Attached scsi CD-ROM sr1 at scsi0, channel 0, id 2, lun 0
sr0: scsi3-mmc drive: 68x/68x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12
sr1: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
== END OUTPUT ==

Why does the ide subsystem not ignore drives which are being controlled
by <drive>=scsi during partition check since the SCSI subsystem is now
going to handle partition checks for that drive?  Thanks for any
information.

Jordan Breeding

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2001-10-09  4:12 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2001-10-09  4:12 weird problem with hdb=scsi Jordan Breeding

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).